JRemote: Class List

JRemote 0.1.0
  • Main Page
  • Classes
  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12345678910]
▼N org
▼N pcsoft
▼N framework
▼N jremote
▼N api
▼N exception
C JRemoteAnnotationException
C JRemoteConfigurationException
C JRemoteException
C JRemoteExecutionException
▼N type
C EventReceivedListener
C ObserverListenerType
C PushChangedListener
C PushItemUpdate
C PushMethodType
C RemoteListener
C Control
C Event
C EventReceiverListener
C Push
C PushModelProperty
C PushObserverListener
C RemoteControlService
C RemoteEventReceiver
C RemoteEventService
C RemotePushModel
C RemotePushObserver
C RemotePushService
▼N commons
C AnnotationUtils
C ReflectionUtils
▼N core
C Client
C ClientState
C Remote
C RemoteBuilder
▼C RemoteClient
C ControlManager
C DataManager
C RemoteClientBuilder
▼C RemoteServer
C BroadcastManager
C RemoteServerBuilder
C ServerState
C State
▼N np
▼N api
▼N annotation
C KeepAlive
▼C Registration
C RegistrationType
C RemoteKeepAliveService
C RemoteRegistrationService
C Client
C ClientBase
C NetworkProtocolPlugin
C Service
C ServiceBase
▼N impl
▼N rmi
▼N interf
C RmiKeepAliveService
C RmiRegistrationService
C RmiClient
C RmiPlugin
C RmiService
▼N tcp
▼N internal
▼N type
C Invocation
C Type
C TcpServer
C TcpClient
C TcpPlugin
C TcpService
Generated by doxygen 1.8.10


JRemote: org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • exception
  • JRemoteAnnotationException
Public Member Functions | List of all members
org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException:
org.pcsoft.framework.jremote.api.exception.JRemoteException

Public Member Functions

JRemoteAnnotationException (String message)
JRemoteAnnotationException (String message, Throwable cause)
JRemoteAnnotationException (Throwable cause)
- Public Member Functions inherited from org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException (String message)
JRemoteException (String message, Throwable cause)
JRemoteException (Throwable cause)
The documentation for this class was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/exception/JRemoteAnnotationException.java


JRemote: org.pcsoft.framework.jremote.api.exception.JRemoteConfigurationException Class Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • exception
  • JRemoteConfigurationException
Public Member Functions | List of all members
org.pcsoft.framework.jremote.api.exception.JRemoteConfigurationException Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.api.exception.JRemoteConfigurationException:
org.pcsoft.framework.jremote.api.exception.JRemoteException

Public Member Functions

JRemoteConfigurationException (String message)
JRemoteConfigurationException (String message, Throwable cause)
JRemoteConfigurationException (Throwable cause)
- Public Member Functions inherited from org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException (String message)
JRemoteException (String message, Throwable cause)
JRemoteException (Throwable cause)
The documentation for this class was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/exception/JRemoteConfigurationException.java


JRemote: org.pcsoft.framework.jremote.api.exception.JRemoteException Class Reference

  • framework
  • jremote
  • api
  • exception
  • JRemoteException
Public Member Functions | List of all members
org.pcsoft.framework.jremote.api.exception.JRemoteException Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.api.exception.JRemoteException:
org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException org.pcsoft.framework.jremote.api.exception.JRemoteConfigurationException org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException

Public Member Functions

JRemoteException (String message)
JRemoteException (String message, Throwable cause)
JRemoteException (Throwable cause)
The documentation for this class was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/exception/JRemoteException.java


JRemote: org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException Class Reference

  • api
  • exception
  • JRemoteExecutionException
Public Member Functions | List of all members
org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException:
org.pcsoft.framework.jremote.api.exception.JRemoteException

Public Member Functions

JRemoteExecutionException (String message)
JRemoteExecutionException (String message, Throwable cause)
JRemoteExecutionException (Throwable cause)
- Public Member Functions inherited from org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException (String message)
JRemoteException (String message, Throwable cause)
JRemoteException (Throwable cause)
The documentation for this class was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/exception/JRemoteExecutionException.java


JRemote: org.pcsoft.framework.jremote.api.type.EventReceivedListener< T > Interface Template Reference

  • api
  • type
  • EventReceivedListener
Public Member Functions | List of all members
org.pcsoft.framework.jremote.api.type.EventReceivedListener< T > Interface Template Reference
Inheritance diagram for org.pcsoft.framework.jremote.api.type.EventReceivedListener< T >:
org.pcsoft.framework.jremote.api.type.RemoteListener

Public Member Functions

void onChange (T value)

Detailed Description

Functional interface for the event observer listener method(s) to observe data from org.pcsoft.framework.jremote.api.RemoteEventService. Method with this parameter must be annotated with EventReceiverListener.

Member Function Documentation

void org.pcsoft.framework.jremote.api.type.EventReceivedListener< T >.onChange ( T value )

Is called if the linked event is called, see EventReceiverListener

Parameters
value New event value was received from org.pcsoft.framework.jremote.api.RemoteEventService
The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/type/EventReceivedListener.java


JRemote: org.pcsoft.framework.jremote.api.type.ObserverListenerType Enum Reference

  • api
  • type
  • ObserverListenerType
Public Attributes | List of all members
org.pcsoft.framework.jremote.api.type.ObserverListenerType Enum Reference

Public Attributes

AutoDetection
Add
Remove

Detailed Description

Type of observer listener

Member Data Documentation

org.pcsoft.framework.jremote.api.type.ObserverListenerType.Add

Mark as 'add' listener method

org.pcsoft.framework.jremote.api.type.ObserverListenerType.AutoDetection

Automatic detection via start with 'add' or 'remove' (default)

org.pcsoft.framework.jremote.api.type.ObserverListenerType.Remove

Mark as 'remove' listener method

The documentation for this enum was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/type/ObserverListenerType.java


JRemote: org.pcsoft.framework.jremote.api.type.PushChangedListener Interface Reference

  • api
  • type
  • PushChangedListener
Public Member Functions | List of all members
org.pcsoft.framework.jremote.api.type.PushChangedListener Interface Reference
Inheritance diagram for org.pcsoft.framework.jremote.api.type.PushChangedListener:
org.pcsoft.framework.jremote.api.type.RemoteListener

Public Member Functions

void onChange ()

Detailed Description

Functional interface for the push observer listener method(s) to observe data changes in org.pcsoft.framework.jremote.api.RemotePushModel from org.pcsoft.framework.jremote.api.RemotePushService. Method with this parameter must be annotated with org.pcsoft.framework.jremote.api.PushObserverListener.

Member Function Documentation

void org.pcsoft.framework.jremote.api.type.PushChangedListener.onChange ( )

Is called if the linked value has changed, see org.pcsoft.framework.jremote.api.PushObserverListener

The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/type/PushChangedListener.java


JRemote: org.pcsoft.framework.jremote.api.type.PushItemUpdate Enum Reference

  • api
  • type
  • PushItemUpdate
Public Attributes | List of all members
org.pcsoft.framework.jremote.api.type.PushItemUpdate Enum Reference

Public Attributes

Add
Update
Remove
The documentation for this enum was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/type/PushItemUpdate.java


JRemote: org.pcsoft.framework.jremote.api.type.PushMethodType Enum Reference

  • api
  • type
  • PushMethodType
Public Attributes | List of all members
org.pcsoft.framework.jremote.api.type.PushMethodType Enum Reference

Public Attributes

Default
SingleListItem

Detailed Description

Type of push method

Member Data Documentation

org.pcsoft.framework.jremote.api.type.PushMethodType.Default

A default field is pushed / updated (contains complete list and array updates)

org.pcsoft.framework.jremote.api.type.PushMethodType.SingleListItem

A single item of a list / array is pushed / updated

The documentation for this enum was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/type/PushMethodType.java


JRemote: org.pcsoft.framework.jremote.api.type.RemoteListener Interface Reference

  • api
  • type
  • RemoteListener
org.pcsoft.framework.jremote.api.type.RemoteListener Interface Reference
Inheritance diagram for org.pcsoft.framework.jremote.api.type.RemoteListener:
org.pcsoft.framework.jremote.api.type.EventReceivedListener< T > org.pcsoft.framework.jremote.api.type.PushChangedListener

Detailed Description

Marker interface for a changed listener

The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/type/RemoteListener.java


JRemote: org.pcsoft.framework.jremote.api.Control Interface Reference

  • api
  • Control
org.pcsoft.framework.jremote.api.Control Interface Reference

Detailed Description

Annotation to mark a method in a RemoteControlService as a control method

The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/Control.java


JRemote: org.pcsoft.framework.jremote.api.Event Interface Reference

  • api
  • Event
Public Member Functions | List of all members
org.pcsoft.framework.jremote.api.Event Interface Reference

Public Member Functions

String | event ()
Class<?> | eventClass ()

Detailed Description

Mark a method in an interface as event method. Interface must be annotated with RemoteEventService.

Member Function Documentation

String org.pcsoft.framework.jremote.api.Event.event ( )

The name of the event in RemoteEventReceiver to deliver to, see EventReceiverListener#value()

Returns
Class<?> org.pcsoft.framework.jremote.api.Event.eventClass ( )

The class of RemoteEventReceiver within the event() to deliver to, see EventReceiverListener

Returns
The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/Event.java


JRemote: org.pcsoft.framework.jremote.api.EventReceiverListener Interface Reference

  • api
  • EventReceiverListener
Public Member Functions | List of all members
org.pcsoft.framework.jremote.api.EventReceiverListener Interface Reference

Public Member Functions

String | value ()
ObserverListenerType | listenerType () default ObserverListenerType.AutoDetection

Detailed Description

Mark a method in an interface as listener method for a event call, see RemoteEventService. Interface must be annotated with RemoteEventReceiver.

The method signature must build with a void return type and one argument of type EventReceivedListener:
void addListener(EventReceivedListener<?> l)

Member Function Documentation

ObserverListenerType org.pcsoft.framework.jremote.api.EventReceiverListener.listenerType ( )

Setup the type of listener method like 'add' or 'remove' (Default is ObserverListenerType#AutoDetection)

Returns
String org.pcsoft.framework.jremote.api.EventReceiverListener.value ( )

The name of this event to receive from RemoteEventService, see Event

Returns
The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/EventReceiverListener.java


JRemote: org.pcsoft.framework.jremote.api.Push Interface Reference

  • api
  • Push
Public Member Functions | List of all members
org.pcsoft.framework.jremote.api.Push Interface Reference

Public Member Functions

String | property ()
Class<?> | modelClass ()
PushMethodType | type () default PushMethodType.Default

Detailed Description

Mark a method in an interface as push method. Interface must be annotated with RemotePushService.

Member Function Documentation

Class<?> org.pcsoft.framework.jremote.api.Push.modelClass ( )

The class of the RemotePushModel within the property() the observer listener listen to, see PushModelProperty

Returns
String org.pcsoft.framework.jremote.api.Push.property ( )

The name of the RemotePushModel property the observer listener listen to, see PushModelProperty#value()

Returns
PushMethodType org.pcsoft.framework.jremote.api.Push.type ( )

Type of push update, see PushMethodType for more information.

Returns
The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/Push.java


JRemote: org.pcsoft.framework.jremote.api.PushModelProperty Interface Reference

  • api
  • PushModelProperty
Public Member Functions | List of all members
org.pcsoft.framework.jremote.api.PushModelProperty Interface Reference

Public Member Functions

String value ()

Detailed Description

Mark a getter method in an interface as model based property. The interface must be annotated with RemotePushModel.

Member Function Documentation

String org.pcsoft.framework.jremote.api.PushModelProperty.value ( )

The name of the model property. Used for referencing from RemotePushService or RemotePushObserver class, see Push or PushObserverListener

Returns
The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/PushModelProperty.java


JRemote: org.pcsoft.framework.jremote.api.PushObserverListener Interface Reference

  • api
  • PushObserverListener
Public Member Functions | List of all members
org.pcsoft.framework.jremote.api.PushObserverListener Interface Reference

Public Member Functions

String | property ()
Class<?> | modelClass ()
ObserverListenerType | listenerType () default ObserverListenerType.AutoDetection

Detailed Description

Mark a method in an interface as listener method for a push call, see RemotePushService. Interface must be annotated with RemotePushObserver.

The method signature must build with a void return type and one argument of type PushChangedListener:
void addListener(PushChangedListener l)

Member Function Documentation

ObserverListenerType org.pcsoft.framework.jremote.api.PushObserverListener.listenerType ( )

Setup the type of listener method like 'add' or 'remove' (Default is ObserverListenerType#AutoDetection)

Returns
Class<?> org.pcsoft.framework.jremote.api.PushObserverListener.modelClass ( )

The class of the RemotePushModel within the property() the observer listener listen to, see PushModelProperty

Returns
String org.pcsoft.framework.jremote.api.PushObserverListener.property ( )

The name of the RemotePushModel property the observer listener listen to, see PushModelProperty#value()

Returns
The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/PushObserverListener.java


JRemote: org.pcsoft.framework.jremote.api.RemoteControlService Interface Reference

  • api
  • RemoteControlService
org.pcsoft.framework.jremote.api.RemoteControlService Interface Reference

Detailed Description

Mark an interface as remote control service. That controls the server. See Control

The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/RemoteControlService.java


JRemote: org.pcsoft.framework.jremote.api.RemoteEventReceiver Interface Reference

  • api
  • RemoteEventReceiver
org.pcsoft.framework.jremote.api.RemoteEventReceiver Interface Reference

Detailed Description

Mark an interface as remote observer for observing data via event methods (RemoteEventService), see EventReceiverListener.

The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/RemoteEventReceiver.java


JRemote: org.pcsoft.framework.jremote.api.RemoteEventService Interface Reference

  • api
  • RemoteEventService
org.pcsoft.framework.jremote.api.RemoteEventService Interface Reference

Detailed Description

Mark an interface as remote event service to push data via RemotePushObserver, see Event

The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/RemoteEventService.java


JRemote: org.pcsoft.framework.jremote.api.RemotePushModel Interface Reference

  • api
  • RemotePushModel
org.pcsoft.framework.jremote.api.RemotePushModel Interface Reference

Detailed Description

Mark an interface as remote model. In it all pushes (RemotePushService) are stored in defined properties, see PushModelProperty.

The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/RemotePushModel.java


JRemote: org.pcsoft.framework.jremote.api.RemotePushObserver Interface Reference

  • api
  • RemotePushObserver
org.pcsoft.framework.jremote.api.RemotePushObserver Interface Reference

Detailed Description

Mark an interface as remote observer for observing RemotePushModel via push methods (RemotePushService), see PushObserverListener.

The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/RemotePushObserver.java


JRemote: org.pcsoft.framework.jremote.api.RemotePushService Interface Reference

  • api
  • RemotePushService
org.pcsoft.framework.jremote.api.RemotePushService Interface Reference

Detailed Description

Mark an interface as remote push service to push data into RemotePushModel and RemotePushObserver, see Push

The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/RemotePushService.java


JRemote: org.pcsoft.framework.jremote.commons.AnnotationUtils Class Reference

  • commons
  • AnnotationUtils
Static Public Member Functions | List of all members
org.pcsoft.framework.jremote.commons.AnnotationUtils Class Reference

Static Public Member Functions

static boolean | isRemoteService (Class<?> clazz)
static boolean | isRemoteMethod (Method method)
static boolean | isRemoteModel (Class<?> clazz)
static boolean | isModelProperty (Method method)
static List< Method > | getModelProperties (Class<?> clazz)
The documentation for this class was generated from the following file:
  • commons/src/main/java/org/pcsoft/framework/jremote/commons/AnnotationUtils.java


JRemote: org.pcsoft.framework.jremote.commons.ReflectionUtils Class Reference

  • commons
  • ReflectionUtils
Static Public Member Functions | List of all members
org.pcsoft.framework.jremote.commons.ReflectionUtils Class Reference

Static Public Member Functions

static List< Class<?> > | findInterfaces (Class<?> clazz)
static List< Class<?> > | findInterfaces (Class<?> clazz, Predicate< Class<?>> validator)
The documentation for this class was generated from the following file:
  • commons/src/main/java/org/pcsoft/framework/jremote/commons/ReflectionUtils.java


JRemote: org.pcsoft.framework.jremote.core.Client Class Reference

  • core
  • Client
Public Member Functions | List of all members
org.pcsoft.framework.jremote.core.Client Class Reference

Public Member Functions

Client (String host, int port)
String | getHost ()
int | getPort ()
The documentation for this class was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/Client.java


JRemote: org.pcsoft.framework.jremote.core.ClientState Enum Reference

  • core
  • ClientState
Public Attributes | List of all members
org.pcsoft.framework.jremote.core.ClientState Enum Reference
Inheritance diagram for org.pcsoft.framework.jremote.core.ClientState:
org.pcsoft.framework.jremote.core.State

Public Attributes

Unknown
Connected
Disconnected
The documentation for this enum was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/ClientState.java


JRemote: org.pcsoft.framework.jremote.core.Remote< S extends State > Interface Template Reference

  • core
  • Remote
Public Member Functions | List of all members
org.pcsoft.framework.jremote.core.Remote< S extends State > Interface Template Reference
Inheritance diagram for org.pcsoft.framework.jremote.core.Remote< S extends State >:

Public Member Functions

void | open () throws IOException
S | getState ()
void | addStateChangeListener (Consumer< S > l)
void | removeStateChangeListener (Consumer< S > l)
String | getHost ()
int | getPort ()
The documentation for this interface was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/Remote.java


JRemote: org.pcsoft.framework.jremote.core.RemoteBuilder< T extends Remote > Interface Template Reference

  • core
  • RemoteBuilder
Public Member Functions | List of all members
org.pcsoft.framework.jremote.core.RemoteBuilder< T extends Remote > Interface Template Reference

Public Member Functions

T build ()
The documentation for this interface was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/RemoteBuilder.java


JRemote: org.pcsoft.framework.jremote.core.RemoteClient Class Reference

  • core
  • RemoteClient
Classes | Public Member Functions | List of all members
org.pcsoft.framework.jremote.core.RemoteClient Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.core.RemoteClient:
org.pcsoft.framework.jremote.core.Remote< ClientState >

Classes

class | ControlManager
class | DataManager

Public Member Functions

DataManager | getData ()
ControlManager | getControl ()
UUID | getUuid ()
String | getHost ()
int | getPort ()
int | getOwnPort ()
void | open () throws IOException
void | close () throws Exception
ClientState | getState ()
void | addStateChangeListener (Consumer< ClientState > l)
void | removeStateChangeListener (Consumer< ClientState > l)
- Public Member Functions inherited from org.pcsoft.framework.jremote.core.Remote< ClientState >
void | open () throws IOException
S | getState ()
void | addStateChangeListener (Consumer< S > l)
void | removeStateChangeListener (Consumer< S > l)
String | getHost ()
int | getPort ()
The documentation for this class was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/RemoteClient.java


JRemote: org.pcsoft.framework.jremote.core.RemoteClient.ControlManager Class Reference

  • core
  • RemoteClient
  • ControlManager
List of all members
org.pcsoft.framework.jremote.core.RemoteClient.ControlManager Class Reference
The documentation for this class was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/RemoteClient.java


JRemote: org.pcsoft.framework.jremote.core.RemoteClient.DataManager Class Reference

  • core
  • RemoteClient
  • DataManager
List of all members
org.pcsoft.framework.jremote.core.RemoteClient.DataManager Class Reference
The documentation for this class was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/RemoteClient.java


JRemote: org.pcsoft.framework.jremote.core.RemoteClientBuilder Class Reference

  • core
  • RemoteClientBuilder
Public Member Functions | Static Public Member Functions | List of all members
org.pcsoft.framework.jremote.core.RemoteClientBuilder Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.core.RemoteClientBuilder:
org.pcsoft.framework.jremote.core.RemoteBuilder< RemoteClient >

Public Member Functions

final RemoteClientBuilder | withRemotePushModel (Class<?>...pushModelClasses)
final RemoteClientBuilder | withRemotePushObserver (Class<?>...pushObserverClasses)
final RemoteClientBuilder | withRemoteEventObserver (Class<?>...eventObserverClasses)
final RemoteClientBuilder | withRemotePushService (Class<?>...pushServiceClasses)
final RemoteClientBuilder | withRemoteEventService (Class<?>...eventServiceClasses)
final RemoteClientBuilder | withRemoteControlClient (Class<?>...controlClientClasses)
RemoteClient | build ()
- Public Member Functions inherited from org.pcsoft.framework.jremote.core.RemoteBuilder< RemoteClient >
T | build ()

Static Public Member Functions

static RemoteClientBuilder create (String host, int port, int ownPort)
The documentation for this class was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/RemoteClientBuilder.java


JRemote: org.pcsoft.framework.jremote.core.RemoteServer Class Reference

  • core
  • RemoteServer
Classes | Public Member Functions | List of all members
org.pcsoft.framework.jremote.core.RemoteServer Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.core.RemoteServer:
org.pcsoft.framework.jremote.core.Remote< ServerState >

Classes

class BroadcastManager

Public Member Functions

BroadcastManager | getBroadcast ()
Client[] | getConnectedClients ()
void | addClientRegisteredListener (Consumer< Client > l)
void | removeClientRegisteredListener (Consumer< Client > l)
void | addClientUnregisteredListener (Consumer< Client > l)
void | removeClientUnregisteredListener (Consumer< Client > l)
String | getHost ()
int | getPort ()
void | open () throws IOException
void | close () throws Exception
ServerState | getState ()
void | addStateChangeListener (Consumer< ServerState > l)
void | removeStateChangeListener (Consumer< ServerState > l)
- Public Member Functions inherited from org.pcsoft.framework.jremote.core.Remote< ServerState >
void | open () throws IOException
S | getState ()
void | addStateChangeListener (Consumer< S > l)
void | removeStateChangeListener (Consumer< S > l)
String | getHost ()
int | getPort ()
The documentation for this class was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/RemoteServer.java


JRemote: org.pcsoft.framework.jremote.core.RemoteServer.BroadcastManager Class Reference

  • core
  • RemoteServer
  • BroadcastManager
List of all members
org.pcsoft.framework.jremote.core.RemoteServer.BroadcastManager Class Reference
The documentation for this class was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/RemoteServer.java


JRemote: org.pcsoft.framework.jremote.core.RemoteServerBuilder Class Reference

  • core
  • RemoteServerBuilder
Public Member Functions | Static Public Member Functions | List of all members
org.pcsoft.framework.jremote.core.RemoteServerBuilder Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.core.RemoteServerBuilder:
org.pcsoft.framework.jremote.core.RemoteBuilder< RemoteServer >

Public Member Functions

RemoteServerBuilder | withPushClient (Class<?>...pushClientClasses)
RemoteServerBuilder | withEventClient (Class<?>...eventClientClasses)
RemoteServerBuilder | withControlService (Class<?>...controlServiceImplClasses)
RemoteServerBuilder | withControlService (Object...controlServiceImpls)
RemoteServerBuilder | withPushModelData (Class<?>...pushModelDataClasses)
RemoteServerBuilder | withPushModelData (Object...pushModelDataList)
RemoteServer | build ()
- Public Member Functions inherited from org.pcsoft.framework.jremote.core.RemoteBuilder< RemoteServer >
T | build ()

Static Public Member Functions

static RemoteServerBuilder create (String host, int port)
The documentation for this class was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/RemoteServerBuilder.java


JRemote: org.pcsoft.framework.jremote.core.ServerState Enum Reference

  • core
  • ServerState
Public Attributes | List of all members
org.pcsoft.framework.jremote.core.ServerState Enum Reference
Inheritance diagram for org.pcsoft.framework.jremote.core.ServerState:
org.pcsoft.framework.jremote.core.State

Public Attributes

Opened
Closed
The documentation for this enum was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/ServerState.java


JRemote: org.pcsoft.framework.jremote.core.State Interface Reference

  • core
  • State
org.pcsoft.framework.jremote.core.State Interface Reference
Inheritance diagram for org.pcsoft.framework.jremote.core.State:
org.pcsoft.framework.jremote.core.ClientState org.pcsoft.framework.jremote.core.ServerState

Detailed Description

Marker interface only for states

The documentation for this interface was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/State.java


JRemote: org.pcsoft.framework.jremote.np.api.annotation.KeepAlive Interface Reference

  • np
  • api
  • annotation
  • KeepAlive
org.pcsoft.framework.jremote.np.api.annotation.KeepAlive Interface Reference

Detailed Description

Marker annotation for an interface method in a remote keep alive service, see RemoteKeepAliveService

The documentation for this interface was generated from the following file:
  • plugins/np/api/src/main/java/org/pcsoft/framework/jremote/np/api/annotation/KeepAlive.java


JRemote: org.pcsoft.framework.jremote.np.api.annotation.Registration Interface Reference

  • np
  • api
  • annotation
  • Registration
Classes | Public Member Functions | List of all members
org.pcsoft.framework.jremote.np.api.annotation.Registration Interface Reference

Classes

enum RegistrationType

Public Member Functions

RegistrationType value ()

Detailed Description

Marker annotation for an interface method in a remote registration service, see RemoteRegistrationService

Member Function Documentation

RegistrationType org.pcsoft.framework.jremote.np.api.annotation.Registration.value ( )

Type of registration method

Returns
The documentation for this interface was generated from the following file:
  • plugins/np/api/src/main/java/org/pcsoft/framework/jremote/np/api/annotation/Registration.java


JRemote: org.pcsoft.framework.jremote.np.api.annotation.Registration.RegistrationType Enum Reference

  • np
  • api
  • annotation
  • Registration
  • RegistrationType
Public Attributes | List of all members
org.pcsoft.framework.jremote.np.api.annotation.Registration.RegistrationType Enum Reference

Public Attributes

Register
Unregister

Detailed Description

Types of registration actions

Member Data Documentation

org.pcsoft.framework.jremote.np.api.annotation.Registration.RegistrationType.Register

Register a client (method with three arguments: UUID (string), host, port)

org.pcsoft.framework.jremote.np.api.annotation.Registration.RegistrationType.Unregister

Unregister a client (method with one argument: UUID (string))

The documentation for this enum was generated from the following file:
  • plugins/np/api/src/main/java/org/pcsoft/framework/jremote/np/api/annotation/Registration.java


JRemote: org.pcsoft.framework.jremote.np.api.annotation.RemoteKeepAliveService Interface Reference

  • np
  • api
  • annotation
  • RemoteKeepAliveService
org.pcsoft.framework.jremote.np.api.annotation.RemoteKeepAliveService Interface Reference

Detailed Description

Mark an interface as remote keep alive service. Must have exactly one method:

  • boolean ping(String uuid) annotated with KeepAlive
    Method to ping server with client's UUID to get TRUE if client is registered, otherwise FALSE
The documentation for this interface was generated from the following file:
  • plugins/np/api/src/main/java/org/pcsoft/framework/jremote/np/api/annotation/RemoteKeepAliveService.java


JRemote: org.pcsoft.framework.jremote.np.api.annotation.RemoteRegistrationService Interface Reference

  • np
  • api
  • annotation
  • RemoteRegistrationService
org.pcsoft.framework.jremote.np.api.annotation.RemoteRegistrationService Interface Reference

Detailed Description

Mark an interface as remote registration service. Must have exactly two methods:

  • void register(String uuid, String host, int port) annotated with Registration(Registration.RegistrationType#Register)
    Method to register a client, identified by its UUID.
  • void unregister(String uuid) annotated with Registration(Registration.RegistrationType#Unregister)
    Method to unregister a client, identified by its UUID
The documentation for this interface was generated from the following file:
  • plugins/np/api/src/main/java/org/pcsoft/framework/jremote/np/api/annotation/RemoteRegistrationService.java


JRemote: org.pcsoft.framework.jremote.np.api.Client Interface Reference

  • np
  • api
  • Client
Public Member Functions | List of all members
org.pcsoft.framework.jremote.np.api.Client Interface Reference
Inheritance diagram for org.pcsoft.framework.jremote.np.api.Client:
org.pcsoft.framework.jremote.np.api.ClientBase org.pcsoft.framework.jremote.np.impl.rmi.RmiClient org.pcsoft.framework.jremote.np.impl.tcp.TcpClient

Public Member Functions

void | open (String host, int port) throws IOException
Object | invokeRemote (Method method, Object...params) throws IOException
Class<?> | getServiceClass ()
void | setServiceClass (Class<?> serviceClass)

Detailed Description

Interface for a client based implementation

Member Function Documentation

Class<?> org.pcsoft.framework.jremote.np.api.Client.getServiceClass ( )

Returns the service class the client work for. All methods in invokeRemote(Method, Object...) are part of this interface class

Returns

Implemented in org.pcsoft.framework.jremote.np.api.ClientBase.

Object org.pcsoft.framework.jremote.np.api.Client.invokeRemote | ( | Method | method,
 |  | Object... | params
 | ) |  | throws IOException

Invoke the given method on server with given parameter values

Parameters
method
params
Returns
Exceptions
IOException

Implemented in org.pcsoft.framework.jremote.np.impl.rmi.RmiClient, and org.pcsoft.framework.jremote.np.impl.tcp.TcpClient.

void org.pcsoft.framework.jremote.np.api.Client.open | ( | String | host,
 |  | int | port
 | ) |  | throws IOException

Open the client on given host / port

Parameters
host
port
Exceptions
IOException

Implemented in org.pcsoft.framework.jremote.np.impl.rmi.RmiClient, and org.pcsoft.framework.jremote.np.impl.tcp.TcpClient.

void org.pcsoft.framework.jremote.np.api.Client.setServiceClass ( Class<?> serviceClass )

Setup the service class the client work for. See getServiceClass()

Parameters
serviceClass

Implemented in org.pcsoft.framework.jremote.np.api.ClientBase.

The documentation for this interface was generated from the following file:
  • plugins/np/api/src/main/java/org/pcsoft/framework/jremote/np/api/Client.java


JRemote: org.pcsoft.framework.jremote.np.api.ClientBase Class Reference

  • np
  • api
  • ClientBase
Public Member Functions | List of all members
org.pcsoft.framework.jremote.np.api.ClientBase Class Referenceabstract
Inheritance diagram for org.pcsoft.framework.jremote.np.api.ClientBase:
org.pcsoft.framework.jremote.np.api.Client org.pcsoft.framework.jremote.np.impl.rmi.RmiClient org.pcsoft.framework.jremote.np.impl.tcp.TcpClient

Public Member Functions

final Class<?> | getServiceClass ()
final void | setServiceClass (Class<?> serviceClass)
- Public Member Functions inherited from org.pcsoft.framework.jremote.np.api.Client
void | open (String host, int port) throws IOException
Object | invokeRemote (Method method, Object...params) throws IOException

Member Function Documentation

final Class<?> org.pcsoft.framework.jremote.np.api.ClientBase.getServiceClass ( )

Returns the service class the client work for. All methods in invokeRemote(Method, Object...) are part of this interface class

Returns

Implements org.pcsoft.framework.jremote.np.api.Client.

final void org.pcsoft.framework.jremote.np.api.ClientBase.setServiceClass ( Class<?> serviceClass )

Setup the service class the client work for. See getServiceClass()

Parameters
serviceClass

Implements org.pcsoft.framework.jremote.np.api.Client.

The documentation for this class was generated from the following file:
  • plugins/np/api/src/main/java/org/pcsoft/framework/jremote/np/api/ClientBase.java


JRemote: org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin Interface Reference

  • np
  • api
  • NetworkProtocolPlugin
Public Member Functions | List of all members
org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin Interface Reference
Inheritance diagram for org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin:
org.pcsoft.framework.jremote.np.impl.rmi.RmiPlugin org.pcsoft.framework.jremote.np.impl.tcp.TcpPlugin

Public Member Functions

Class<?extends Service > | getServiceClass ()
Class<?extends org.pcsoft.framework.jremote.np.api.Client > | getClientClass ()
Class<?> | getRegistrationServiceClass ()
Class<?> | getKeepAliveServiceClass ()

Detailed Description

Interface for network protocol plugin mechanism

Member Function Documentation

Class<? extends org.pcsoft.framework.jremote.np.api.Client> org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin.getClientClass ( )

Returns the class of Client for this plugin. Class is instantiate automatically.

Returns

Implemented in org.pcsoft.framework.jremote.np.impl.rmi.RmiPlugin, and org.pcsoft.framework.jremote.np.impl.tcp.TcpPlugin.

Class<?> org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin.getKeepAliveServiceClass ( )

Returns the concrete remote keep alive service class to use for this plugin

Returns

Implemented in org.pcsoft.framework.jremote.np.impl.rmi.RmiPlugin, and org.pcsoft.framework.jremote.np.impl.tcp.TcpPlugin.

Class<?> org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin.getRegistrationServiceClass ( )

Returns the concrete remote registration service class to use for this plugin

Returns

Implemented in org.pcsoft.framework.jremote.np.impl.rmi.RmiPlugin, and org.pcsoft.framework.jremote.np.impl.tcp.TcpPlugin.

Class<? extends Service> org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin.getServiceClass ( )

Returns the class of Service for this plugin. Class is instantiate automatically.

Returns

Implemented in org.pcsoft.framework.jremote.np.impl.rmi.RmiPlugin, and org.pcsoft.framework.jremote.np.impl.tcp.TcpPlugin.

The documentation for this interface was generated from the following file:
  • plugins/np/api/src/main/java/org/pcsoft/framework/jremote/np/api/NetworkProtocolPlugin.java


JRemote: org.pcsoft.framework.jremote.np.api.Service Interface Reference

  • np
  • api
  • Service
Public Member Functions | List of all members
org.pcsoft.framework.jremote.np.api.Service Interface Reference
Inheritance diagram for org.pcsoft.framework.jremote.np.api.Service:
org.pcsoft.framework.jremote.np.api.ServiceBase org.pcsoft.framework.jremote.np.impl.rmi.RmiService org.pcsoft.framework.jremote.np.impl.tcp.TcpService

Public Member Functions

void | open (String host, int port) throws IOException
void | setServiceImplementation (Object serviceImplementation)
Object | getServiceImplementation ()

Detailed Description

Represent the base interface for a service implementation

Member Function Documentation

Object org.pcsoft.framework.jremote.np.api.Service.getServiceImplementation ( )

Returns the service implementation, see setServiceImplementation(Object)

Returns

Implemented in org.pcsoft.framework.jremote.np.api.ServiceBase.

void org.pcsoft.framework.jremote.np.api.Service.open | ( | String | host,
 |  | int | port
 | ) |  | throws IOException

Start service on given host and port

Parameters
host
port
Exceptions
IOException

Implemented in org.pcsoft.framework.jremote.np.impl.rmi.RmiService, and org.pcsoft.framework.jremote.np.impl.tcp.TcpService.

void org.pcsoft.framework.jremote.np.api.Service.setServiceImplementation ( Object serviceImplementation )

Setup the service implementation to call methods on

Parameters
serviceImplementation

Implemented in org.pcsoft.framework.jremote.np.api.ServiceBase.

The documentation for this interface was generated from the following file:
  • plugins/np/api/src/main/java/org/pcsoft/framework/jremote/np/api/Service.java


JRemote: org.pcsoft.framework.jremote.np.api.ServiceBase Class Reference

  • np
  • api
  • ServiceBase
Public Member Functions | List of all members
org.pcsoft.framework.jremote.np.api.ServiceBase Class Referenceabstract
Inheritance diagram for org.pcsoft.framework.jremote.np.api.ServiceBase:
org.pcsoft.framework.jremote.np.api.Service org.pcsoft.framework.jremote.np.impl.rmi.RmiService org.pcsoft.framework.jremote.np.impl.tcp.TcpService

Public Member Functions

final Object | getServiceImplementation ()
final void | setServiceImplementation (Object serviceImplementation)
- Public Member Functions inherited from org.pcsoft.framework.jremote.np.api.Service
void | open (String host, int port) throws IOException

Detailed Description

Basic implementation for a service. Contains the basic implementation.

Member Function Documentation

final Object org.pcsoft.framework.jremote.np.api.ServiceBase.getServiceImplementation ( )

Returns the service implementation, see setServiceImplementation(Object)

Returns

Implements org.pcsoft.framework.jremote.np.api.Service.

final void org.pcsoft.framework.jremote.np.api.ServiceBase.setServiceImplementation ( Object serviceImplementation )

Setup the service implementation to call methods on

Parameters
serviceImplementation

Implements org.pcsoft.framework.jremote.np.api.Service.

The documentation for this class was generated from the following file:
  • plugins/np/api/src/main/java/org/pcsoft/framework/jremote/np/api/ServiceBase.java


JRemote: org.pcsoft.framework.jremote.np.impl.rmi.interf.RmiKeepAliveService Interface Reference

  • np
  • impl
  • rmi
  • interf
  • RmiKeepAliveService
Public Member Functions | List of all members
org.pcsoft.framework.jremote.np.impl.rmi.interf.RmiKeepAliveService Interface Reference
Inheritance diagram for org.pcsoft.framework.jremote.np.impl.rmi.interf.RmiKeepAliveService:

Public Member Functions

boolean ping (String uuid) throws RemoteException
The documentation for this interface was generated from the following file:
  • plugins/np/impl/rmi/src/main/java/org/pcsoft/framework/jremote/np/impl/rmi/interf/RmiKeepAliveService.java


JRemote: org.pcsoft.framework.jremote.np.impl.rmi.interf.RmiRegistrationService Interface Reference

  • np
  • impl
  • rmi
  • interf
  • RmiRegistrationService
Public Member Functions | List of all members
org.pcsoft.framework.jremote.np.impl.rmi.interf.RmiRegistrationService Interface Reference
Inheritance diagram for org.pcsoft.framework.jremote.np.impl.rmi.interf.RmiRegistrationService:

Public Member Functions

void | register (String uuid, String host, int port) throws RemoteException
void | unregister (String uuid) throws RemoteException
The documentation for this interface was generated from the following file:
  • plugins/np/impl/rmi/src/main/java/org/pcsoft/framework/jremote/np/impl/rmi/interf/RmiRegistrationService.java


JRemote: org.pcsoft.framework.jremote.np.impl.rmi.RmiClient Class Reference

  • np
  • impl
  • rmi
  • RmiClient
Public Member Functions | List of all members
org.pcsoft.framework.jremote.np.impl.rmi.RmiClient Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.np.impl.rmi.RmiClient:
org.pcsoft.framework.jremote.np.api.ClientBase org.pcsoft.framework.jremote.np.api.Client

Public Member Functions

void | open (String host, int port) throws IOException
void | close () throws IOException
Object | invokeRemote (Method method, Object...params) throws IOException
- Public Member Functions inherited from org.pcsoft.framework.jremote.np.api.ClientBase
final Class<?> | getServiceClass ()
final void | setServiceClass (Class<?> serviceClass)

Member Function Documentation

Object org.pcsoft.framework.jremote.np.impl.rmi.RmiClient.invokeRemote | ( | Method | method,
 |  | Object... | params
 | ) |  | throws IOException

Invoke the given method on server with given parameter values

Parameters
method
params
Returns
Exceptions
IOException

Implements org.pcsoft.framework.jremote.np.api.Client.

void org.pcsoft.framework.jremote.np.impl.rmi.RmiClient.open | ( | String | host,
 |  | int | port
 | ) |  | throws IOException

Open the client on given host / port

Parameters
host
port
Exceptions
IOException

Implements org.pcsoft.framework.jremote.np.api.Client.

The documentation for this class was generated from the following file:
  • plugins/np/impl/rmi/src/main/java/org/pcsoft/framework/jremote/np/impl/rmi/RmiClient.java


JRemote: org.pcsoft.framework.jremote.np.impl.rmi.RmiPlugin Class Reference

  • np
  • impl
  • rmi
  • RmiPlugin
Public Member Functions | List of all members
org.pcsoft.framework.jremote.np.impl.rmi.RmiPlugin Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.np.impl.rmi.RmiPlugin:
org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin

Public Member Functions

Class<?extends Service > | getServiceClass ()
Class<?extends Client > | getClientClass ()
Class<?> | getRegistrationServiceClass ()
Class<?> | getKeepAliveServiceClass ()

Member Function Documentation

Class<? extends Client> org.pcsoft.framework.jremote.np.impl.rmi.RmiPlugin.getClientClass ( )

Returns the class of Client for this plugin. Class is instantiate automatically.

Returns

Implements org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin.

Class<?> org.pcsoft.framework.jremote.np.impl.rmi.RmiPlugin.getKeepAliveServiceClass ( )

Returns the concrete remote keep alive service class to use for this plugin

Returns

Implements org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin.

Class<?> org.pcsoft.framework.jremote.np.impl.rmi.RmiPlugin.getRegistrationServiceClass ( )

Returns the concrete remote registration service class to use for this plugin

Returns

Implements org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin.

Class<? extends Service> org.pcsoft.framework.jremote.np.impl.rmi.RmiPlugin.getServiceClass ( )

Returns the class of Service for this plugin. Class is instantiate automatically.

Returns

Implements org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin.

The documentation for this class was generated from the following file:
  • plugins/np/impl/rmi/src/main/java/org/pcsoft/framework/jremote/np/impl/rmi/RmiPlugin.java


JRemote: org.pcsoft.framework.jremote.np.impl.rmi.RmiService Class Reference

  • np
  • impl
  • rmi
  • RmiService
Public Member Functions | List of all members
org.pcsoft.framework.jremote.np.impl.rmi.RmiService Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.np.impl.rmi.RmiService:
org.pcsoft.framework.jremote.np.api.ServiceBase org.pcsoft.framework.jremote.np.api.Service

Public Member Functions

void | open (String host, int port) throws IOException
void | close () throws IOException
- Public Member Functions inherited from org.pcsoft.framework.jremote.np.api.ServiceBase
final Object | getServiceImplementation ()
final void | setServiceImplementation (Object serviceImplementation)

Member Function Documentation

void org.pcsoft.framework.jremote.np.impl.rmi.RmiService.open | ( | String | host,
 |  | int | port
 | ) |  | throws IOException

Start service on given host and port

Parameters
host
port
Exceptions
IOException

Implements org.pcsoft.framework.jremote.np.api.Service.

The documentation for this class was generated from the following file:
  • plugins/np/impl/rmi/src/main/java/org/pcsoft/framework/jremote/np/impl/rmi/RmiService.java


JRemote: org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Invocation Class Reference

  • np
  • impl
  • tcp
  • internal
  • type
  • Invocation
Classes | Public Member Functions | List of all members
org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Invocation Class Reference

Classes

class Parameter

Public Member Functions

Invocation (String methodName, Type returnType, Parameter...parameters)
String | getMethodName ()
Type | getReturnType ()
Parameter[] | getParameters ()
Class<?>[] | getParameterClasses ()
Object[] | getParameterValues ()
The documentation for this class was generated from the following file:
  • plugins/np/impl/tcp/src/main/java/org/pcsoft/framework/jremote/np/impl/tcp/internal/type/Invocation.java


JRemote: org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type Enum Reference

  • np
  • impl
  • tcp
  • internal
  • type
  • Type
Public Member Functions | Static Public Member Functions | Public Attributes | List of all members
org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type Enum Reference

Public Member Functions

Type (byte value, Class<?> clazz)
byte | getValue ()
Class<?> | getClazz ()

Static Public Member Functions

static Type fromValue (byte value)

Public Attributes

Void =((byte) 0, void.class)
Byte =((byte) 1, byte.class)
ByteType =((byte) 2, Byte.class)
Short =((byte) 3, short.class)
ShortType =((byte) 4, Short.class)
Integer =((byte) 5, int.class)
IntegerType =((byte) 6, Integer.class)
Long =((byte) 7, long.class)
LongType =((byte) 8, Long.class)
Double =((byte) 9, double.class)
DoubleType =((byte) 10, Double.class)
Float =((byte) 11, float.class)
FloatType =((byte) 12, Float.class)
SignedByte =((byte) 21, byte.class)
SignedByteType =((byte) 22, Byte.class)
UnsignedShort =((byte) 23, short.class)
UnsignedShortType =((byte) 24, Short.class)
UnsignedInteger =((byte) 25, int.class)
UnsignedIntegerType =((byte) 26, Integer.class)
UnsignedLong =((byte) 27, long.class)
UnsignedLongType =((byte) 28, Long.class)
UnsignedDouble =((byte) 29, double.class)
UnsignedDoubleType =((byte) 30, Double.class)
UnsignedFloat =((byte) 31, float.class)
UnsignedFloatType =((byte) 32, Float.class)
Character =((byte) 100, char.class)
CharacterType =((byte) 101, Character.class)
String =((byte) 110, String.class)
Complex =((byte) 255, Object.class)
The documentation for this enum was generated from the following file:
  • plugins/np/impl/tcp/src/main/java/org/pcsoft/framework/jremote/np/impl/tcp/internal/type/Type.java


JRemote: org.pcsoft.framework.jremote.np.impl.tcp.internal.TcpServer Class Reference

  • np
  • impl
  • tcp
  • internal
  • TcpServer
Public Member Functions | List of all members
org.pcsoft.framework.jremote.np.impl.tcp.internal.TcpServer Class Reference

Public Member Functions

TcpServer (ServerSocket serverSocket, Function< Invocation, Object > invocationCallback)
void acceptAndHandle () throws IOException
The documentation for this class was generated from the following file:
  • plugins/np/impl/tcp/src/main/java/org/pcsoft/framework/jremote/np/impl/tcp/internal/TcpServer.java


JRemote: org.pcsoft.framework.jremote.np.impl.tcp.TcpClient Class Reference

  • np
  • impl
  • tcp
  • TcpClient
Public Member Functions | List of all members
org.pcsoft.framework.jremote.np.impl.tcp.TcpClient Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.np.impl.tcp.TcpClient:
org.pcsoft.framework.jremote.np.api.ClientBase org.pcsoft.framework.jremote.np.api.Client

Public Member Functions

void | open (String host, int port) throws IOException
Object | invokeRemote (Method method, Object...params) throws IOException
void | close () throws IOException
- Public Member Functions inherited from org.pcsoft.framework.jremote.np.api.ClientBase
final Class<?> | getServiceClass ()
final void | setServiceClass (Class<?> serviceClass)

Member Function Documentation

Object org.pcsoft.framework.jremote.np.impl.tcp.TcpClient.invokeRemote | ( | Method | method,
 |  | Object... | params
 | ) |  | throws IOException

Invoke the given method on server with given parameter values

Parameters
method
params
Returns
Exceptions
IOException

Implements org.pcsoft.framework.jremote.np.api.Client.

void org.pcsoft.framework.jremote.np.impl.tcp.TcpClient.open | ( | String | host,
 |  | int | port
 | ) |  | throws IOException

Open the client on given host / port

Parameters
host
port
Exceptions
IOException

Implements org.pcsoft.framework.jremote.np.api.Client.

The documentation for this class was generated from the following file:
  • plugins/np/impl/tcp/src/main/java/org/pcsoft/framework/jremote/np/impl/tcp/TcpClient.java


JRemote: org.pcsoft.framework.jremote.np.impl.tcp.TcpPlugin Class Reference

  • np
  • impl
  • tcp
  • TcpPlugin
Public Member Functions | List of all members
org.pcsoft.framework.jremote.np.impl.tcp.TcpPlugin Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.np.impl.tcp.TcpPlugin:
org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin

Public Member Functions

Class<?extends Service > | getServiceClass ()
Class<?extends Client > | getClientClass ()
Class<?> | getRegistrationServiceClass ()
Class<?> | getKeepAliveServiceClass ()

Member Function Documentation

Class<? extends Client> org.pcsoft.framework.jremote.np.impl.tcp.TcpPlugin.getClientClass ( )

Returns the class of Client for this plugin. Class is instantiate automatically.

Returns

Implements org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin.

Class<?> org.pcsoft.framework.jremote.np.impl.tcp.TcpPlugin.getKeepAliveServiceClass ( )

Returns the concrete remote keep alive service class to use for this plugin

Returns

Implements org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin.

Class<?> org.pcsoft.framework.jremote.np.impl.tcp.TcpPlugin.getRegistrationServiceClass ( )

Returns the concrete remote registration service class to use for this plugin

Returns

Implements org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin.

Class<? extends Service> org.pcsoft.framework.jremote.np.impl.tcp.TcpPlugin.getServiceClass ( )

Returns the class of Service for this plugin. Class is instantiate automatically.

Returns

Implements org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin.

The documentation for this class was generated from the following file:
  • plugins/np/impl/tcp/src/main/java/org/pcsoft/framework/jremote/np/impl/tcp/TcpPlugin.java


JRemote: org.pcsoft.framework.jremote.np.impl.tcp.TcpService Class Reference

  • np
  • impl
  • tcp
  • TcpService
Public Member Functions | List of all members
org.pcsoft.framework.jremote.np.impl.tcp.TcpService Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.np.impl.tcp.TcpService:
org.pcsoft.framework.jremote.np.api.ServiceBase org.pcsoft.framework.jremote.np.api.Service

Public Member Functions

void | open (String host, int port) throws IOException
void | close () throws IOException
- Public Member Functions inherited from org.pcsoft.framework.jremote.np.api.ServiceBase
final Object | getServiceImplementation ()
final void | setServiceImplementation (Object serviceImplementation)

Member Function Documentation

void org.pcsoft.framework.jremote.np.impl.tcp.TcpService.open | ( | String | host,
 |  | int | port
 | ) |  | throws IOException

Start service on given host and port

Parameters
host
port
Exceptions
IOException

Implements org.pcsoft.framework.jremote.np.api.Service.

The documentation for this class was generated from the following file:
  • plugins/np/impl/tcp/src/main/java/org/pcsoft/framework/jremote/np/impl/tcp/TcpService.java


JRemote: Class Index

Class Index
A | B | C | D | E | I | J | K | N | O | P | R | S | T
A
JRemoteException (org.pcsoft.framework.jremote.api.exception) RemoteEventReceiver (org.pcsoft.framework.jremote.api)
JRemoteExecutionException (org.pcsoft.framework.jremote.api.exception) | RemoteEventService (org.pcsoft.framework.jremote.api)
AnnotationUtils (org.pcsoft.framework.jremote.commons)
K
RemoteKeepAliveService (org.pcsoft.framework.jremote.np.api.annotation)
B
RemoteListener (org.pcsoft.framework.jremote.api.type)
KeepAlive (org.pcsoft.framework.jremote.np.api.annotation) | RemotePushModel (org.pcsoft.framework.jremote.api)
RemoteServer.BroadcastManager (org.pcsoft.framework.jremote.core)
N
RemotePushObserver (org.pcsoft.framework.jremote.api)
C
RemotePushService (org.pcsoft.framework.jremote.api)
NetworkProtocolPlugin (org.pcsoft.framework.jremote.np.api) | RemoteRegistrationService (org.pcsoft.framework.jremote.np.api.annotation)
Client (org.pcsoft.framework.jremote.np.api)
O
RemoteServer (org.pcsoft.framework.jremote.core)
Client (org.pcsoft.framework.jremote.core) | RemoteServerBuilder (org.pcsoft.framework.jremote.core)
ClientBase (org.pcsoft.framework.jremote.np.api) | ObserverListenerType (org.pcsoft.framework.jremote.api.type) | RmiClient (org.pcsoft.framework.jremote.np.impl.rmi)
ClientState (org.pcsoft.framework.jremote.core)
P
RmiKeepAliveService (org.pcsoft.framework.jremote.np.impl.rmi.interf)
Control (org.pcsoft.framework.jremote.api) | RmiPlugin (org.pcsoft.framework.jremote.np.impl.rmi)
RemoteClient.ControlManager (org.pcsoft.framework.jremote.core) | Push (org.pcsoft.framework.jremote.api) | RmiRegistrationService (org.pcsoft.framework.jremote.np.impl.rmi.interf)
D
PushChangedListener (org.pcsoft.framework.jremote.api.type) RmiService (org.pcsoft.framework.jremote.np.impl.rmi)
PushItemUpdate (org.pcsoft.framework.jremote.api.type)
S
RemoteClient.DataManager (org.pcsoft.framework.jremote.core) | PushMethodType (org.pcsoft.framework.jremote.api.type)
E
PushModelProperty (org.pcsoft.framework.jremote.api) ServerState (org.pcsoft.framework.jremote.core)
PushObserverListener (org.pcsoft.framework.jremote.api) | Service (org.pcsoft.framework.jremote.np.api)
Event (org.pcsoft.framework.jremote.api)
R
ServiceBase (org.pcsoft.framework.jremote.np.api)
EventReceivedListener (org.pcsoft.framework.jremote.api.type) | State (org.pcsoft.framework.jremote.core)
EventReceiverListener (org.pcsoft.framework.jremote.api) ReflectionUtils (org.pcsoft.framework.jremote.commons)
T
I
Registration (org.pcsoft.framework.jremote.np.api.annotation)
Registration.RegistrationType (org.pcsoft.framework.jremote.np.api.annotation) | TcpClient (org.pcsoft.framework.jremote.np.impl.tcp)
Invocation (org.pcsoft.framework.jremote.np.impl.tcp.internal.type) | Remote (org.pcsoft.framework.jremote.core) | TcpPlugin (org.pcsoft.framework.jremote.np.impl.tcp)
J
RemoteBuilder (org.pcsoft.framework.jremote.core) TcpServer (org.pcsoft.framework.jremote.np.impl.tcp.internal)
RemoteClient (org.pcsoft.framework.jremote.core) | TcpService (org.pcsoft.framework.jremote.np.impl.tcp)
JRemoteAnnotationException (org.pcsoft.framework.jremote.api.exception) | RemoteClientBuilder (org.pcsoft.framework.jremote.core) | Type (org.pcsoft.framework.jremote.np.impl.tcp.internal.type)
JRemoteConfigurationException (org.pcsoft.framework.jremote.api.exception) | RemoteControlService (org.pcsoft.framework.jremote.api)
A | B | C | D | E | I | J | K | N | O | P | R | S | T


JRemote: Class Hierarchy

Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 1234]
C org.pcsoft.framework.jremote.commons.AnnotationUtils
▼C AutoCloseable
C org.pcsoft.framework.jremote.core.Remote< S extends State >
C org.pcsoft.framework.jremote.core.RemoteServer.BroadcastManager
C org.pcsoft.framework.jremote.core.Client
C org.pcsoft.framework.jremote.api.Control
C org.pcsoft.framework.jremote.core.RemoteClient.ControlManager
C org.pcsoft.framework.jremote.core.RemoteClient.DataManager
C org.pcsoft.framework.jremote.api.Event
C org.pcsoft.framework.jremote.api.EventReceiverListener
C org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Invocation
C org.pcsoft.framework.jremote.np.api.annotation.KeepAlive
▼C org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin
C org.pcsoft.framework.jremote.np.impl.rmi.RmiPlugin
C org.pcsoft.framework.jremote.np.impl.tcp.TcpPlugin
C org.pcsoft.framework.jremote.api.type.ObserverListenerType
C org.pcsoft.framework.jremote.api.Push
C org.pcsoft.framework.jremote.api.type.PushItemUpdate
C org.pcsoft.framework.jremote.api.type.PushMethodType
C org.pcsoft.framework.jremote.api.PushModelProperty
C org.pcsoft.framework.jremote.api.PushObserverListener
C org.pcsoft.framework.jremote.commons.ReflectionUtils
C org.pcsoft.framework.jremote.np.api.annotation.Registration
C org.pcsoft.framework.jremote.np.api.annotation.Registration.RegistrationType
▼C org.pcsoft.framework.jremote.core.Remote< ClientState >
C org.pcsoft.framework.jremote.core.RemoteClient
▼C org.pcsoft.framework.jremote.core.Remote< ServerState >
C org.pcsoft.framework.jremote.core.RemoteServer
C org.pcsoft.framework.jremote.core.RemoteBuilder< T extends Remote >
▼C org.pcsoft.framework.jremote.core.RemoteBuilder< RemoteClient >
C org.pcsoft.framework.jremote.core.RemoteClientBuilder
▼C org.pcsoft.framework.jremote.core.RemoteBuilder< RemoteServer >
C org.pcsoft.framework.jremote.core.RemoteServerBuilder
C org.pcsoft.framework.jremote.api.RemoteControlService
C org.pcsoft.framework.jremote.api.RemoteEventReceiver
C org.pcsoft.framework.jremote.api.RemoteEventService
C org.pcsoft.framework.jremote.np.api.annotation.RemoteKeepAliveService
▼C org.pcsoft.framework.jremote.api.type.RemoteListener
C org.pcsoft.framework.jremote.api.type.EventReceivedListener< T >
C org.pcsoft.framework.jremote.api.type.PushChangedListener
C org.pcsoft.framework.jremote.api.RemotePushModel
C org.pcsoft.framework.jremote.api.RemotePushObserver
C org.pcsoft.framework.jremote.api.RemotePushService
C org.pcsoft.framework.jremote.np.api.annotation.RemoteRegistrationService
▼C RuntimeException
▼C org.pcsoft.framework.jremote.api.exception.JRemoteException
C org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException
C org.pcsoft.framework.jremote.api.exception.JRemoteConfigurationException
C org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException
▼C org.pcsoft.framework.jremote.core.State
C org.pcsoft.framework.jremote.core.ClientState
C org.pcsoft.framework.jremote.core.ServerState
C org.pcsoft.framework.jremote.np.impl.tcp.internal.TcpServer
C org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type
▼C Closeable
▼C org.pcsoft.framework.jremote.np.api.Client
▼C org.pcsoft.framework.jremote.np.api.ClientBase
C org.pcsoft.framework.jremote.np.impl.rmi.RmiClient
C org.pcsoft.framework.jremote.np.impl.tcp.TcpClient
▼C org.pcsoft.framework.jremote.np.api.Service
▼C org.pcsoft.framework.jremote.np.api.ServiceBase
C org.pcsoft.framework.jremote.np.impl.rmi.RmiService
C org.pcsoft.framework.jremote.np.impl.tcp.TcpService
▼C Remote
C org.pcsoft.framework.jremote.np.impl.rmi.interf.RmiKeepAliveService
C org.pcsoft.framework.jremote.np.impl.rmi.interf.RmiRegistrationService


JRemote: Class Members

  • All
  • Functions
  • Variables
  • a
  • d
  • e
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • Add : org.pcsoft.framework.jremote.api.type.ObserverListenerType
  • AutoDetection : org.pcsoft.framework.jremote.api.type.ObserverListenerType

- d -

  • Default : org.pcsoft.framework.jremote.api.type.PushMethodType

- e -

  • event() : org.pcsoft.framework.jremote.api.Event
  • eventClass() : org.pcsoft.framework.jremote.api.Event

- g -

  • getClientClass() : org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin , org.pcsoft.framework.jremote.np.impl.rmi.RmiPlugin , org.pcsoft.framework.jremote.np.impl.tcp.TcpPlugin
  • getKeepAliveServiceClass() : org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin , org.pcsoft.framework.jremote.np.impl.rmi.RmiPlugin , org.pcsoft.framework.jremote.np.impl.tcp.TcpPlugin
  • getRegistrationServiceClass() : org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin , org.pcsoft.framework.jremote.np.impl.rmi.RmiPlugin , org.pcsoft.framework.jremote.np.impl.tcp.TcpPlugin
  • getServiceClass() : org.pcsoft.framework.jremote.np.api.Client , org.pcsoft.framework.jremote.np.api.ClientBase , org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin , org.pcsoft.framework.jremote.np.impl.rmi.RmiPlugin , org.pcsoft.framework.jremote.np.impl.tcp.TcpPlugin
  • getServiceImplementation() : org.pcsoft.framework.jremote.np.api.Service , org.pcsoft.framework.jremote.np.api.ServiceBase

- i -

  • invokeRemote() : org.pcsoft.framework.jremote.np.api.Client , org.pcsoft.framework.jremote.np.impl.rmi.RmiClient , org.pcsoft.framework.jremote.np.impl.tcp.TcpClient

- l -

  • listenerType() : org.pcsoft.framework.jremote.api.EventReceiverListener , org.pcsoft.framework.jremote.api.PushObserverListener

- m -

  • modelClass() : org.pcsoft.framework.jremote.api.Push , org.pcsoft.framework.jremote.api.PushObserverListener

- o -

  • onChange() : org.pcsoft.framework.jremote.api.type.EventReceivedListener< T > , org.pcsoft.framework.jremote.api.type.PushChangedListener
  • open() : org.pcsoft.framework.jremote.np.api.Client , org.pcsoft.framework.jremote.np.api.Service , org.pcsoft.framework.jremote.np.impl.rmi.RmiClient , org.pcsoft.framework.jremote.np.impl.rmi.RmiService , org.pcsoft.framework.jremote.np.impl.tcp.TcpClient , org.pcsoft.framework.jremote.np.impl.tcp.TcpService

- p -

  • property() : org.pcsoft.framework.jremote.api.Push , org.pcsoft.framework.jremote.api.PushObserverListener

- r -

  • Register : org.pcsoft.framework.jremote.np.api.annotation.Registration.RegistrationType
  • Remove : org.pcsoft.framework.jremote.api.type.ObserverListenerType

- s -

  • setServiceClass() : org.pcsoft.framework.jremote.np.api.Client , org.pcsoft.framework.jremote.np.api.ClientBase
  • setServiceImplementation() : org.pcsoft.framework.jremote.np.api.Service , org.pcsoft.framework.jremote.np.api.ServiceBase
  • SingleListItem : org.pcsoft.framework.jremote.api.type.PushMethodType

- t -

  • type() : org.pcsoft.framework.jremote.api.Push

- u -

  • Unregister : org.pcsoft.framework.jremote.np.api.annotation.Registration.RegistrationType

- v -

  • value() : org.pcsoft.framework.jremote.api.EventReceiverListener , org.pcsoft.framework.jremote.api.PushModelProperty , org.pcsoft.framework.jremote.np.api.annotation.Registration


JRemote: Class Members - Functions

  • All
  • Functions
  • Variables
  • e
  • g
  • i
  • l
  • m
  • o
  • p
  • s
  • t
  • v

- e -

  • event() : org.pcsoft.framework.jremote.api.Event
  • eventClass() : org.pcsoft.framework.jremote.api.Event

- g -

  • getClientClass() : org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin , org.pcsoft.framework.jremote.np.impl.rmi.RmiPlugin , org.pcsoft.framework.jremote.np.impl.tcp.TcpPlugin
  • getKeepAliveServiceClass() : org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin , org.pcsoft.framework.jremote.np.impl.rmi.RmiPlugin , org.pcsoft.framework.jremote.np.impl.tcp.TcpPlugin
  • getRegistrationServiceClass() : org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin , org.pcsoft.framework.jremote.np.impl.rmi.RmiPlugin , org.pcsoft.framework.jremote.np.impl.tcp.TcpPlugin
  • getServiceClass() : org.pcsoft.framework.jremote.np.api.Client , org.pcsoft.framework.jremote.np.api.ClientBase , org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin , org.pcsoft.framework.jremote.np.impl.rmi.RmiPlugin , org.pcsoft.framework.jremote.np.impl.tcp.TcpPlugin
  • getServiceImplementation() : org.pcsoft.framework.jremote.np.api.Service , org.pcsoft.framework.jremote.np.api.ServiceBase

- i -

  • invokeRemote() : org.pcsoft.framework.jremote.np.api.Client , org.pcsoft.framework.jremote.np.impl.rmi.RmiClient , org.pcsoft.framework.jremote.np.impl.tcp.TcpClient

- l -

  • listenerType() : org.pcsoft.framework.jremote.api.EventReceiverListener , org.pcsoft.framework.jremote.api.PushObserverListener

- m -

  • modelClass() : org.pcsoft.framework.jremote.api.Push , org.pcsoft.framework.jremote.api.PushObserverListener

- o -

  • onChange() : org.pcsoft.framework.jremote.api.type.EventReceivedListener< T > , org.pcsoft.framework.jremote.api.type.PushChangedListener
  • open() : org.pcsoft.framework.jremote.np.api.Client , org.pcsoft.framework.jremote.np.api.Service , org.pcsoft.framework.jremote.np.impl.rmi.RmiClient , org.pcsoft.framework.jremote.np.impl.rmi.RmiService , org.pcsoft.framework.jremote.np.impl.tcp.TcpClient , org.pcsoft.framework.jremote.np.impl.tcp.TcpService

- p -

  • property() : org.pcsoft.framework.jremote.api.Push , org.pcsoft.framework.jremote.api.PushObserverListener

- s -

  • setServiceClass() : org.pcsoft.framework.jremote.np.api.Client , org.pcsoft.framework.jremote.np.api.ClientBase
  • setServiceImplementation() : org.pcsoft.framework.jremote.np.api.Service , org.pcsoft.framework.jremote.np.api.ServiceBase

- t -

  • type() : org.pcsoft.framework.jremote.api.Push

- v -

  • value() : org.pcsoft.framework.jremote.api.EventReceiverListener , org.pcsoft.framework.jremote.api.PushModelProperty , org.pcsoft.framework.jremote.np.api.annotation.Registration


JRemote: Class Members - Variables

  • All
  • Functions
  • Variables
  • Add : org.pcsoft.framework.jremote.api.type.ObserverListenerType
  • AutoDetection : org.pcsoft.framework.jremote.api.type.ObserverListenerType
  • Default : org.pcsoft.framework.jremote.api.type.PushMethodType
  • Register : org.pcsoft.framework.jremote.np.api.annotation.Registration.RegistrationType
  • Remove : org.pcsoft.framework.jremote.api.type.ObserverListenerType
  • SingleListItem : org.pcsoft.framework.jremote.api.type.PushMethodType
  • Unregister : org.pcsoft.framework.jremote.np.api.annotation.Registration.RegistrationType


JRemote: api/src/main/java/org/pcsoft/framework/jremote Directory Reference

  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
jremote Directory Reference

Directories

directory api


JRemote: api/src/main/java/org Directory Reference

  • api
  • src
  • main
  • java
  • org
org Directory Reference

Directories

directory pcsoft


JRemote: plugins/np/impl/tcp/src/main/java/org/pcsoft/framework/jremote/np/impl/tcp/internal/type Directory Reference

  • plugins
  • np
  • impl
  • tcp
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • np
  • impl
  • tcp
  • internal
  • type
type Directory Reference

Files

file | Invocation.java
file | Type.java


JRemote: plugins/np/impl/rmi Directory Reference

  • plugins
  • np
  • impl
  • rmi
rmi Directory Reference

Directories

directory src


JRemote: plugins/np/impl/tcp/src/main/java/org/pcsoft/framework/jremote Directory Reference

  • plugins
  • np
  • impl
  • tcp
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
jremote Directory Reference

Directories

directory np


JRemote: plugins/np/impl/rmi/src/main/java/org/pcsoft/framework/jremote/np/impl Directory Reference

  • plugins
  • np
  • impl
  • rmi
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • np
  • impl
impl Directory Reference

Directories

directory rmi


JRemote: core/src/main/java/org/pcsoft/framework/jremote/core/internal/registry Directory Reference

  • core
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • internal
  • registry
registry Directory Reference

Files

file | ClientRegistry.java
file | NetworkProtocolPluginRegistry.java
file | PluginRegistry.java


JRemote: plugins/np/impl/rmi/src Directory Reference

  • plugins
  • np
  • impl
  • rmi
  • src
src Directory Reference

Directories

directory main


JRemote: core/src/main/java/org/pcsoft/framework/jremote/core/internal/validation Directory Reference

  • core
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • internal
  • validation
validation Directory Reference

Files

file | AnnotationValidator.java
file | RemoteBroadcastServiceAnnotationValidator.java
file | RemoteControlServiceAnnotationValidator.java
file | RemoteEventReceiverAnnotationValidator.java
file | RemoteEventServiceAnnotationValidator.java
file | RemoteKeepAliveServiceAnnotationValidator.java
file | RemotePushModelAnnotationValidator.java
file | RemotePushObserverAnnotationValidator.java
file | RemotePushServiceAnnotationValidator.java
file | RemoteRegistrationServiceAnnotationValidator.java
file | RemoteServiceAnnotationValidator.java
file | RemoteServiceAnnotationValidatorBase.java
file | SimpleAnnotationValidator.java
file | Validator.java


JRemote: plugins/np/impl/rmi/src/main/java/org/pcsoft/framework/jremote Directory Reference

  • plugins
  • np
  • impl
  • rmi
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
jremote Directory Reference

Directories

directory np


JRemote: api/src/main/java/org/pcsoft/framework/jremote/api/type Directory Reference

  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • type
type Directory Reference

Files

file | EventReceivedListener.java
file | ObserverListenerType.java
file | PushChangedListener.java
file | PushItemUpdate.java
file | PushMethodType.java
file | RemoteListener.java


JRemote: api/src/main/java Directory Reference

  • api
  • src
  • main
  • java
java Directory Reference

Directories

directory org

Files

file module-info.java


JRemote: core/src/main Directory Reference

  • core
  • src
  • main
main Directory Reference

Directories

directory java


JRemote: core/src/main/java/org/pcsoft/framework/jremote/core/internal/processor Directory Reference

  • core
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • internal
  • processor
processor Directory Reference

Files

file | KeepAliveProcessor.java
file | Processor.java


JRemote: commons/src/main Directory Reference

  • commons
  • src
  • main
main Directory Reference

Directories

directory java


JRemote: plugins/np/api/src/main Directory Reference

  • plugins
  • np
  • api
  • src
  • main
main Directory Reference

Directories

directory java


JRemote: plugins/np/impl/tcp/src/main/java/org/pcsoft/framework/jremote/np/impl Directory Reference

  • plugins
  • np
  • impl
  • tcp
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • np
  • impl
impl Directory Reference

Directories

directory tcp


JRemote: plugins/np/impl Directory Reference

  • plugins
  • np
  • impl
impl Directory Reference

Directories

directory | rmi
directory | tcp


JRemote: plugins/np/impl/tcp/src/main/java/org/pcsoft/framework/jremote/np Directory Reference

  • plugins
  • np
  • impl
  • tcp
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • np
np Directory Reference

Directories

directory impl


JRemote: commons/src/main/java/org Directory Reference

  • commons
  • src
  • main
  • java
  • org
org Directory Reference

Directories

directory pcsoft


JRemote: plugins/np/impl/rmi/src/main/java/org Directory Reference

  • plugins
  • np
  • impl
  • rmi
  • src
  • main
  • java
  • org
org Directory Reference

Directories

directory pcsoft


JRemote: plugins/np/api/src/main/java/org/pcsoft/framework Directory Reference

  • plugins
  • np
  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
framework Directory Reference

Directories

directory jremote


JRemote: api/src/main/java/org/pcsoft/framework Directory Reference

  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
framework Directory Reference

Directories

directory jremote


JRemote: plugins/np/impl/rmi/src/main/java/org/pcsoft/framework/jremote/np/impl/rmi Directory Reference

  • plugins
  • np
  • impl
  • rmi
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • np
  • impl
  • rmi
rmi Directory Reference

Directories

directory interf

Files

file | RmiClient.java
file | RmiPlugin.java
file | RmiService.java


JRemote: plugins/np/impl/tcp/src/main/java/org/pcsoft/framework/jremote/np/impl/tcp Directory Reference

  • plugins
  • np
  • impl
  • tcp
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • np
  • impl
  • tcp
tcp Directory Reference

Directories

directory internal

Files

file | TcpClient.java
file | TcpPlugin.java
file | TcpService.java


JRemote: plugins/np/api/src/main/java/org/pcsoft Directory Reference

  • plugins
  • np
  • api
  • src
  • main
  • java
  • org
  • pcsoft
pcsoft Directory Reference

Directories

directory framework


JRemote: commons/src/main/java/org/pcsoft/framework Directory Reference

  • commons
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
framework Directory Reference

Directories

directory jremote


JRemote: api Directory Reference

  • api
api Directory Reference

Directories

directory src


JRemote: plugins/np/impl/tcp/src/main/java/org/pcsoft/framework Directory Reference

  • plugins
  • np
  • impl
  • tcp
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
framework Directory Reference

Directories

directory jremote


JRemote: plugins/np/impl/tcp/src/main Directory Reference

  • plugins
  • np
  • impl
  • tcp
  • src
  • main
main Directory Reference

Directories

directory java


JRemote: core/src/main/java/org/pcsoft/framework/jremote/core/internal/manager Directory Reference

  • core
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • internal
  • manager
manager Directory Reference

Files

file | ClientProxyManager.java
file | ServerProxyManager.java


JRemote: api/src/main/java/org/pcsoft/framework/jremote/api Directory Reference

  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • api
api Directory Reference

Directories

directory | exception
directory | internal
directory | type

Files

file | Control.java
file | Event.java
file | EventReceiverListener.java
file | Push.java
file | PushModelProperty.java
file | PushObserverListener.java
file | RemoteControlService.java
file | RemoteEventReceiver.java
file | RemoteEventService.java
file | RemotePushModel.java
file | RemotePushObserver.java
file | RemotePushService.java


JRemote: commons/src/main/java/org/pcsoft Directory Reference

  • commons
  • src
  • main
  • java
  • org
  • pcsoft
pcsoft Directory Reference

Directories

directory framework


JRemote: commons Directory Reference

  • commons
commons Directory Reference

Directories

directory src


JRemote: plugins/np/api/src/main/java/org/pcsoft/framework/jremote/np/api Directory Reference

  • plugins
  • np
  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • np
  • api
api Directory Reference

Directories

directory annotation

Files

file | Client.java
file | ClientBase.java
file | NetworkProtocolPlugin.java
file | Service.java
file | ServiceBase.java


JRemote: api/src/main Directory Reference

  • api
  • src
  • main
main Directory Reference

Directories

directory java


JRemote: plugins/np/api/src Directory Reference

  • plugins
  • np
  • api
  • src
src Directory Reference

Directories

directory main


JRemote: plugins/np/impl/tcp/src/main/java Directory Reference

  • plugins
  • np
  • impl
  • tcp
  • src
  • main
  • java
java Directory Reference

Directories

directory org

Files

file module-info.java


JRemote: commons/src/main/java/org/pcsoft/framework/jremote Directory Reference

  • commons
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
jremote Directory Reference

Directories

directory commons


JRemote: plugins/np/impl/tcp/src/main/java/org/pcsoft Directory Reference

  • plugins
  • np
  • impl
  • tcp
  • src
  • main
  • java
  • org
  • pcsoft
pcsoft Directory Reference

Directories

directory framework


JRemote: core/src/main/java/org/pcsoft/framework/jremote/core/internal/type Directory Reference

  • core
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • internal
  • type
type Directory Reference

Directories

directory wrapper

Files

file MethodKey.java


JRemote: plugins/np/api Directory Reference

  • plugins
  • np
  • api
api Directory Reference

Directories

directory src


JRemote: commons/src/main/java Directory Reference

  • commons
  • src
  • main
  • java
java Directory Reference

Directories

directory org

Files

file module-info.java


JRemote: plugins/np/api/src/main/java/org/pcsoft/framework/jremote/np/api/annotation Directory Reference

  • plugins
  • np
  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • np
  • api
  • annotation
annotation Directory Reference

Files

file | KeepAlive.java
file | Registration.java
file | RemoteKeepAliveService.java
file | RemoteRegistrationService.java


JRemote: plugins/np/impl/rmi/src/main/java Directory Reference

  • plugins
  • np
  • impl
  • rmi
  • src
  • main
  • java
java Directory Reference

Directories

directory org

Files

file module-info.java


JRemote: commons/src/main/java/org/pcsoft/framework/jremote/commons Directory Reference

  • commons
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • commons
commons Directory Reference

Files

file | AnnotationUtils.java
file | ReflectionUtils.java


JRemote: plugins/np/impl/rmi/src/main/java/org/pcsoft/framework Directory Reference

  • plugins
  • np
  • impl
  • rmi
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
framework Directory Reference

Directories

directory jremote


JRemote: commons/src Directory Reference

  • commons
  • src
src Directory Reference

Directories

directory main


JRemote: api/src/main/java/org/pcsoft Directory Reference

  • api
  • src
  • main
  • java
  • org
  • pcsoft
pcsoft Directory Reference

Directories

directory framework


JRemote: plugins/np/impl/tcp Directory Reference

  • plugins
  • np
  • impl
  • tcp
tcp Directory Reference

Directories

directory src


JRemote: plugins Directory Reference

  • plugins
plugins Directory Reference

Directories

directory np


JRemote: plugins/np/impl/rmi/src/main Directory Reference

  • plugins
  • np
  • impl
  • rmi
  • src
  • main
main Directory Reference

Directories

directory java


JRemote: core/src Directory Reference

  • core
  • src
src Directory Reference

Directories

directory main


JRemote: plugins/np/api/src/main/java/org Directory Reference

  • plugins
  • np
  • api
  • src
  • main
  • java
  • org
org Directory Reference

Directories

directory pcsoft


JRemote: plugins/np/api/src/main/java/org/pcsoft/framework/jremote Directory Reference

  • plugins
  • np
  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
jremote Directory Reference

Directories

directory np


JRemote: plugins/np/api/src/main/java Directory Reference

  • plugins
  • np
  • api
  • src
  • main
  • java
java Directory Reference

Directories

directory org

Files

file module-info.java


JRemote: plugins/np/impl/tcp/src Directory Reference

  • plugins
  • np
  • impl
  • tcp
  • src
src Directory Reference

Directories

directory main


JRemote: plugins/np/impl/tcp/src/main/java/org/pcsoft/framework/jremote/np/impl/tcp/internal Directory Reference

  • plugins
  • np
  • impl
  • tcp
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • np
  • impl
  • tcp
  • internal
internal Directory Reference

Directories

directory type

Files

file TcpServer.java


JRemote: api/src/main/java/org/pcsoft/framework/jremote/api/internal Directory Reference

  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • internal
internal Directory Reference

Files

file | RemoteMethod.java
file | RemoteService.java


JRemote: core/src/main/java/org/pcsoft/framework/jremote Directory Reference

  • core
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
jremote Directory Reference

Directories

directory core


JRemote: plugins/np/impl/tcp/src/main/java/org Directory Reference

  • plugins
  • np
  • impl
  • tcp
  • src
  • main
  • java
  • org
org Directory Reference

Directories

directory pcsoft


JRemote: core/src/main/java/org/pcsoft/framework Directory Reference

  • core
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
framework Directory Reference

Directories

directory jremote


JRemote: plugins/np/impl/rmi/src/main/java/org/pcsoft/framework/jremote/np Directory Reference

  • plugins
  • np
  • impl
  • rmi
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • np
np Directory Reference

Directories

directory impl


JRemote: plugins/np Directory Reference

  • plugins
  • np
np Directory Reference

Directories

directory | api
directory | impl


JRemote: api/src Directory Reference

  • api
  • src
src Directory Reference

Directories

directory main


JRemote: core/src/main/java Directory Reference

  • core
  • src
  • main
  • java
java Directory Reference

Directories

directory org

Files

file module-info.java


JRemote: api/src/main/java/org/pcsoft/framework/jremote/api/exception Directory Reference

  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • exception
exception Directory Reference

Files

file | JRemoteAnnotationException.java
file | JRemoteConfigurationException.java
file | JRemoteException.java
file | JRemoteExecutionException.java


JRemote: core/src/main/java/org/pcsoft/framework/jremote/core/internal/proxy Directory Reference

  • core
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • internal
  • proxy
proxy Directory Reference

Files

file | ProxyBuilder.java
file | ProxyFactory.java
file | RemoteClientServiceProxyBuilder.java
file | RemoteEventReceiverProxyBuilder.java
file | RemoteEventServiceProxyBuilder.java
file | RemoteKeepAliveServiceProxyBuilder.java
file | RemoteListenerProxyBuilder.java
file | RemotePushModelProxyBuilder.java
file | RemotePushObserverProxyBuilder.java
file | RemotePushServiceProxyBuilder.java
file | RemoteRegistrationServiceProxyBuilder.java


JRemote: core/src/main/java/org/pcsoft/framework/jremote/core/internal Directory Reference

  • core
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • internal
internal Directory Reference

Directories

directory | handler
directory | manager
directory | processor
directory | proxy
directory | registry
directory | type
directory | validation


JRemote: plugins/np/impl/rmi/src/main/java/org/pcsoft Directory Reference

  • plugins
  • np
  • impl
  • rmi
  • src
  • main
  • java
  • org
  • pcsoft
pcsoft Directory Reference

Directories

directory framework


JRemote: core Directory Reference

  • core
core Directory Reference

Directories

directory src


JRemote: core/src/main/java/org/pcsoft Directory Reference

  • core
  • src
  • main
  • java
  • org
  • pcsoft
pcsoft Directory Reference

Directories

directory framework


JRemote: plugins/np/api/src/main/java/org/pcsoft/framework/jremote/np Directory Reference

  • plugins
  • np
  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • np
np Directory Reference

Directories

directory api


JRemote: core/src/main/java/org/pcsoft/framework/jremote/core/internal/type/wrapper Directory Reference

  • core
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • internal
  • type
  • wrapper
wrapper Directory Reference

Files

file | ClientWrapper.java
file | RemoteKeepAliveClientWrapper.java
file | RemoteRegistrationClientWrapper.java


JRemote: core/src/main/java/org Directory Reference

  • core
  • src
  • main
  • java
  • org
org Directory Reference

Directories

directory pcsoft


JRemote: core/src/main/java/org/pcsoft/framework/jremote/core Directory Reference

  • core
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • core
core Directory Reference

Directories

directory internal

Files

file | Client.java
file | ClientState.java
file | Remote.java
file | RemoteBuilder.java
file | RemoteClient.java
file | RemoteClientBuilder.java
file | RemoteServer.java
file | RemoteServerBuilder.java
file | ServerState.java
file | State.java


JRemote: plugins/np/impl/rmi/src/main/java/org/pcsoft/framework/jremote/np/impl/rmi/interf Directory Reference

  • plugins
  • np
  • impl
  • rmi
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • np
  • impl
  • rmi
  • interf
interf Directory Reference

Files

file | RmiKeepAliveService.java
file | RmiRegistrationService.java


JRemote: core/src/main/java/org/pcsoft/framework/jremote/core/internal/handler Directory Reference

  • core
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • internal
  • handler
handler Directory Reference

Files

file PushModelHandler.java


JRemote: Main Page

JRemote Documentation


JRemote: Member List

  • core
  • RemoteClient
  • ControlManager
org.pcsoft.framework.jremote.core.RemoteClient.ControlManager Member List

This is the complete list of members for org.pcsoft.framework.jremote.core.RemoteClient.ControlManager, including all inherited members.


JRemote: Member List

  • api
  • exception
  • JRemoteExecutionException
org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException, including all inherited members.

JRemoteException() (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(String message) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(String message, Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteExecutionException() (defined in org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException) | org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException
JRemoteExecutionException(String message) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException) | org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException
JRemoteExecutionException(String message, Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException) | org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException
JRemoteExecutionException(Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException) | org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException


JRemote: Member List

  • np
  • impl
  • rmi
  • interf
  • RmiRegistrationService
org.pcsoft.framework.jremote.np.impl.rmi.interf.RmiRegistrationService Member List

This is the complete list of members for org.pcsoft.framework.jremote.np.impl.rmi.interf.RmiRegistrationService, including all inherited members.

register(String uuid, String host, int port) (defined in org.pcsoft.framework.jremote.np.impl.rmi.interf.RmiRegistrationService) | org.pcsoft.framework.jremote.np.impl.rmi.interf.RmiRegistrationService
unregister(String uuid) (defined in org.pcsoft.framework.jremote.np.impl.rmi.interf.RmiRegistrationService) | org.pcsoft.framework.jremote.np.impl.rmi.interf.RmiRegistrationService


JRemote: Member List

  • api
  • Push
org.pcsoft.framework.jremote.api.Push Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.Push, including all inherited members.

modelClass() | org.pcsoft.framework.jremote.api.Push
property() | org.pcsoft.framework.jremote.api.Push
type() default PushMethodType.Default | org.pcsoft.framework.jremote.api.Push


JRemote: Member List

  • core
  • RemoteServerBuilder
org.pcsoft.framework.jremote.core.RemoteServerBuilder Member List

This is the complete list of members for org.pcsoft.framework.jremote.core.RemoteServerBuilder, including all inherited members.

build() (defined in org.pcsoft.framework.jremote.core.RemoteServerBuilder) | org.pcsoft.framework.jremote.core.RemoteServerBuilder |
create(String host, int port) (defined in org.pcsoft.framework.jremote.core.RemoteServerBuilder) | org.pcsoft.framework.jremote.core.RemoteServerBuilder | static
withControlService(Class<?>...controlServiceImplClasses) (defined in org.pcsoft.framework.jremote.core.RemoteServerBuilder) | org.pcsoft.framework.jremote.core.RemoteServerBuilder |
withControlService(Object...controlServiceImpls) (defined in org.pcsoft.framework.jremote.core.RemoteServerBuilder) | org.pcsoft.framework.jremote.core.RemoteServerBuilder |
withEventClient(Class<?>...eventClientClasses) (defined in org.pcsoft.framework.jremote.core.RemoteServerBuilder) | org.pcsoft.framework.jremote.core.RemoteServerBuilder |
withPushClient(Class<?>...pushClientClasses) (defined in org.pcsoft.framework.jremote.core.RemoteServerBuilder) | org.pcsoft.framework.jremote.core.RemoteServerBuilder |
withPushModelData(Class<?>...pushModelDataClasses) (defined in org.pcsoft.framework.jremote.core.RemoteServerBuilder) | org.pcsoft.framework.jremote.core.RemoteServerBuilder |
withPushModelData(Object...pushModelDataList) (defined in org.pcsoft.framework.jremote.core.RemoteServerBuilder) | org.pcsoft.framework.jremote.core.RemoteServerBuilder |


JRemote: Member List

  • np
  • impl
  • tcp
  • TcpService
org.pcsoft.framework.jremote.np.impl.tcp.TcpService Member List

This is the complete list of members for org.pcsoft.framework.jremote.np.impl.tcp.TcpService, including all inherited members.

close() (defined in org.pcsoft.framework.jremote.np.impl.tcp.TcpService) | org.pcsoft.framework.jremote.np.impl.tcp.TcpService
getServiceImplementation() | org.pcsoft.framework.jremote.np.api.ServiceBase
open(String host, int port) | org.pcsoft.framework.jremote.np.impl.tcp.TcpService
setServiceImplementation(Object serviceImplementation) | org.pcsoft.framework.jremote.np.api.ServiceBase


JRemote: Member List

  • api
  • exception
  • JRemoteException
org.pcsoft.framework.jremote.api.exception.JRemoteException Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.exception.JRemoteException, including all inherited members.

JRemoteException() (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(String message) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(String message, Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException


JRemote: Member List

  • commons
  • AnnotationUtils
org.pcsoft.framework.jremote.commons.AnnotationUtils Member List

This is the complete list of members for org.pcsoft.framework.jremote.commons.AnnotationUtils, including all inherited members.

getModelProperties(Class<?> clazz) (defined in org.pcsoft.framework.jremote.commons.AnnotationUtils) | org.pcsoft.framework.jremote.commons.AnnotationUtils | static
isModelProperty(Method method) (defined in org.pcsoft.framework.jremote.commons.AnnotationUtils) | org.pcsoft.framework.jremote.commons.AnnotationUtils | static
isRemoteMethod(Method method) (defined in org.pcsoft.framework.jremote.commons.AnnotationUtils) | org.pcsoft.framework.jremote.commons.AnnotationUtils | static
isRemoteModel(Class<?> clazz) (defined in org.pcsoft.framework.jremote.commons.AnnotationUtils) | org.pcsoft.framework.jremote.commons.AnnotationUtils | static
isRemoteService(Class<?> clazz) (defined in org.pcsoft.framework.jremote.commons.AnnotationUtils) | org.pcsoft.framework.jremote.commons.AnnotationUtils | static


JRemote: Member List

  • np
  • api
  • Service
org.pcsoft.framework.jremote.np.api.Service Member List

This is the complete list of members for org.pcsoft.framework.jremote.np.api.Service, including all inherited members.

getServiceImplementation() | org.pcsoft.framework.jremote.np.api.Service
open(String host, int port) | org.pcsoft.framework.jremote.np.api.Service
setServiceImplementation(Object serviceImplementation) | org.pcsoft.framework.jremote.np.api.Service


JRemote: Member List

  • np
  • impl
  • rmi
  • RmiPlugin
org.pcsoft.framework.jremote.np.impl.rmi.RmiPlugin Member List

This is the complete list of members for org.pcsoft.framework.jremote.np.impl.rmi.RmiPlugin, including all inherited members.

getClientClass() | org.pcsoft.framework.jremote.np.impl.rmi.RmiPlugin
getKeepAliveServiceClass() | org.pcsoft.framework.jremote.np.impl.rmi.RmiPlugin
getRegistrationServiceClass() | org.pcsoft.framework.jremote.np.impl.rmi.RmiPlugin
getServiceClass() | org.pcsoft.framework.jremote.np.impl.rmi.RmiPlugin


JRemote: Member List

  • np
  • api
  • annotation
  • Registration
org.pcsoft.framework.jremote.np.api.annotation.Registration Member List

This is the complete list of members for org.pcsoft.framework.jremote.np.api.annotation.Registration, including all inherited members.

value() org.pcsoft.framework.jremote.np.api.annotation.Registration


JRemote: Member List

  • api
  • exception
  • JRemoteConfigurationException
org.pcsoft.framework.jremote.api.exception.JRemoteConfigurationException Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.exception.JRemoteConfigurationException, including all inherited members.

JRemoteConfigurationException() (defined in org.pcsoft.framework.jremote.api.exception.JRemoteConfigurationException) | org.pcsoft.framework.jremote.api.exception.JRemoteConfigurationException
JRemoteConfigurationException(String message) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteConfigurationException) | org.pcsoft.framework.jremote.api.exception.JRemoteConfigurationException
JRemoteConfigurationException(String message, Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteConfigurationException) | org.pcsoft.framework.jremote.api.exception.JRemoteConfigurationException
JRemoteConfigurationException(Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteConfigurationException) | org.pcsoft.framework.jremote.api.exception.JRemoteConfigurationException
JRemoteException() (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(String message) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(String message, Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException


JRemote: Member List

  • np
  • impl
  • rmi
  • interf
  • RmiKeepAliveService
org.pcsoft.framework.jremote.np.impl.rmi.interf.RmiKeepAliveService Member List

This is the complete list of members for org.pcsoft.framework.jremote.np.impl.rmi.interf.RmiKeepAliveService, including all inherited members.

ping(String uuid) (defined in org.pcsoft.framework.jremote.np.impl.rmi.interf.RmiKeepAliveService) org.pcsoft.framework.jremote.np.impl.rmi.interf.RmiKeepAliveService


JRemote: Member List

  • np
  • impl
  • tcp
  • TcpPlugin
org.pcsoft.framework.jremote.np.impl.tcp.TcpPlugin Member List

This is the complete list of members for org.pcsoft.framework.jremote.np.impl.tcp.TcpPlugin, including all inherited members.

getClientClass() | org.pcsoft.framework.jremote.np.impl.tcp.TcpPlugin
getKeepAliveServiceClass() | org.pcsoft.framework.jremote.np.impl.tcp.TcpPlugin
getRegistrationServiceClass() | org.pcsoft.framework.jremote.np.impl.tcp.TcpPlugin
getServiceClass() | org.pcsoft.framework.jremote.np.impl.tcp.TcpPlugin


JRemote: Member List

  • api
  • exception
  • JRemoteAnnotationException
org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException, including all inherited members.

JRemoteAnnotationException() (defined in org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException) | org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException
JRemoteAnnotationException(String message) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException) | org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException
JRemoteAnnotationException(String message, Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException) | org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException
JRemoteAnnotationException(Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException) | org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException
JRemoteException() (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(String message) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(String message, Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException


JRemote: Member List

  • commons
  • ReflectionUtils
org.pcsoft.framework.jremote.commons.ReflectionUtils Member List

This is the complete list of members for org.pcsoft.framework.jremote.commons.ReflectionUtils, including all inherited members.

findInterfaces(Class<?> clazz) (defined in org.pcsoft.framework.jremote.commons.ReflectionUtils) | org.pcsoft.framework.jremote.commons.ReflectionUtils | static
findInterfaces(Class<?> clazz, Predicate< Class<?>> validator) (defined in org.pcsoft.framework.jremote.commons.ReflectionUtils) | org.pcsoft.framework.jremote.commons.ReflectionUtils | static


JRemote: Member List

  • np
  • api
  • NetworkProtocolPlugin
org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin Member List

This is the complete list of members for org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin, including all inherited members.

getClientClass() | org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin
getKeepAliveServiceClass() | org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin
getRegistrationServiceClass() | org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin
getServiceClass() | org.pcsoft.framework.jremote.np.api.NetworkProtocolPlugin


JRemote: Member List

  • np
  • api
  • ServiceBase
org.pcsoft.framework.jremote.np.api.ServiceBase Member List

This is the complete list of members for org.pcsoft.framework.jremote.np.api.ServiceBase, including all inherited members.

getServiceImplementation() | org.pcsoft.framework.jremote.np.api.ServiceBase
open(String host, int port) | org.pcsoft.framework.jremote.np.api.Service
setServiceImplementation(Object serviceImplementation) | org.pcsoft.framework.jremote.np.api.ServiceBase


JRemote: Member List

  • core
  • RemoteServer
org.pcsoft.framework.jremote.core.RemoteServer Member List

This is the complete list of members for org.pcsoft.framework.jremote.core.RemoteServer, including all inherited members.

addClientRegisteredListener(Consumer< Client > l) (defined in org.pcsoft.framework.jremote.core.RemoteServer) | org.pcsoft.framework.jremote.core.RemoteServer
addClientUnregisteredListener(Consumer< Client > l) (defined in org.pcsoft.framework.jremote.core.RemoteServer) | org.pcsoft.framework.jremote.core.RemoteServer
addStateChangeListener(Consumer< ServerState > l) (defined in org.pcsoft.framework.jremote.core.RemoteServer) | org.pcsoft.framework.jremote.core.RemoteServer
addStateChangeListener(Consumer< S > l) (defined in org.pcsoft.framework.jremote.core.Remote< ServerState >) | org.pcsoft.framework.jremote.core.Remote< ServerState >
close() (defined in org.pcsoft.framework.jremote.core.RemoteServer) | org.pcsoft.framework.jremote.core.RemoteServer
getBroadcast() (defined in org.pcsoft.framework.jremote.core.RemoteServer) | org.pcsoft.framework.jremote.core.RemoteServer
getConnectedClients() (defined in org.pcsoft.framework.jremote.core.RemoteServer) | org.pcsoft.framework.jremote.core.RemoteServer
getHost() (defined in org.pcsoft.framework.jremote.core.RemoteServer) | org.pcsoft.framework.jremote.core.RemoteServer
getPort() (defined in org.pcsoft.framework.jremote.core.RemoteServer) | org.pcsoft.framework.jremote.core.RemoteServer
getState() (defined in org.pcsoft.framework.jremote.core.RemoteServer) | org.pcsoft.framework.jremote.core.RemoteServer
open() (defined in org.pcsoft.framework.jremote.core.RemoteServer) | org.pcsoft.framework.jremote.core.RemoteServer
removeClientRegisteredListener(Consumer< Client > l) (defined in org.pcsoft.framework.jremote.core.RemoteServer) | org.pcsoft.framework.jremote.core.RemoteServer
removeClientUnregisteredListener(Consumer< Client > l) (defined in org.pcsoft.framework.jremote.core.RemoteServer) | org.pcsoft.framework.jremote.core.RemoteServer
removeStateChangeListener(Consumer< ServerState > l) (defined in org.pcsoft.framework.jremote.core.RemoteServer) | org.pcsoft.framework.jremote.core.RemoteServer
removeStateChangeListener(Consumer< S > l) (defined in org.pcsoft.framework.jremote.core.Remote< ServerState >) | org.pcsoft.framework.jremote.core.Remote< ServerState >


JRemote: Member List

  • api
  • PushModelProperty
org.pcsoft.framework.jremote.api.PushModelProperty Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.PushModelProperty, including all inherited members.

value() org.pcsoft.framework.jremote.api.PushModelProperty


JRemote: Member List

  • core
  • RemoteBuilder
org.pcsoft.framework.jremote.core.RemoteBuilder< T extends Remote > Member List

This is the complete list of members for org.pcsoft.framework.jremote.core.RemoteBuilder< T extends Remote >, including all inherited members.

build() (defined in org.pcsoft.framework.jremote.core.RemoteBuilder< T extends Remote >) org.pcsoft.framework.jremote.core.RemoteBuilder< T extends Remote >


JRemote: Member List

  • np
  • api
  • annotation
  • Registration
  • RegistrationType
org.pcsoft.framework.jremote.np.api.annotation.Registration.RegistrationType Member List

This is the complete list of members for org.pcsoft.framework.jremote.np.api.annotation.Registration.RegistrationType, including all inherited members.

Register | org.pcsoft.framework.jremote.np.api.annotation.Registration.RegistrationType
Unregister | org.pcsoft.framework.jremote.np.api.annotation.Registration.RegistrationType


JRemote: Member List

  • core
  • RemoteClientBuilder
org.pcsoft.framework.jremote.core.RemoteClientBuilder Member List

This is the complete list of members for org.pcsoft.framework.jremote.core.RemoteClientBuilder, including all inherited members.

build() (defined in org.pcsoft.framework.jremote.core.RemoteClientBuilder) | org.pcsoft.framework.jremote.core.RemoteClientBuilder |
create(String host, int port, int ownPort) (defined in org.pcsoft.framework.jremote.core.RemoteClientBuilder) | org.pcsoft.framework.jremote.core.RemoteClientBuilder | static
withRemoteControlClient(Class<?>...controlClientClasses) (defined in org.pcsoft.framework.jremote.core.RemoteClientBuilder) | org.pcsoft.framework.jremote.core.RemoteClientBuilder |
withRemoteEventObserver(Class<?>...eventObserverClasses) (defined in org.pcsoft.framework.jremote.core.RemoteClientBuilder) | org.pcsoft.framework.jremote.core.RemoteClientBuilder |
withRemoteEventService(Class<?>...eventServiceClasses) (defined in org.pcsoft.framework.jremote.core.RemoteClientBuilder) | org.pcsoft.framework.jremote.core.RemoteClientBuilder |
withRemotePushModel(Class<?>...pushModelClasses) (defined in org.pcsoft.framework.jremote.core.RemoteClientBuilder) | org.pcsoft.framework.jremote.core.RemoteClientBuilder |
withRemotePushObserver(Class<?>...pushObserverClasses) (defined in org.pcsoft.framework.jremote.core.RemoteClientBuilder) | org.pcsoft.framework.jremote.core.RemoteClientBuilder |
withRemotePushService(Class<?>...pushServiceClasses) (defined in org.pcsoft.framework.jremote.core.RemoteClientBuilder) | org.pcsoft.framework.jremote.core.RemoteClientBuilder |


JRemote: Member List

  • api
  • type
  • PushMethodType
org.pcsoft.framework.jremote.api.type.PushMethodType Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.type.PushMethodType, including all inherited members.

Default | org.pcsoft.framework.jremote.api.type.PushMethodType
SingleListItem | org.pcsoft.framework.jremote.api.type.PushMethodType


JRemote: Member List

  • api
  • type
  • ObserverListenerType
org.pcsoft.framework.jremote.api.type.ObserverListenerType Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.type.ObserverListenerType, including all inherited members.

Add | org.pcsoft.framework.jremote.api.type.ObserverListenerType
AutoDetection | org.pcsoft.framework.jremote.api.type.ObserverListenerType
Remove | org.pcsoft.framework.jremote.api.type.ObserverListenerType


JRemote: Member List

  • np
  • impl
  • rmi
  • RmiClient
org.pcsoft.framework.jremote.np.impl.rmi.RmiClient Member List

This is the complete list of members for org.pcsoft.framework.jremote.np.impl.rmi.RmiClient, including all inherited members.

close() (defined in org.pcsoft.framework.jremote.np.impl.rmi.RmiClient) | org.pcsoft.framework.jremote.np.impl.rmi.RmiClient
getServiceClass() | org.pcsoft.framework.jremote.np.api.ClientBase
invokeRemote(Method method, Object...params) | org.pcsoft.framework.jremote.np.impl.rmi.RmiClient
open(String host, int port) | org.pcsoft.framework.jremote.np.impl.rmi.RmiClient
setServiceClass(Class<?> serviceClass) | org.pcsoft.framework.jremote.np.api.ClientBase


JRemote: Member List

  • core
  • Client
org.pcsoft.framework.jremote.core.Client Member List

This is the complete list of members for org.pcsoft.framework.jremote.core.Client, including all inherited members.

Client(String host, int port) (defined in org.pcsoft.framework.jremote.core.Client) | org.pcsoft.framework.jremote.core.Client
getHost() (defined in org.pcsoft.framework.jremote.core.Client) | org.pcsoft.framework.jremote.core.Client
getPort() (defined in org.pcsoft.framework.jremote.core.Client) | org.pcsoft.framework.jremote.core.Client


JRemote: Member List

  • api
  • PushObserverListener
org.pcsoft.framework.jremote.api.PushObserverListener Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.PushObserverListener, including all inherited members.

listenerType() default ObserverListenerType.AutoDetection | org.pcsoft.framework.jremote.api.PushObserverListener
modelClass() | org.pcsoft.framework.jremote.api.PushObserverListener
property() | org.pcsoft.framework.jremote.api.PushObserverListener


JRemote: Member List

  • np
  • impl
  • rmi
  • RmiService
org.pcsoft.framework.jremote.np.impl.rmi.RmiService Member List

This is the complete list of members for org.pcsoft.framework.jremote.np.impl.rmi.RmiService, including all inherited members.

close() (defined in org.pcsoft.framework.jremote.np.impl.rmi.RmiService) | org.pcsoft.framework.jremote.np.impl.rmi.RmiService
getServiceImplementation() | org.pcsoft.framework.jremote.np.api.ServiceBase
open(String host, int port) | org.pcsoft.framework.jremote.np.impl.rmi.RmiService
setServiceImplementation(Object serviceImplementation) | org.pcsoft.framework.jremote.np.api.ServiceBase


JRemote: Member List

  • api
  • type
  • PushChangedListener
org.pcsoft.framework.jremote.api.type.PushChangedListener Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.type.PushChangedListener, including all inherited members.

onChange() org.pcsoft.framework.jremote.api.type.PushChangedListener


JRemote: Member List

  • core
  • RemoteServer
  • BroadcastManager
org.pcsoft.framework.jremote.core.RemoteServer.BroadcastManager Member List

This is the complete list of members for org.pcsoft.framework.jremote.core.RemoteServer.BroadcastManager, including all inherited members.


JRemote: Member List

  • np
  • api
  • ClientBase
org.pcsoft.framework.jremote.np.api.ClientBase Member List

This is the complete list of members for org.pcsoft.framework.jremote.np.api.ClientBase, including all inherited members.

getServiceClass() | org.pcsoft.framework.jremote.np.api.ClientBase
invokeRemote(Method method, Object...params) | org.pcsoft.framework.jremote.np.api.Client
open(String host, int port) | org.pcsoft.framework.jremote.np.api.Client
setServiceClass(Class<?> serviceClass) | org.pcsoft.framework.jremote.np.api.ClientBase


JRemote: Member List

  • np
  • impl
  • tcp
  • internal
  • TcpServer
org.pcsoft.framework.jremote.np.impl.tcp.internal.TcpServer Member List

This is the complete list of members for org.pcsoft.framework.jremote.np.impl.tcp.internal.TcpServer, including all inherited members.

acceptAndHandle() (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.TcpServer) | org.pcsoft.framework.jremote.np.impl.tcp.internal.TcpServer
TcpServer(ServerSocket serverSocket, Function< Invocation, Object > invocationCallback) (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.TcpServer) | org.pcsoft.framework.jremote.np.impl.tcp.internal.TcpServer


JRemote: Member List

  • api
  • type
  • PushItemUpdate
org.pcsoft.framework.jremote.api.type.PushItemUpdate Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.type.PushItemUpdate, including all inherited members.

Add (defined in org.pcsoft.framework.jremote.api.type.PushItemUpdate) | org.pcsoft.framework.jremote.api.type.PushItemUpdate
Remove (defined in org.pcsoft.framework.jremote.api.type.PushItemUpdate) | org.pcsoft.framework.jremote.api.type.PushItemUpdate
Update (defined in org.pcsoft.framework.jremote.api.type.PushItemUpdate) | org.pcsoft.framework.jremote.api.type.PushItemUpdate


JRemote: Member List

  • api
  • Event
org.pcsoft.framework.jremote.api.Event Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.Event, including all inherited members.

event() | org.pcsoft.framework.jremote.api.Event
eventClass() | org.pcsoft.framework.jremote.api.Event


JRemote: Member List

  • np
  • impl
  • tcp
  • internal
  • type
  • Invocation
org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Invocation Member List

This is the complete list of members for org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Invocation, including all inherited members.

getMethodName() (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Invocation) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Invocation
getParameterClasses() (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Invocation) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Invocation
getParameters() (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Invocation) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Invocation
getParameterValues() (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Invocation) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Invocation
getReturnType() (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Invocation) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Invocation
Invocation(String methodName, Type returnType, Parameter...parameters) (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Invocation) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Invocation


JRemote: Member List

  • api
  • type
  • EventReceivedListener
org.pcsoft.framework.jremote.api.type.EventReceivedListener< T > Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.type.EventReceivedListener< T >, including all inherited members.

onChange(T value) org.pcsoft.framework.jremote.api.type.EventReceivedListener< T >


JRemote: Member List

  • core
  • RemoteClient
org.pcsoft.framework.jremote.core.RemoteClient Member List

This is the complete list of members for org.pcsoft.framework.jremote.core.RemoteClient, including all inherited members.

addStateChangeListener(Consumer< ClientState > l) (defined in org.pcsoft.framework.jremote.core.RemoteClient) | org.pcsoft.framework.jremote.core.RemoteClient
addStateChangeListener(Consumer< S > l) (defined in org.pcsoft.framework.jremote.core.Remote< ClientState >) | org.pcsoft.framework.jremote.core.Remote< ClientState >
close() (defined in org.pcsoft.framework.jremote.core.RemoteClient) | org.pcsoft.framework.jremote.core.RemoteClient
getControl() (defined in org.pcsoft.framework.jremote.core.RemoteClient) | org.pcsoft.framework.jremote.core.RemoteClient
getData() (defined in org.pcsoft.framework.jremote.core.RemoteClient) | org.pcsoft.framework.jremote.core.RemoteClient
getHost() (defined in org.pcsoft.framework.jremote.core.RemoteClient) | org.pcsoft.framework.jremote.core.RemoteClient
getOwnPort() (defined in org.pcsoft.framework.jremote.core.RemoteClient) | org.pcsoft.framework.jremote.core.RemoteClient
getPort() (defined in org.pcsoft.framework.jremote.core.RemoteClient) | org.pcsoft.framework.jremote.core.RemoteClient
getState() (defined in org.pcsoft.framework.jremote.core.RemoteClient) | org.pcsoft.framework.jremote.core.RemoteClient
getUuid() (defined in org.pcsoft.framework.jremote.core.RemoteClient) | org.pcsoft.framework.jremote.core.RemoteClient
open() (defined in org.pcsoft.framework.jremote.core.RemoteClient) | org.pcsoft.framework.jremote.core.RemoteClient
removeStateChangeListener(Consumer< ClientState > l) (defined in org.pcsoft.framework.jremote.core.RemoteClient) | org.pcsoft.framework.jremote.core.RemoteClient
removeStateChangeListener(Consumer< S > l) (defined in org.pcsoft.framework.jremote.core.Remote< ClientState >) | org.pcsoft.framework.jremote.core.Remote< ClientState >


JRemote: Member List

  • np
  • impl
  • tcp
  • TcpClient
org.pcsoft.framework.jremote.np.impl.tcp.TcpClient Member List

This is the complete list of members for org.pcsoft.framework.jremote.np.impl.tcp.TcpClient, including all inherited members.

close() (defined in org.pcsoft.framework.jremote.np.impl.tcp.TcpClient) | org.pcsoft.framework.jremote.np.impl.tcp.TcpClient
getServiceClass() | org.pcsoft.framework.jremote.np.api.ClientBase
invokeRemote(Method method, Object...params) | org.pcsoft.framework.jremote.np.impl.tcp.TcpClient
open(String host, int port) | org.pcsoft.framework.jremote.np.impl.tcp.TcpClient
setServiceClass(Class<?> serviceClass) | org.pcsoft.framework.jremote.np.api.ClientBase


JRemote: Member List

  • core
  • Remote
org.pcsoft.framework.jremote.core.Remote< S extends State > Member List

This is the complete list of members for org.pcsoft.framework.jremote.core.Remote< S extends State >, including all inherited members.

addStateChangeListener(Consumer< S > l) (defined in org.pcsoft.framework.jremote.core.Remote< S extends State >) | org.pcsoft.framework.jremote.core.Remote< S extends State >
getHost() (defined in org.pcsoft.framework.jremote.core.Remote< S extends State >) | org.pcsoft.framework.jremote.core.Remote< S extends State >
getPort() (defined in org.pcsoft.framework.jremote.core.Remote< S extends State >) | org.pcsoft.framework.jremote.core.Remote< S extends State >
getState() (defined in org.pcsoft.framework.jremote.core.Remote< S extends State >) | org.pcsoft.framework.jremote.core.Remote< S extends State >
open() (defined in org.pcsoft.framework.jremote.core.Remote< S extends State >) | org.pcsoft.framework.jremote.core.Remote< S extends State >
removeStateChangeListener(Consumer< S > l) (defined in org.pcsoft.framework.jremote.core.Remote< S extends State >) | org.pcsoft.framework.jremote.core.Remote< S extends State >


JRemote: Member List

  • np
  • impl
  • tcp
  • internal
  • type
  • Type
org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type Member List

This is the complete list of members for org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type, including all inherited members.

Byte (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
ByteType (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
Character (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
CharacterType (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
Complex (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
Double (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
DoubleType (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
Float (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
FloatType (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
fromValue(byte value) (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type | static
getClazz() (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
getValue() (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
Integer (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
IntegerType (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
Long (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
LongType (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
Short (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
ShortType (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
SignedByte (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
SignedByteType (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
String (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
Type(byte value, Class<?> clazz) (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
UnsignedDouble (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
UnsignedDoubleType (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
UnsignedFloat (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
UnsignedFloatType (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
UnsignedInteger (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
UnsignedIntegerType (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
UnsignedLong (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
UnsignedLongType (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
UnsignedShort (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
UnsignedShortType (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |
Void (defined in org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type) | org.pcsoft.framework.jremote.np.impl.tcp.internal.type.Type |


JRemote: Member List

  • np
  • api
  • Client
org.pcsoft.framework.jremote.np.api.Client Member List

This is the complete list of members for org.pcsoft.framework.jremote.np.api.Client, including all inherited members.

getServiceClass() | org.pcsoft.framework.jremote.np.api.Client
invokeRemote(Method method, Object...params) | org.pcsoft.framework.jremote.np.api.Client
open(String host, int port) | org.pcsoft.framework.jremote.np.api.Client
setServiceClass(Class<?> serviceClass) | org.pcsoft.framework.jremote.np.api.Client


JRemote: Member List

  • core
  • ClientState
org.pcsoft.framework.jremote.core.ClientState Member List

This is the complete list of members for org.pcsoft.framework.jremote.core.ClientState, including all inherited members.

Connected (defined in org.pcsoft.framework.jremote.core.ClientState) | org.pcsoft.framework.jremote.core.ClientState
Disconnected (defined in org.pcsoft.framework.jremote.core.ClientState) | org.pcsoft.framework.jremote.core.ClientState
Unknown (defined in org.pcsoft.framework.jremote.core.ClientState) | org.pcsoft.framework.jremote.core.ClientState


JRemote: Member List

  • api
  • EventReceiverListener
org.pcsoft.framework.jremote.api.EventReceiverListener Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.EventReceiverListener, including all inherited members.

listenerType() default ObserverListenerType.AutoDetection | org.pcsoft.framework.jremote.api.EventReceiverListener
value() | org.pcsoft.framework.jremote.api.EventReceiverListener


JRemote: Member List

  • core
  • RemoteClient
  • DataManager
org.pcsoft.framework.jremote.core.RemoteClient.DataManager Member List

This is the complete list of members for org.pcsoft.framework.jremote.core.RemoteClient.DataManager, including all inherited members.


JRemote: Member List

  • core
  • ServerState
org.pcsoft.framework.jremote.core.ServerState Member List

This is the complete list of members for org.pcsoft.framework.jremote.core.ServerState, including all inherited members.

Closed (defined in org.pcsoft.framework.jremote.core.ServerState) | org.pcsoft.framework.jremote.core.ServerState
Opened (defined in org.pcsoft.framework.jremote.core.ServerState) | org.pcsoft.framework.jremote.core.ServerState