JRemote: Class List

JRemote 0.2.0
  • Main Page
  • Classes
  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12345678910]
▼N org
▼N pcsoft
▼N framework
▼N jremote
▼N api
▼N exception
C JRemoteAnnotationException
C JRemoteException
C JRemoteExecutionException
C JRemoteExtensionException
▼N type
C EventReceivedListener
C ObserverListenerType
C PushChangedListener
C PushItemUpdate
C PushMethodType
C RemoteListener
C Control
C Event
C EventReceiverListener
C Push
C PushModelProperty
C PushObserverListener
C RemoteControlService
C RemoteEventReceiver
C RemoteEventService
C RemotePushModel
C RemotePushObserver
C RemotePushService
▼N commons
C AnnotationUtils
C ReflectionUtils
▼N core
C Client
C ClientState
C LifecycleState
C Remote
C RemoteBase
C RemoteBuilder
▼C RemoteClient
C ControlManager
C DataManager
C RemoteClientBuilder
▼C RemoteServer
C BroadcastManager
C RemoteServerBuilder
C ServerState
C State
▼N ext
▼N config
▼N api
▼N exception
C JRemoteConfigurationException
C ClientConfiguration
C RemoteConfiguration
C ServerConfiguration
▼N impl
▼N fluent
C ClientFluentConfiguration
C RemoteFluentConfiguration
C ServerFluentConfiguration
▼N prop
C ClientPropertyConfiguration
C RemotePropertyConfiguration
C ServerPropertyConfiguration
▼N xml
C ClientXmlConfiguration
C RemoteXmlConfiguration
C ServerXmlConfiguration
▼N np
▼N api
▼N annotation
C KeepAlive
▼C Registration
C RegistrationType
C RemoteKeepAliveService
C RemoteRegistrationService
▼N exception
C JRemoteNetworkProtocolException
C Client
C ClientBase
C NetworkProtocol
C Service
C ServiceBase
▼N impl
▼N rmi
C RmiProtocol
Generated by doxygen 1.8.10


JRemote: org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • exception
  • JRemoteAnnotationException
Public Member Functions | List of all members
org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException:
org.pcsoft.framework.jremote.api.exception.JRemoteException

Public Member Functions

JRemoteAnnotationException (String message)
JRemoteAnnotationException (String message, Throwable cause)
JRemoteAnnotationException (Throwable cause)
- Public Member Functions inherited from org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException (String message)
JRemoteException (String message, Throwable cause)
JRemoteException (Throwable cause)
The documentation for this class was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/exception/JRemoteAnnotationException.java


JRemote: org.pcsoft.framework.jremote.api.exception.JRemoteException Class Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • exception
  • JRemoteException
Public Member Functions | List of all members
org.pcsoft.framework.jremote.api.exception.JRemoteException Class Referenceabstract
Inheritance diagram for org.pcsoft.framework.jremote.api.exception.JRemoteException:
org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException org.pcsoft.framework.jremote.ext.config.api.exception.JRemoteConfigurationException org.pcsoft.framework.jremote.ext.np.api.exception.JRemoteNetworkProtocolException

Public Member Functions

JRemoteException (String message)
JRemoteException (String message, Throwable cause)
JRemoteException (Throwable cause)
The documentation for this class was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/exception/JRemoteException.java


JRemote: org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException Class Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • exception
  • JRemoteExecutionException
Public Member Functions | List of all members
org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException:
org.pcsoft.framework.jremote.api.exception.JRemoteException

Public Member Functions

JRemoteExecutionException (String message)
JRemoteExecutionException (String message, Throwable cause)
JRemoteExecutionException (Throwable cause)
- Public Member Functions inherited from org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException (String message)
JRemoteException (String message, Throwable cause)
JRemoteException (Throwable cause)
The documentation for this class was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/exception/JRemoteExecutionException.java


JRemote: org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException Class Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • exception
  • JRemoteExtensionException
Public Member Functions | List of all members
org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException Class Referenceabstract
Inheritance diagram for org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException:
org.pcsoft.framework.jremote.api.exception.JRemoteException org.pcsoft.framework.jremote.ext.config.api.exception.JRemoteConfigurationException org.pcsoft.framework.jremote.ext.np.api.exception.JRemoteNetworkProtocolException

Public Member Functions

JRemoteExtensionException (String message)
JRemoteExtensionException (String message, Throwable cause)
JRemoteExtensionException (Throwable cause)
- Public Member Functions inherited from org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException (String message)
JRemoteException (String message, Throwable cause)
JRemoteException (Throwable cause)
The documentation for this class was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/exception/JRemoteExtensionException.java


JRemote: org.pcsoft.framework.jremote.api.type.EventReceivedListener< T > Interface Template Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • type
  • EventReceivedListener
Public Member Functions | List of all members
org.pcsoft.framework.jremote.api.type.EventReceivedListener< T > Interface Template Reference
Inheritance diagram for org.pcsoft.framework.jremote.api.type.EventReceivedListener< T >:
org.pcsoft.framework.jremote.api.type.RemoteListener

Public Member Functions

void onChange (T value)

Detailed Description

Functional interface for the event observer listener method(s) to observe data from org.pcsoft.framework.jremote.api.RemoteEventService. Method with this parameter must be annotated with EventReceiverListener.

Member Function Documentation

void org.pcsoft.framework.jremote.api.type.EventReceivedListener< T >.onChange ( T value )

Is called if the linked event is called, see EventReceiverListener

Parameters
value New event value was received from org.pcsoft.framework.jremote.api.RemoteEventService
The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/type/EventReceivedListener.java


JRemote: org.pcsoft.framework.jremote.api.type.ObserverListenerType Enum Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • type
  • ObserverListenerType
Public Attributes | List of all members
org.pcsoft.framework.jremote.api.type.ObserverListenerType Enum Reference

Public Attributes

AutoDetection
Add
Remove

Detailed Description

Type of observer listener

Member Data Documentation

org.pcsoft.framework.jremote.api.type.ObserverListenerType.Add

Mark as 'add' listener method

org.pcsoft.framework.jremote.api.type.ObserverListenerType.AutoDetection

Automatic detection via start with 'add' or 'remove' (default)

org.pcsoft.framework.jremote.api.type.ObserverListenerType.Remove

Mark as 'remove' listener method

The documentation for this enum was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/type/ObserverListenerType.java


JRemote: org.pcsoft.framework.jremote.api.type.PushChangedListener Interface Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • type
  • PushChangedListener
Public Member Functions | List of all members
org.pcsoft.framework.jremote.api.type.PushChangedListener Interface Reference
Inheritance diagram for org.pcsoft.framework.jremote.api.type.PushChangedListener:
org.pcsoft.framework.jremote.api.type.RemoteListener

Public Member Functions

void onChange ()

Detailed Description

Functional interface for the push observer listener method(s) to observe data changes in org.pcsoft.framework.jremote.api.RemotePushModel from org.pcsoft.framework.jremote.api.RemotePushService. Method with this parameter must be annotated with org.pcsoft.framework.jremote.api.PushObserverListener.

Member Function Documentation

void org.pcsoft.framework.jremote.api.type.PushChangedListener.onChange ( )

Is called if the linked value has changed, see org.pcsoft.framework.jremote.api.PushObserverListener

The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/type/PushChangedListener.java


JRemote: org.pcsoft.framework.jremote.api.type.PushItemUpdate Enum Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • type
  • PushItemUpdate
Public Attributes | List of all members
org.pcsoft.framework.jremote.api.type.PushItemUpdate Enum Reference

Public Attributes

Add
Update
Remove
The documentation for this enum was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/type/PushItemUpdate.java


JRemote: org.pcsoft.framework.jremote.api.type.PushMethodType Enum Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • type
  • PushMethodType
Public Attributes | List of all members
org.pcsoft.framework.jremote.api.type.PushMethodType Enum Reference

Public Attributes

Default
SingleListItem

Detailed Description

Type of push method

Member Data Documentation

org.pcsoft.framework.jremote.api.type.PushMethodType.Default

A default field is pushed / updated (contains complete list and array updates)

org.pcsoft.framework.jremote.api.type.PushMethodType.SingleListItem

A single item of a list / array is pushed / updated, see PushItemUpdate

The documentation for this enum was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/type/PushMethodType.java


JRemote: org.pcsoft.framework.jremote.api.type.RemoteListener Interface Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • type
  • RemoteListener
org.pcsoft.framework.jremote.api.type.RemoteListener Interface Reference
Inheritance diagram for org.pcsoft.framework.jremote.api.type.RemoteListener:
org.pcsoft.framework.jremote.api.type.EventReceivedListener< T > org.pcsoft.framework.jremote.api.type.PushChangedListener

Detailed Description

Marker interface for a changed listener

The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/type/RemoteListener.java


JRemote: org.pcsoft.framework.jremote.api.Control Interface Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • Control
org.pcsoft.framework.jremote.api.Control Interface Reference

Detailed Description

Annotation to mark a method in a RemoteControlService as a control method

The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/Control.java


JRemote: org.pcsoft.framework.jremote.api.Event Interface Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • Event
Public Member Functions | List of all members
org.pcsoft.framework.jremote.api.Event Interface Reference

Public Member Functions

String | event ()
Class<?> | eventClass ()

Detailed Description

Mark a method in an interface as event method. Interface must be annotated with RemoteEventService.

Member Function Documentation

String org.pcsoft.framework.jremote.api.Event.event ( )

The name of the event in RemoteEventReceiver to deliver to, see EventReceiverListener#value()

Returns
Class<?> org.pcsoft.framework.jremote.api.Event.eventClass ( )

The class of RemoteEventReceiver within the event() to deliver to, see EventReceiverListener

Returns
The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/Event.java


JRemote: org.pcsoft.framework.jremote.api.EventReceiverListener Interface Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • EventReceiverListener
Public Member Functions | List of all members
org.pcsoft.framework.jremote.api.EventReceiverListener Interface Reference

Public Member Functions

String | value ()
ObserverListenerType | listenerType () default ObserverListenerType.AutoDetection

Detailed Description

Mark a method in an interface as listener method for a event call, see RemoteEventService. Interface must be annotated with RemoteEventReceiver.

The method signature must build with a void return type and one argument of type EventReceivedListener:
void addListener(EventReceivedListener<?> l)

Member Function Documentation

ObserverListenerType org.pcsoft.framework.jremote.api.EventReceiverListener.listenerType ( )

Setup the type of listener method like 'add' or 'remove' (Default is ObserverListenerType#AutoDetection)

Returns
String org.pcsoft.framework.jremote.api.EventReceiverListener.value ( )

The name of this event to receive from RemoteEventService, see Event

Returns
The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/EventReceiverListener.java


JRemote: org.pcsoft.framework.jremote.api.Push Interface Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • Push
Public Member Functions | List of all members
org.pcsoft.framework.jremote.api.Push Interface Reference

Public Member Functions

String | property ()
Class<?> | modelClass ()
PushMethodType | type () default PushMethodType.Default

Detailed Description

Mark a method in an interface as push method. Interface must be annotated with RemotePushService.

Member Function Documentation

Class<?> org.pcsoft.framework.jremote.api.Push.modelClass ( )

The class of the RemotePushModel within the property() the observer listener listen to, see PushModelProperty

Returns
String org.pcsoft.framework.jremote.api.Push.property ( )

The name of the RemotePushModel property the observer listener listen to, see PushModelProperty#value()

Returns
PushMethodType org.pcsoft.framework.jremote.api.Push.type ( )

Type of push update, see PushMethodType for more information.

Returns
The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/Push.java


JRemote: org.pcsoft.framework.jremote.api.PushModelProperty Interface Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • PushModelProperty
Public Member Functions | List of all members
org.pcsoft.framework.jremote.api.PushModelProperty Interface Reference

Public Member Functions

String value ()

Detailed Description

Mark a getter method in an interface as model based property. The interface must be annotated with RemotePushModel.

Member Function Documentation

String org.pcsoft.framework.jremote.api.PushModelProperty.value ( )

The name of the model property. Used for referencing from RemotePushService or RemotePushObserver class, see Push or PushObserverListener

Returns
The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/PushModelProperty.java


JRemote: org.pcsoft.framework.jremote.api.PushObserverListener Interface Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • PushObserverListener
Public Member Functions | List of all members
org.pcsoft.framework.jremote.api.PushObserverListener Interface Reference

Public Member Functions

String | property ()
Class<?> | modelClass ()
ObserverListenerType | listenerType () default ObserverListenerType.AutoDetection

Detailed Description

Mark a method in an interface as listener method for a push call, see RemotePushService. Interface must be annotated with RemotePushObserver.

The method signature must build with a void return type and one argument of type PushChangedListener:
void addListener(PushChangedListener l)

Member Function Documentation

ObserverListenerType org.pcsoft.framework.jremote.api.PushObserverListener.listenerType ( )

Setup the type of listener method like 'add' or 'remove' (Default is ObserverListenerType#AutoDetection)

Returns
Class<?> org.pcsoft.framework.jremote.api.PushObserverListener.modelClass ( )

The class of the RemotePushModel within the property() the observer listener listen to, see PushModelProperty

Returns
String org.pcsoft.framework.jremote.api.PushObserverListener.property ( )

The name of the RemotePushModel property the observer listener listen to, see PushModelProperty#value()

Returns
The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/PushObserverListener.java


JRemote: org.pcsoft.framework.jremote.api.RemoteControlService Interface Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • RemoteControlService
org.pcsoft.framework.jremote.api.RemoteControlService Interface Reference

Detailed Description

Mark an interface as remote control service. That controls the server. See Control

The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/RemoteControlService.java


JRemote: org.pcsoft.framework.jremote.api.RemoteEventReceiver Interface Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • RemoteEventReceiver
org.pcsoft.framework.jremote.api.RemoteEventReceiver Interface Reference

Detailed Description

Mark an interface as remote observer for observing data via event methods (RemoteEventService), see EventReceiverListener.

The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/RemoteEventReceiver.java


JRemote: org.pcsoft.framework.jremote.api.RemoteEventService Interface Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • RemoteEventService
org.pcsoft.framework.jremote.api.RemoteEventService Interface Reference

Detailed Description

Mark an interface as remote event service to push data via RemotePushObserver, see Event

The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/RemoteEventService.java


JRemote: org.pcsoft.framework.jremote.api.RemotePushModel Interface Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • RemotePushModel
org.pcsoft.framework.jremote.api.RemotePushModel Interface Reference

Detailed Description

Mark an interface as remote model. In it all pushes (RemotePushService) are stored in defined properties, see PushModelProperty.

The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/RemotePushModel.java


JRemote: org.pcsoft.framework.jremote.api.RemotePushObserver Interface Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • RemotePushObserver
org.pcsoft.framework.jremote.api.RemotePushObserver Interface Reference

Detailed Description

Mark an interface as remote observer for observing RemotePushModel via push methods (RemotePushService), see PushObserverListener.

The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/RemotePushObserver.java


JRemote: org.pcsoft.framework.jremote.api.RemotePushService Interface Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • RemotePushService
org.pcsoft.framework.jremote.api.RemotePushService Interface Reference

Detailed Description

Mark an interface as remote push service to push data into RemotePushModel and RemotePushObserver, see Push

The documentation for this interface was generated from the following file:
  • api/src/main/java/org/pcsoft/framework/jremote/api/RemotePushService.java


JRemote: org.pcsoft.framework.jremote.commons.AnnotationUtils Class Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • commons
  • AnnotationUtils
Static Public Member Functions | List of all members
org.pcsoft.framework.jremote.commons.AnnotationUtils Class Reference

Static Public Member Functions

static boolean | isRemoteService (Class<?> clazz)
static boolean | isRemoteMethod (Method method)
static boolean | isRemoteModel (Class<?> clazz)
static boolean | isModelProperty (Method method)
static List< Method > | getModelProperties (Class<?> clazz)
The documentation for this class was generated from the following file:
  • commons/src/main/java/org/pcsoft/framework/jremote/commons/AnnotationUtils.java


JRemote: org.pcsoft.framework.jremote.commons.ReflectionUtils Class Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • commons
  • ReflectionUtils
Static Public Member Functions | List of all members
org.pcsoft.framework.jremote.commons.ReflectionUtils Class Reference

Static Public Member Functions

static List< Class<?> > | findInterfaces (Class<?> clazz)
static List< Class<?> > | findInterfaces (Class<?> clazz, Predicate< Class<?>> validator)
The documentation for this class was generated from the following file:
  • commons/src/main/java/org/pcsoft/framework/jremote/commons/ReflectionUtils.java


JRemote: org.pcsoft.framework.jremote.core.Client Class Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • Client
Public Member Functions | List of all members
org.pcsoft.framework.jremote.core.Client Class Reference

Public Member Functions

Client (String host, int port)
String | getHost ()
int | getPort ()
The documentation for this class was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/Client.java


JRemote: org.pcsoft.framework.jremote.core.ClientState Enum Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • ClientState
Public Attributes | List of all members
org.pcsoft.framework.jremote.core.ClientState Enum Reference
Inheritance diagram for org.pcsoft.framework.jremote.core.ClientState:
org.pcsoft.framework.jremote.core.State

Public Attributes

Unknown
Connected
Disconnected
The documentation for this enum was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/ClientState.java


JRemote: org.pcsoft.framework.jremote.core.LifecycleState Enum Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • LifecycleState
Public Attributes | List of all members
org.pcsoft.framework.jremote.core.LifecycleState Enum Reference

Public Attributes

Created
Opened
Closed

Detailed Description

Represent all lifecycle states of RemoteServer and RemoteClient

Member Data Documentation

org.pcsoft.framework.jremote.core.LifecycleState.Closed

Instance was closed via Remote#close()

org.pcsoft.framework.jremote.core.LifecycleState.Created

Instance was created / build, see RemoteServerBuilder or RemoteClientBuilder

org.pcsoft.framework.jremote.core.LifecycleState.Opened

Instance was opened via Remote#open()

The documentation for this enum was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/LifecycleState.java


JRemote: org.pcsoft.framework.jremote.core.Remote< S extends State > Interface Template Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • Remote
Public Member Functions | List of all members
org.pcsoft.framework.jremote.core.Remote< S extends State > Interface Template Reference
Inheritance diagram for org.pcsoft.framework.jremote.core.Remote< S extends State >:

Public Member Functions

void | open () throws IOException
S | getState ()
void | addStateChangeListener (Consumer< S > l)
void | removeStateChangeListener (Consumer< S > l)
LifecycleState getLifecycleState ()
void | addLifecycleStateChangeListener (Consumer< LifecycleState > l)
void | removeLifecycleStateChangeListener (Consumer< LifecycleState > l)
String | getHost ()
int | getPort ()
Class<?extends NetworkProtocol > | getNetworkProtocolClass ()

Detailed Description

Remote interface for RemoteServer and RemoteClient with all common methods

Parameters
<S>

Member Function Documentation

String org.pcsoft.framework.jremote.core.Remote< S extends State >.getHost ( )

Returns the configured host name of this remote object to use

Returns
LifecycleState org.pcsoft.framework.jremote.core.Remote< S extends State >.getLifecycleState ( )

Returns the lifecycle state of the remote object

Returns
Class<? extends NetworkProtocol> org.pcsoft.framework.jremote.core.Remote< S extends State >.getNetworkProtocolClass ( )

Returns the class of network protocol for this remote instance to use.

Returns
int org.pcsoft.framework.jremote.core.Remote< S extends State >.getPort ( )

Returns the configured port of this remote object to use

Returns
S org.pcsoft.framework.jremote.core.Remote< S extends State >.getState ( )

Returns the current state of the remote object. This is an other state than getLifecycleState()

Returns
void org.pcsoft.framework.jremote.core.Remote< S extends State >.open ( ) throws IOException

Open the remote object

Exceptions
IOException
The documentation for this interface was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/Remote.java


JRemote: org.pcsoft.framework.jremote.core.RemoteBase< S extends State > Class Template Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • RemoteBase
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
org.pcsoft.framework.jremote.core.RemoteBase< S extends State > Class Template Referenceabstract
Inheritance diagram for org.pcsoft.framework.jremote.core.RemoteBase< S extends State >:
org.pcsoft.framework.jremote.core.Remote< S >

Public Member Functions

final void | open () throws IOException
final void | close () throws Exception
final LifecycleState | getLifecycleState ()
final void | addLifecycleStateChangeListener (Consumer< LifecycleState > l)
final void | removeLifecycleStateChangeListener (Consumer< LifecycleState > l)
Class<?extends NetworkProtocol > | getNetworkProtocolClass ()
- Public Member Functions inherited from org.pcsoft.framework.jremote.core.Remote< S >
void | open () throws IOException
S | getState ()
void | addStateChangeListener (Consumer< S > l)
void | removeStateChangeListener (Consumer< S > l)
LifecycleState getLifecycleState ()
void | addLifecycleStateChangeListener (Consumer< LifecycleState > l)
void | removeLifecycleStateChangeListener (Consumer< LifecycleState > l)
String | getHost ()
int | getPort ()
Class<?extends NetworkProtocol > | getNetworkProtocolClass ()

Protected Member Functions

abstract void | doOpen () throws IOException
abstract void | doClose () throws Exception

Protected Attributes

final String | host
final int | port
final NetworkProtocol | networkProtocol

Detailed Description

Represent the base implementation for the remote interface. Contains always used members like host and port.

Parameters
<S>
The documentation for this class was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/RemoteBase.java


JRemote: org.pcsoft.framework.jremote.core.RemoteBuilder< T extends Remote > Interface Template Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • RemoteBuilder
Public Member Functions | List of all members
org.pcsoft.framework.jremote.core.RemoteBuilder< T extends Remote > Interface Template Reference

Public Member Functions

T build ()
The documentation for this interface was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/RemoteBuilder.java


JRemote: org.pcsoft.framework.jremote.core.RemoteClient Class Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • RemoteClient
Classes | Public Member Functions | List of all members
org.pcsoft.framework.jremote.core.RemoteClient Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.core.RemoteClient:
org.pcsoft.framework.jremote.core.RemoteBase< ClientState >

Classes

class | ControlManager
class | DataManager

Public Member Functions

DataManager | getData ()
ControlManager | getControl ()
UUID | getUuid ()
String | getHost ()
int | getPort ()
int | getOwnPort ()
void | doOpen () throws IOException
void | doClose () throws Exception
ClientState | getState ()
void | addStateChangeListener (Consumer< ClientState > l)
void | removeStateChangeListener (Consumer< ClientState > l)
- Public Member Functions inherited from org.pcsoft.framework.jremote.core.RemoteBase< ClientState >
final void | open () throws IOException
final void | close () throws Exception
final LifecycleState | getLifecycleState ()
final void | addLifecycleStateChangeListener (Consumer< LifecycleState > l)
final void | removeLifecycleStateChangeListener (Consumer< LifecycleState > l)
Class<?extends NetworkProtocol > | getNetworkProtocolClass ()

Additional Inherited Members

- Protected Member Functions inherited from org.pcsoft.framework.jremote.core.RemoteBase< ClientState >
abstract void | doOpen () throws IOException
abstract void | doClose () throws Exception
- Protected Attributes inherited from org.pcsoft.framework.jremote.core.RemoteBase< ClientState >
final String | host
final int | port
final NetworkProtocol | networkProtocol
The documentation for this class was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/RemoteClient.java


JRemote: org.pcsoft.framework.jremote.core.RemoteClient.ControlManager Class Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • RemoteClient
  • ControlManager
List of all members
org.pcsoft.framework.jremote.core.RemoteClient.ControlManager Class Reference
The documentation for this class was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/RemoteClient.java


JRemote: org.pcsoft.framework.jremote.core.RemoteClient.DataManager Class Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • RemoteClient
  • DataManager
List of all members
org.pcsoft.framework.jremote.core.RemoteClient.DataManager Class Reference
The documentation for this class was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/RemoteClient.java


JRemote: org.pcsoft.framework.jremote.core.RemoteClientBuilder Class Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • RemoteClientBuilder
Public Member Functions | Static Public Member Functions | List of all members
org.pcsoft.framework.jremote.core.RemoteClientBuilder Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.core.RemoteClientBuilder:
org.pcsoft.framework.jremote.core.RemoteBuilder< RemoteClient >

Public Member Functions

final RemoteClientBuilder | withRemotePushModel (Class<?>...pushModelClasses)
final RemoteClientBuilder | withRemotePushObserver (Class<?>...pushObserverClasses)
final RemoteClientBuilder | withRemoteEventReceiver (Class<?>...eventReceiverClasses)
final RemoteClientBuilder | withRemotePushService (Class<?>...pushServiceClasses)
final RemoteClientBuilder | withRemoteEventService (Class<?>...eventServiceClasses)
final RemoteClientBuilder | withRemoteControlClient (Class<?>...controlClientClasses)
RemoteClient | build ()
- Public Member Functions inherited from org.pcsoft.framework.jremote.core.RemoteBuilder< RemoteClient >
T | build ()

Static Public Member Functions

static RemoteClientBuilder | create (String host, int port, int ownPort)
static RemoteClientBuilder | create (String host, int port, int ownPort, Class<?extends NetworkProtocol > networkProtocolClass)
static RemoteClientBuilder | create (ClientConfiguration configuration)
static RemoteClientBuilder | create (ClientConfiguration configuration, Class<?extends NetworkProtocol > networkProtocolClass)
The documentation for this class was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/RemoteClientBuilder.java


JRemote: org.pcsoft.framework.jremote.core.RemoteServer Class Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • RemoteServer
Classes | Public Member Functions | List of all members
org.pcsoft.framework.jremote.core.RemoteServer Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.core.RemoteServer:
org.pcsoft.framework.jremote.core.RemoteBase< ServerState >

Classes

class BroadcastManager

Public Member Functions

BroadcastManager | getBroadcast ()
Client[] | getConnectedClients ()
void | addClientRegisteredListener (Consumer< Client > l)
void | removeClientRegisteredListener (Consumer< Client > l)
void | addClientUnregisteredListener (Consumer< Client > l)
void | removeClientUnregisteredListener (Consumer< Client > l)
String | getHost ()
int | getPort ()
void | doOpen () throws IOException
void | doClose () throws Exception
ServerState | getState ()
void | addStateChangeListener (Consumer< ServerState > l)
void | removeStateChangeListener (Consumer< ServerState > l)
- Public Member Functions inherited from org.pcsoft.framework.jremote.core.RemoteBase< ServerState >
final void | open () throws IOException
final void | close () throws Exception
final LifecycleState | getLifecycleState ()
final void | addLifecycleStateChangeListener (Consumer< LifecycleState > l)
final void | removeLifecycleStateChangeListener (Consumer< LifecycleState > l)
Class<?extends NetworkProtocol > | getNetworkProtocolClass ()

Additional Inherited Members

- Protected Member Functions inherited from org.pcsoft.framework.jremote.core.RemoteBase< ServerState >
abstract void | doOpen () throws IOException
abstract void | doClose () throws Exception
- Protected Attributes inherited from org.pcsoft.framework.jremote.core.RemoteBase< ServerState >
final String | host
final int | port
final NetworkProtocol | networkProtocol
The documentation for this class was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/RemoteServer.java


JRemote: org.pcsoft.framework.jremote.core.RemoteServer.BroadcastManager Class Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • RemoteServer
  • BroadcastManager
List of all members
org.pcsoft.framework.jremote.core.RemoteServer.BroadcastManager Class Reference
The documentation for this class was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/RemoteServer.java


JRemote: org.pcsoft.framework.jremote.core.RemoteServerBuilder Class Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • RemoteServerBuilder
Public Member Functions | Static Public Member Functions | List of all members
org.pcsoft.framework.jremote.core.RemoteServerBuilder Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.core.RemoteServerBuilder:
org.pcsoft.framework.jremote.core.RemoteBuilder< RemoteServer >

Public Member Functions

RemoteServerBuilder | withPushClient (Class<?>...pushClientClasses)
RemoteServerBuilder | withEventClient (Class<?>...eventClientClasses)
RemoteServerBuilder | withRemoteControlService (Class<?>...controlServiceImplClasses)
RemoteServerBuilder | withRemoteControlService (Object...controlServiceImpls)
RemoteServerBuilder | withPushModelData (Class<?>...pushModelDataClasses)
RemoteServerBuilder | withPushModelData (Object...pushModelDataList)
RemoteServer | build ()
- Public Member Functions inherited from org.pcsoft.framework.jremote.core.RemoteBuilder< RemoteServer >
T | build ()

Static Public Member Functions

static RemoteServerBuilder | create (String host, int port)
static RemoteServerBuilder | create (String host, int port, Class<?extends NetworkProtocol > networkProtocolClass)
static RemoteServerBuilder | create (ServerConfiguration configuration)
static RemoteServerBuilder | create (ServerConfiguration configuration, Class<?extends NetworkProtocol > networkProtocolClass)
The documentation for this class was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/RemoteServerBuilder.java


JRemote: org.pcsoft.framework.jremote.core.ServerState Enum Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • ServerState
Public Attributes | List of all members
org.pcsoft.framework.jremote.core.ServerState Enum Reference
Inheritance diagram for org.pcsoft.framework.jremote.core.ServerState:
org.pcsoft.framework.jremote.core.State

Public Attributes

Opened
Closed
The documentation for this enum was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/ServerState.java


JRemote: org.pcsoft.framework.jremote.core.State Interface Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • State
org.pcsoft.framework.jremote.core.State Interface Reference
Inheritance diagram for org.pcsoft.framework.jremote.core.State:
org.pcsoft.framework.jremote.core.ClientState org.pcsoft.framework.jremote.core.ServerState

Detailed Description

Marker interface only for states

The documentation for this interface was generated from the following file:
  • core/src/main/java/org/pcsoft/framework/jremote/core/State.java


JRemote: org.pcsoft.framework.jremote.ext.config.api.exception.JRemoteConfigurationException Class Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • api
  • exception
  • JRemoteConfigurationException
Public Member Functions | List of all members
org.pcsoft.framework.jremote.ext.config.api.exception.JRemoteConfigurationException Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.ext.config.api.exception.JRemoteConfigurationException:
org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException org.pcsoft.framework.jremote.api.exception.JRemoteException

Public Member Functions

JRemoteConfigurationException (String message)
JRemoteConfigurationException (String message, Throwable cause)
JRemoteConfigurationException (Throwable cause)
- Public Member Functions inherited from org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException
JRemoteExtensionException (String message)
JRemoteExtensionException (String message, Throwable cause)
JRemoteExtensionException (Throwable cause)
- Public Member Functions inherited from org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException (String message)
JRemoteException (String message, Throwable cause)
JRemoteException (Throwable cause)
The documentation for this class was generated from the following file:
  • extensions/config/api/src/main/java/org/pcsoft/framework/jremote/ext/config/api/exception/JRemoteConfigurationException.java


JRemote: org.pcsoft.framework.jremote.ext.config.api.ClientConfiguration Interface Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • api
  • ClientConfiguration
Public Member Functions | List of all members
org.pcsoft.framework.jremote.ext.config.api.ClientConfiguration Interface Reference
Inheritance diagram for org.pcsoft.framework.jremote.ext.config.api.ClientConfiguration:
org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration org.pcsoft.framework.jremote.ext.config.impl.fluent.ClientFluentConfiguration org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration org.pcsoft.framework.jremote.ext.config.impl.xml.ClientXmlConfiguration

Public Member Functions

int | getOwnPort ()
- Public Member Functions inherited from org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration
String | getHost ()
int | getPort ()
void | validate () throws JRemoteConfigurationException

Detailed Description

Special configuration interface for the client side

Member Function Documentation

int org.pcsoft.framework.jremote.ext.config.api.ClientConfiguration.getOwnPort ( )

Returns the own port (for client services)

Returns

Implemented in org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration, org.pcsoft.framework.jremote.ext.config.impl.xml.ClientXmlConfiguration, and org.pcsoft.framework.jremote.ext.config.impl.fluent.ClientFluentConfiguration.

The documentation for this interface was generated from the following file:
  • extensions/config/api/src/main/java/org/pcsoft/framework/jremote/ext/config/api/ClientConfiguration.java


JRemote: org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration Interface Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • api
  • RemoteConfiguration
Public Member Functions | List of all members
org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration Interface Reference
Inheritance diagram for org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration:
org.pcsoft.framework.jremote.ext.config.api.ClientConfiguration org.pcsoft.framework.jremote.ext.config.api.ServerConfiguration org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< T extends RemoteFluentConfiguration< T > org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< T extends RemoteConfigurationType > org.pcsoft.framework.jremote.ext.config.impl.fluent.ClientFluentConfiguration org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration org.pcsoft.framework.jremote.ext.config.impl.xml.ClientXmlConfiguration org.pcsoft.framework.jremote.ext.config.impl.fluent.ServerFluentConfiguration org.pcsoft.framework.jremote.ext.config.impl.prop.ServerPropertyConfiguration org.pcsoft.framework.jremote.ext.config.impl.xml.ServerXmlConfiguration org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration org.pcsoft.framework.jremote.ext.config.impl.prop.ServerPropertyConfiguration

Public Member Functions

String | getHost ()
int | getPort ()
void | validate () throws JRemoteConfigurationException

Detailed Description

Remote configuration interface for all extension implementations for configuration handling

Member Function Documentation

String org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration.getHost ( )

Returns the configured host

Returns

Implemented in org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration, org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< T extends RemoteConfigurationType >, and org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< T extends RemoteFluentConfiguration< T >.

int org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration.getPort ( )

Returns the configured port

Returns

Implemented in org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< T extends RemoteFluentConfiguration< T >, org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration, and org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< T extends RemoteConfigurationType >.

void org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration.validate ( ) throws JRemoteConfigurationException

Validate the configuration and check that all needed values are set

Exceptions
JRemoteConfigurationException Is thrown if validation failed

Implemented in org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration, org.pcsoft.framework.jremote.ext.config.impl.xml.ClientXmlConfiguration, org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< T extends RemoteFluentConfiguration< T >, org.pcsoft.framework.jremote.ext.config.impl.fluent.ClientFluentConfiguration, org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration, and org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< T extends RemoteConfigurationType >.

The documentation for this interface was generated from the following file:
  • extensions/config/api/src/main/java/org/pcsoft/framework/jremote/ext/config/api/RemoteConfiguration.java


JRemote: org.pcsoft.framework.jremote.ext.config.api.ServerConfiguration Interface Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • api
  • ServerConfiguration
List of all members
org.pcsoft.framework.jremote.ext.config.api.ServerConfiguration Interface Reference
Inheritance diagram for org.pcsoft.framework.jremote.ext.config.api.ServerConfiguration:
org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration org.pcsoft.framework.jremote.ext.config.impl.fluent.ServerFluentConfiguration org.pcsoft.framework.jremote.ext.config.impl.prop.ServerPropertyConfiguration org.pcsoft.framework.jremote.ext.config.impl.xml.ServerXmlConfiguration

Additional Inherited Members

- Public Member Functions inherited from org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration
String | getHost ()
int | getPort ()
void | validate () throws JRemoteConfigurationException

Detailed Description

Special configuration interface for the server side

The documentation for this interface was generated from the following file:
  • extensions/config/api/src/main/java/org/pcsoft/framework/jremote/ext/config/api/ServerConfiguration.java


JRemote: org.pcsoft.framework.jremote.ext.config.impl.fluent.ClientFluentConfiguration Class Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • impl
  • fluent
  • ClientFluentConfiguration
Public Member Functions | Static Public Member Functions | List of all members
org.pcsoft.framework.jremote.ext.config.impl.fluent.ClientFluentConfiguration Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.ext.config.impl.fluent.ClientFluentConfiguration:
org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< ClientFluentConfiguration > org.pcsoft.framework.jremote.ext.config.api.ClientConfiguration org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration

Public Member Functions

int | getOwnPort ()
ClientFluentConfiguration | setOwnPort (int ownPort)
void | validate () throws JRemoteConfigurationException
- Public Member Functions inherited from org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< ClientFluentConfiguration >
String | getHost ()
T | setHost (String host)
int | getPort ()
T | setPort (int port)
void | validate () throws JRemoteConfigurationException
- Public Member Functions inherited from org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration
String | getHost ()
int | getPort ()

Static Public Member Functions

static ClientFluentConfiguration create ()

Member Function Documentation

int org.pcsoft.framework.jremote.ext.config.impl.fluent.ClientFluentConfiguration.getOwnPort ( )

Returns the own port (for client services)

Returns

Implements org.pcsoft.framework.jremote.ext.config.api.ClientConfiguration.

void org.pcsoft.framework.jremote.ext.config.impl.fluent.ClientFluentConfiguration.validate ( ) throws JRemoteConfigurationException

Validate the configuration and check that all needed values are set

Exceptions
JRemoteConfigurationException Is thrown if validation failed

Implements org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration.

The documentation for this class was generated from the following file:
  • extensions/config/impl/fluent/src/main/java/org/pcsoft/framework/jremote/ext/config/impl/fluent/ClientFluentConfiguration.java


JRemote: org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< T extends RemoteFluentConfiguration< T > Class Template Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • impl
  • fluent
  • RemoteFluentConfiguration
Public Member Functions | List of all members
org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< T extends RemoteFluentConfiguration< T > Class Template Referenceabstract
Inheritance diagram for org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< T extends RemoteFluentConfiguration< T >:
org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration

Public Member Functions

String | getHost ()
T | setHost (String host)
int | getPort ()
T | setPort (int port)
void | validate () throws JRemoteConfigurationException

Member Function Documentation

String org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< T extends RemoteFluentConfiguration< T >.getHost ( )

Returns the configured host

Returns

Implements org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration.

int org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< T extends RemoteFluentConfiguration< T >.getPort ( )

Returns the configured port

Returns

Implements org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration.

void org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< T extends RemoteFluentConfiguration< T >.validate ( ) throws JRemoteConfigurationException

Validate the configuration and check that all needed values are set

Exceptions
JRemoteConfigurationException Is thrown if validation failed

Implements org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration.

The documentation for this class was generated from the following file:
  • extensions/config/impl/fluent/src/main/java/org/pcsoft/framework/jremote/ext/config/impl/fluent/RemoteFluentConfiguration.java


JRemote: org.pcsoft.framework.jremote.ext.config.impl.fluent.ServerFluentConfiguration Class Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • impl
  • fluent
  • ServerFluentConfiguration
Static Public Member Functions | List of all members
org.pcsoft.framework.jremote.ext.config.impl.fluent.ServerFluentConfiguration Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.ext.config.impl.fluent.ServerFluentConfiguration:
org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< ServerFluentConfiguration > org.pcsoft.framework.jremote.ext.config.api.ServerConfiguration org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration

Static Public Member Functions

static ServerFluentConfiguration create ()

Additional Inherited Members

- Public Member Functions inherited from org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< ServerFluentConfiguration >
String | getHost ()
T | setHost (String host)
int | getPort ()
T | setPort (int port)
void | validate () throws JRemoteConfigurationException
- Public Member Functions inherited from org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration
String | getHost ()
int | getPort ()
void | validate () throws JRemoteConfigurationException
The documentation for this class was generated from the following file:
  • extensions/config/impl/fluent/src/main/java/org/pcsoft/framework/jremote/ext/config/impl/fluent/ServerFluentConfiguration.java


JRemote: org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration Class Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • impl
  • prop
  • ClientPropertyConfiguration
Public Member Functions | Static Public Member Functions | Protected Member Functions | List of all members
org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration:
org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration org.pcsoft.framework.jremote.ext.config.api.ClientConfiguration org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration

Public Member Functions

int | getOwnPort ()
void | validate () throws JRemoteConfigurationException
- Public Member Functions inherited from org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration
String | getHost ()
int | getPort ()
void | validate () throws JRemoteConfigurationException

Static Public Member Functions

static ClientPropertyConfiguration | loadFrom (File file) throws IOException
static ClientPropertyConfiguration | loadFrom (InputStream in) throws IOException
static ClientPropertyConfiguration | loadFrom (Properties properties)

Protected Member Functions

void | load (Properties properties) throws JRemoteConfigurationException
- Protected Member Functions inherited from org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration
void | load (Properties properties) throws JRemoteConfigurationException

Member Function Documentation

int org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration.getOwnPort ( )

Returns the own port (for client services)

Returns

Implements org.pcsoft.framework.jremote.ext.config.api.ClientConfiguration.

void org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration.validate ( ) throws JRemoteConfigurationException

Validate the configuration and check that all needed values are set

Exceptions
JRemoteConfigurationException Is thrown if validation failed

Implements org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration.

The documentation for this class was generated from the following file:
  • extensions/config/impl/prop/src/main/java/org/pcsoft/framework/jremote/ext/config/impl/prop/ClientPropertyConfiguration.java


JRemote: org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration Class Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • impl
  • prop
  • RemotePropertyConfiguration
Public Member Functions | Protected Member Functions | List of all members
org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration Class Referenceabstract
Inheritance diagram for org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration:
org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration org.pcsoft.framework.jremote.ext.config.impl.prop.ServerPropertyConfiguration

Public Member Functions

String | getHost ()
int | getPort ()
void | validate () throws JRemoteConfigurationException

Protected Member Functions

void load (Properties properties) throws JRemoteConfigurationException

Member Function Documentation

String org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration.getHost ( )

Returns the configured host

Returns

Implements org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration.

int org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration.getPort ( )

Returns the configured port

Returns

Implements org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration.

void org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration.validate ( ) throws JRemoteConfigurationException

Validate the configuration and check that all needed values are set

Exceptions
JRemoteConfigurationException Is thrown if validation failed

Implements org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration.

The documentation for this class was generated from the following file:
  • extensions/config/impl/prop/src/main/java/org/pcsoft/framework/jremote/ext/config/impl/prop/RemotePropertyConfiguration.java


JRemote: org.pcsoft.framework.jremote.ext.config.impl.prop.ServerPropertyConfiguration Class Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • impl
  • prop
  • ServerPropertyConfiguration
Static Public Member Functions | List of all members
org.pcsoft.framework.jremote.ext.config.impl.prop.ServerPropertyConfiguration Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.ext.config.impl.prop.ServerPropertyConfiguration:
org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration org.pcsoft.framework.jremote.ext.config.api.ServerConfiguration org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration

Static Public Member Functions

static ServerPropertyConfiguration | loadFrom (File file) throws IOException
static ServerPropertyConfiguration | loadFrom (InputStream in) throws IOException
static ServerPropertyConfiguration | loadFrom (Properties properties)

Additional Inherited Members

- Public Member Functions inherited from org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration
String | getHost ()
int | getPort ()
void | validate () throws JRemoteConfigurationException
- Protected Member Functions inherited from org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration
void | load (Properties properties) throws JRemoteConfigurationException
The documentation for this class was generated from the following file:
  • extensions/config/impl/prop/src/main/java/org/pcsoft/framework/jremote/ext/config/impl/prop/ServerPropertyConfiguration.java


JRemote: org.pcsoft.framework.jremote.ext.config.impl.xml.ClientXmlConfiguration Class Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • impl
  • xml
  • ClientXmlConfiguration
Public Member Functions | Static Public Member Functions | Protected Member Functions | List of all members
org.pcsoft.framework.jremote.ext.config.impl.xml.ClientXmlConfiguration Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.ext.config.impl.xml.ClientXmlConfiguration:
org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< ClientConfigurationType > org.pcsoft.framework.jremote.ext.config.api.ClientConfiguration org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration

Public Member Functions

int | getOwnPort ()
void | validate () throws JRemoteConfigurationException
- Public Member Functions inherited from org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< ClientConfigurationType >
String | getHost ()
int | getPort ()
void | validate () throws JRemoteConfigurationException
- Public Member Functions inherited from org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration
String | getHost ()
int | getPort ()

Static Public Member Functions

static ClientXmlConfiguration | loadFrom (File file) throws IOException
static ClientXmlConfiguration | loadFrom (InputStream in)
static ClientXmlConfiguration | loadFrom (ClientConfigurationType type)

Protected Member Functions

void | load (ClientConfigurationType type) throws JRemoteConfigurationException
- Protected Member Functions inherited from org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< ClientConfigurationType >
void | load (T type) throws JRemoteConfigurationException

Member Function Documentation

int org.pcsoft.framework.jremote.ext.config.impl.xml.ClientXmlConfiguration.getOwnPort ( )

Returns the own port (for client services)

Returns

Implements org.pcsoft.framework.jremote.ext.config.api.ClientConfiguration.

void org.pcsoft.framework.jremote.ext.config.impl.xml.ClientXmlConfiguration.validate ( ) throws JRemoteConfigurationException

Validate the configuration and check that all needed values are set

Exceptions
JRemoteConfigurationException Is thrown if validation failed

Implements org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration.

The documentation for this class was generated from the following file:
  • extensions/config/impl/xml/src/main/java/org/pcsoft/framework/jremote/ext/config/impl/xml/ClientXmlConfiguration.java


JRemote: org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< T extends RemoteConfigurationType > Class Template Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • impl
  • xml
  • RemoteXmlConfiguration
Public Member Functions | Protected Member Functions | List of all members
org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< T extends RemoteConfigurationType > Class Template Referenceabstract
Inheritance diagram for org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< T extends RemoteConfigurationType >:
org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration

Public Member Functions

String | getHost ()
int | getPort ()
void | validate () throws JRemoteConfigurationException

Protected Member Functions

void load (T type) throws JRemoteConfigurationException

Member Function Documentation

String org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< T extends RemoteConfigurationType >.getHost ( )

Returns the configured host

Returns

Implements org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration.

int org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< T extends RemoteConfigurationType >.getPort ( )

Returns the configured port

Returns

Implements org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration.

void org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< T extends RemoteConfigurationType >.validate ( ) throws JRemoteConfigurationException

Validate the configuration and check that all needed values are set

Exceptions
JRemoteConfigurationException Is thrown if validation failed

Implements org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration.

The documentation for this class was generated from the following file:
  • extensions/config/impl/xml/src/main/java/org/pcsoft/framework/jremote/ext/config/impl/xml/RemoteXmlConfiguration.java


JRemote: org.pcsoft.framework.jremote.ext.config.impl.xml.ServerXmlConfiguration Class Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • impl
  • xml
  • ServerXmlConfiguration
Static Public Member Functions | List of all members
org.pcsoft.framework.jremote.ext.config.impl.xml.ServerXmlConfiguration Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.ext.config.impl.xml.ServerXmlConfiguration:
org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< ServerConfigurationType > org.pcsoft.framework.jremote.ext.config.api.ServerConfiguration org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration

Static Public Member Functions

static ServerXmlConfiguration | loadFrom (File file) throws IOException
static ServerXmlConfiguration | loadFrom (InputStream in)
static ServerXmlConfiguration | loadFrom (ServerConfigurationType type)

Additional Inherited Members

- Public Member Functions inherited from org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< ServerConfigurationType >
String | getHost ()
int | getPort ()
void | validate () throws JRemoteConfigurationException
- Public Member Functions inherited from org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration
String | getHost ()
int | getPort ()
void | validate () throws JRemoteConfigurationException
- Protected Member Functions inherited from org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< ServerConfigurationType >
void | load (T type) throws JRemoteConfigurationException
The documentation for this class was generated from the following file:
  • extensions/config/impl/xml/src/main/java/org/pcsoft/framework/jremote/ext/config/impl/xml/ServerXmlConfiguration.java


JRemote: org.pcsoft.framework.jremote.ext.np.api.annotation.KeepAlive Interface Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • api
  • annotation
  • KeepAlive
org.pcsoft.framework.jremote.ext.np.api.annotation.KeepAlive Interface Reference

Detailed Description

Marker annotation for an interface method in a remote keep alive service, see RemoteKeepAliveService

The documentation for this interface was generated from the following file:
  • extensions/np/api/src/main/java/org/pcsoft/framework/jremote/ext/np/api/annotation/KeepAlive.java


JRemote: org.pcsoft.framework.jremote.ext.np.api.annotation.Registration Interface Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • api
  • annotation
  • Registration
Classes | Public Member Functions | List of all members
org.pcsoft.framework.jremote.ext.np.api.annotation.Registration Interface Reference

Classes

enum RegistrationType

Public Member Functions

RegistrationType value ()

Detailed Description

Marker annotation for an interface method in a remote registration service, see RemoteRegistrationService

Member Function Documentation

RegistrationType org.pcsoft.framework.jremote.ext.np.api.annotation.Registration.value ( )

Type of registration method

Returns
The documentation for this interface was generated from the following file:
  • extensions/np/api/src/main/java/org/pcsoft/framework/jremote/ext/np/api/annotation/Registration.java


JRemote: org.pcsoft.framework.jremote.ext.np.api.annotation.Registration.RegistrationType Enum Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • api
  • annotation
  • Registration
  • RegistrationType
Public Attributes | List of all members
org.pcsoft.framework.jremote.ext.np.api.annotation.Registration.RegistrationType Enum Reference

Public Attributes

Register
Unregister

Detailed Description

Types of registration actions

Member Data Documentation

org.pcsoft.framework.jremote.ext.np.api.annotation.Registration.RegistrationType.Register

Register a client (method with three arguments: UUID (string), host, port)

org.pcsoft.framework.jremote.ext.np.api.annotation.Registration.RegistrationType.Unregister

Unregister a client (method with one argument: UUID (string))

The documentation for this enum was generated from the following file:
  • extensions/np/api/src/main/java/org/pcsoft/framework/jremote/ext/np/api/annotation/Registration.java


JRemote: org.pcsoft.framework.jremote.ext.np.api.annotation.RemoteKeepAliveService Interface Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • api
  • annotation
  • RemoteKeepAliveService
org.pcsoft.framework.jremote.ext.np.api.annotation.RemoteKeepAliveService Interface Reference

Detailed Description

Mark an interface as remote keep alive service. Must have exactly one method:

  • boolean ping(String uuid) annotated with KeepAlive
    Method to ping server with client's UUID to get TRUE if client is registered, otherwise FALSE
The documentation for this interface was generated from the following file:
  • extensions/np/api/src/main/java/org/pcsoft/framework/jremote/ext/np/api/annotation/RemoteKeepAliveService.java


JRemote: org.pcsoft.framework.jremote.ext.np.api.annotation.RemoteRegistrationService Interface Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • api
  • annotation
  • RemoteRegistrationService
org.pcsoft.framework.jremote.ext.np.api.annotation.RemoteRegistrationService Interface Reference

Detailed Description

Mark an interface as remote registration service. Must have exactly two methods:

  • void register(String uuid, String host, int port) annotated with Registration(Registration.RegistrationType#Register)
    Method to register a client, identified by its UUID.
  • void unregister(String uuid) annotated with Registration(Registration.RegistrationType#Unregister)
    Method to unregister a client, identified by its UUID
The documentation for this interface was generated from the following file:
  • extensions/np/api/src/main/java/org/pcsoft/framework/jremote/ext/np/api/annotation/RemoteRegistrationService.java


JRemote: org.pcsoft.framework.jremote.ext.np.api.exception.JRemoteNetworkProtocolException Class Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • api
  • exception
  • JRemoteNetworkProtocolException
Public Member Functions | List of all members
org.pcsoft.framework.jremote.ext.np.api.exception.JRemoteNetworkProtocolException Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.ext.np.api.exception.JRemoteNetworkProtocolException:
org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException org.pcsoft.framework.jremote.api.exception.JRemoteException

Public Member Functions

JRemoteNetworkProtocolException (String message)
JRemoteNetworkProtocolException (String message, Throwable cause)
JRemoteNetworkProtocolException (Throwable cause)
- Public Member Functions inherited from org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException
JRemoteExtensionException (String message)
JRemoteExtensionException (String message, Throwable cause)
JRemoteExtensionException (Throwable cause)
- Public Member Functions inherited from org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException (String message)
JRemoteException (String message, Throwable cause)
JRemoteException (Throwable cause)
The documentation for this class was generated from the following file:
  • extensions/np/api/src/main/java/org/pcsoft/framework/jremote/ext/np/api/exception/JRemoteNetworkProtocolException.java


JRemote: org.pcsoft.framework.jremote.ext.np.api.Client Interface Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • api
  • Client
Public Member Functions | List of all members
org.pcsoft.framework.jremote.ext.np.api.Client Interface Reference
Inheritance diagram for org.pcsoft.framework.jremote.ext.np.api.Client:
org.pcsoft.framework.jremote.ext.np.api.ClientBase

Public Member Functions

void | open (String host, int port) throws IOException
Object | invokeRemote (Method method, Object...params) throws IOException

Detailed Description

Interface for a client based implementation

Member Function Documentation

Object org.pcsoft.framework.jremote.ext.np.api.Client.invokeRemote | ( | Method | method,
 |  | Object... | params
 | ) |  | throws IOException

Invoke the given method on server with given parameter values

Parameters
method
params
Returns
Exceptions
IOException
void org.pcsoft.framework.jremote.ext.np.api.Client.open | ( | String | host,
 |  | int | port
 | ) |  | throws IOException

Open the client on given host / port

Parameters
host
port
Exceptions
IOException
The documentation for this interface was generated from the following file:
  • extensions/np/api/src/main/java/org/pcsoft/framework/jremote/ext/np/api/Client.java


JRemote: org.pcsoft.framework.jremote.ext.np.api.ClientBase Class Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • api
  • ClientBase
Public Member Functions | Protected Attributes | List of all members
org.pcsoft.framework.jremote.ext.np.api.ClientBase Class Referenceabstract
Inheritance diagram for org.pcsoft.framework.jremote.ext.np.api.ClientBase:
org.pcsoft.framework.jremote.ext.np.api.Client

Public Member Functions

ClientBase (Class<?> serviceClass)
- Public Member Functions inherited from org.pcsoft.framework.jremote.ext.np.api.Client
void | open (String host, int port) throws IOException
Object | invokeRemote (Method method, Object...params) throws IOException

Protected Attributes

final Class<?> serviceClass
The documentation for this class was generated from the following file:
  • extensions/np/api/src/main/java/org/pcsoft/framework/jremote/ext/np/api/ClientBase.java


JRemote: org.pcsoft.framework.jremote.ext.np.api.NetworkProtocol Interface Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • api
  • NetworkProtocol
Public Member Functions | List of all members
org.pcsoft.framework.jremote.ext.np.api.NetworkProtocol Interface Reference
Inheritance diagram for org.pcsoft.framework.jremote.ext.np.api.NetworkProtocol:
org.pcsoft.framework.jremote.ext.np.impl.rmi.RmiProtocol

Public Member Functions

Service | createService (Object serviceImplementation)
Client | createClient (Class<?> serviceClass)
Class<?> | getRegistrationServiceClass ()
Class<?> | getKeepAliveServiceClass ()

Detailed Description

Interface for network protocol mechanism

Member Function Documentation

Client org.pcsoft.framework.jremote.ext.np.api.NetworkProtocol.createClient ( Class<?> serviceClass )

Creates a new client for this protocol to use.

Parameters
serviceClass Class of the service to create client for
Returns

Implemented in org.pcsoft.framework.jremote.ext.np.impl.rmi.RmiProtocol.

Service org.pcsoft.framework.jremote.ext.np.api.NetworkProtocol.createService ( Object serviceImplementation )

Creates a new service for this protocol to use.

Parameters
serviceImplementation Implementation of the class to invoke methods via network
Returns

Implemented in org.pcsoft.framework.jremote.ext.np.impl.rmi.RmiProtocol.

Class<?> org.pcsoft.framework.jremote.ext.np.api.NetworkProtocol.getKeepAliveServiceClass ( )

Returns the concrete remote keep alive service class to use for this plugin

Returns

Implemented in org.pcsoft.framework.jremote.ext.np.impl.rmi.RmiProtocol.

Class<?> org.pcsoft.framework.jremote.ext.np.api.NetworkProtocol.getRegistrationServiceClass ( )

Returns the concrete remote registration service class to use for this plugin

Returns

Implemented in org.pcsoft.framework.jremote.ext.np.impl.rmi.RmiProtocol.

The documentation for this interface was generated from the following file:
  • extensions/np/api/src/main/java/org/pcsoft/framework/jremote/ext/np/api/NetworkProtocol.java


JRemote: org.pcsoft.framework.jremote.ext.np.api.Service Interface Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • api
  • Service
Public Member Functions | List of all members
org.pcsoft.framework.jremote.ext.np.api.Service Interface Reference
Inheritance diagram for org.pcsoft.framework.jremote.ext.np.api.Service:
org.pcsoft.framework.jremote.ext.np.api.ServiceBase

Public Member Functions

void open (String host, int port) throws IOException

Detailed Description

Represent the base interface for a service implementation

Member Function Documentation

void org.pcsoft.framework.jremote.ext.np.api.Service.open | ( | String | host,
 |  | int | port
 | ) |  | throws IOException

Start service on given host and port

Parameters
host
port
Exceptions
IOException
The documentation for this interface was generated from the following file:
  • extensions/np/api/src/main/java/org/pcsoft/framework/jremote/ext/np/api/Service.java


JRemote: org.pcsoft.framework.jremote.ext.np.api.ServiceBase Class Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • api
  • ServiceBase
Public Member Functions | Protected Attributes | List of all members
org.pcsoft.framework.jremote.ext.np.api.ServiceBase Class Referenceabstract
Inheritance diagram for org.pcsoft.framework.jremote.ext.np.api.ServiceBase:
org.pcsoft.framework.jremote.ext.np.api.Service

Public Member Functions

ServiceBase (Object serviceImplementation)
- Public Member Functions inherited from org.pcsoft.framework.jremote.ext.np.api.Service
void open (String host, int port) throws IOException

Protected Attributes

final Object serviceImplementation

Detailed Description

Basic implementation for a service. Contains the basic implementation.

The documentation for this class was generated from the following file:
  • extensions/np/api/src/main/java/org/pcsoft/framework/jremote/ext/np/api/ServiceBase.java


JRemote: org.pcsoft.framework.jremote.ext.np.impl.rmi.RmiProtocol Class Reference

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • impl
  • rmi
  • RmiProtocol
Public Member Functions | List of all members
org.pcsoft.framework.jremote.ext.np.impl.rmi.RmiProtocol Class Reference
Inheritance diagram for org.pcsoft.framework.jremote.ext.np.impl.rmi.RmiProtocol:
org.pcsoft.framework.jremote.ext.np.api.NetworkProtocol

Public Member Functions

Service | createService (Object serviceImplementation)
Client | createClient (Class<?> serviceClass)
Class<?> | getRegistrationServiceClass ()
Class<?> | getKeepAliveServiceClass ()

Member Function Documentation

Client org.pcsoft.framework.jremote.ext.np.impl.rmi.RmiProtocol.createClient ( Class<?> serviceClass )

Creates a new client for this protocol to use.

Parameters
serviceClass Class of the service to create client for
Returns

Implements org.pcsoft.framework.jremote.ext.np.api.NetworkProtocol.

Service org.pcsoft.framework.jremote.ext.np.impl.rmi.RmiProtocol.createService ( Object serviceImplementation )

Creates a new service for this protocol to use.

Parameters
serviceImplementation Implementation of the class to invoke methods via network
Returns

Implements org.pcsoft.framework.jremote.ext.np.api.NetworkProtocol.

Class<?> org.pcsoft.framework.jremote.ext.np.impl.rmi.RmiProtocol.getKeepAliveServiceClass ( )

Returns the concrete remote keep alive service class to use for this plugin

Returns

Implements org.pcsoft.framework.jremote.ext.np.api.NetworkProtocol.

Class<?> org.pcsoft.framework.jremote.ext.np.impl.rmi.RmiProtocol.getRegistrationServiceClass ( )

Returns the concrete remote registration service class to use for this plugin

Returns

Implements org.pcsoft.framework.jremote.ext.np.api.NetworkProtocol.

The documentation for this class was generated from the following file:
  • extensions/np/impl/rmi/src/main/java/org/pcsoft/framework/jremote/ext/np/impl/rmi/RmiProtocol.java


JRemote: Class Index

  • Class Members
Class Index
A | B | C | D | E | J | K | L | N | O | P | R | S
A
JRemoteException (org.pcsoft.framework.jremote.api.exception) RemoteBase (org.pcsoft.framework.jremote.core)
JRemoteExecutionException (org.pcsoft.framework.jremote.api.exception) | RemoteBuilder (org.pcsoft.framework.jremote.core)
AnnotationUtils (org.pcsoft.framework.jremote.commons) | JRemoteExtensionException (org.pcsoft.framework.jremote.api.exception) | RemoteClient (org.pcsoft.framework.jremote.core)
B
JRemoteNetworkProtocolException (org.pcsoft.framework.jremote.ext.np.api.exception) RemoteClientBuilder (org.pcsoft.framework.jremote.core)
K
RemoteConfiguration (org.pcsoft.framework.jremote.ext.config.api)
RemoteServer.BroadcastManager (org.pcsoft.framework.jremote.core) | RemoteControlService (org.pcsoft.framework.jremote.api)
C
KeepAlive (org.pcsoft.framework.jremote.ext.np.api.annotation) RemoteEventReceiver (org.pcsoft.framework.jremote.api)
L
RemoteEventService (org.pcsoft.framework.jremote.api)
Client (org.pcsoft.framework.jremote.core) | RemoteFluentConfiguration (org.pcsoft.framework.jremote.ext.config.impl.fluent)
Client (org.pcsoft.framework.jremote.ext.np.api) | LifecycleState (org.pcsoft.framework.jremote.core) | RemoteKeepAliveService (org.pcsoft.framework.jremote.ext.np.api.annotation)
ClientBase (org.pcsoft.framework.jremote.ext.np.api)
N
RemoteListener (org.pcsoft.framework.jremote.api.type)
ClientConfiguration (org.pcsoft.framework.jremote.ext.config.api) | RemotePropertyConfiguration (org.pcsoft.framework.jremote.ext.config.impl.prop)
ClientFluentConfiguration (org.pcsoft.framework.jremote.ext.config.impl.fluent) | NetworkProtocol (org.pcsoft.framework.jremote.ext.np.api) | RemotePushModel (org.pcsoft.framework.jremote.api)
ClientPropertyConfiguration (org.pcsoft.framework.jremote.ext.config.impl.prop)
O
RemotePushObserver (org.pcsoft.framework.jremote.api)
ClientState (org.pcsoft.framework.jremote.core) | RemotePushService (org.pcsoft.framework.jremote.api)
ClientXmlConfiguration (org.pcsoft.framework.jremote.ext.config.impl.xml) | ObserverListenerType (org.pcsoft.framework.jremote.api.type) | RemoteRegistrationService (org.pcsoft.framework.jremote.ext.np.api.annotation)
Control (org.pcsoft.framework.jremote.api)
P
RemoteServer (org.pcsoft.framework.jremote.core)
RemoteClient.ControlManager (org.pcsoft.framework.jremote.core) | RemoteServerBuilder (org.pcsoft.framework.jremote.core)
D
Push (org.pcsoft.framework.jremote.api) RemoteXmlConfiguration (org.pcsoft.framework.jremote.ext.config.impl.xml)
PushChangedListener (org.pcsoft.framework.jremote.api.type) | RmiProtocol (org.pcsoft.framework.jremote.ext.np.impl.rmi)
RemoteClient.DataManager (org.pcsoft.framework.jremote.core) PushItemUpdate (org.pcsoft.framework.jremote.api.type)
S
E
PushMethodType (org.pcsoft.framework.jremote.api.type)
PushModelProperty (org.pcsoft.framework.jremote.api) | ServerConfiguration (org.pcsoft.framework.jremote.ext.config.api)
Event (org.pcsoft.framework.jremote.api) | PushObserverListener (org.pcsoft.framework.jremote.api) | ServerFluentConfiguration (org.pcsoft.framework.jremote.ext.config.impl.fluent)
EventReceivedListener (org.pcsoft.framework.jremote.api.type)
R
ServerPropertyConfiguration (org.pcsoft.framework.jremote.ext.config.impl.prop)
EventReceiverListener (org.pcsoft.framework.jremote.api) | ServerState (org.pcsoft.framework.jremote.core)
J
ReflectionUtils (org.pcsoft.framework.jremote.commons) ServerXmlConfiguration (org.pcsoft.framework.jremote.ext.config.impl.xml)
Registration (org.pcsoft.framework.jremote.ext.np.api.annotation) | Service (org.pcsoft.framework.jremote.ext.np.api)
JRemoteAnnotationException (org.pcsoft.framework.jremote.api.exception) | Registration.RegistrationType (org.pcsoft.framework.jremote.ext.np.api.annotation) | ServiceBase (org.pcsoft.framework.jremote.ext.np.api)
JRemoteConfigurationException (org.pcsoft.framework.jremote.ext.config.api.exception) | Remote (org.pcsoft.framework.jremote.core) | State (org.pcsoft.framework.jremote.core)
A | B | C | D | E | J | K | L | N | O | P | R | S


JRemote: Class Hierarchy

  • Class Members
Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 1234]
C org.pcsoft.framework.jremote.commons.AnnotationUtils
▼C AutoCloseable
C org.pcsoft.framework.jremote.core.Remote< S extends State >
C org.pcsoft.framework.jremote.core.RemoteServer.BroadcastManager
C org.pcsoft.framework.jremote.core.Client
C org.pcsoft.framework.jremote.api.Control
C org.pcsoft.framework.jremote.core.RemoteClient.ControlManager
C org.pcsoft.framework.jremote.core.RemoteClient.DataManager
C org.pcsoft.framework.jremote.api.Event
C org.pcsoft.framework.jremote.api.EventReceiverListener
C org.pcsoft.framework.jremote.ext.np.api.annotation.KeepAlive
C org.pcsoft.framework.jremote.core.LifecycleState
▼C org.pcsoft.framework.jremote.ext.np.api.NetworkProtocol
C org.pcsoft.framework.jremote.ext.np.impl.rmi.RmiProtocol
C org.pcsoft.framework.jremote.api.type.ObserverListenerType
C org.pcsoft.framework.jremote.api.Push
C org.pcsoft.framework.jremote.api.type.PushItemUpdate
C org.pcsoft.framework.jremote.api.type.PushMethodType
C org.pcsoft.framework.jremote.api.PushModelProperty
C org.pcsoft.framework.jremote.api.PushObserverListener
C org.pcsoft.framework.jremote.commons.ReflectionUtils
C org.pcsoft.framework.jremote.ext.np.api.annotation.Registration
C org.pcsoft.framework.jremote.ext.np.api.annotation.Registration.RegistrationType
▼C org.pcsoft.framework.jremote.core.Remote< S >
C org.pcsoft.framework.jremote.core.RemoteBase< S extends State >
▼C org.pcsoft.framework.jremote.core.RemoteBase< ClientState >
C org.pcsoft.framework.jremote.core.RemoteClient
▼C org.pcsoft.framework.jremote.core.RemoteBase< ServerState >
C org.pcsoft.framework.jremote.core.RemoteServer
C org.pcsoft.framework.jremote.core.RemoteBuilder< T extends Remote >
▼C org.pcsoft.framework.jremote.core.RemoteBuilder< RemoteClient >
C org.pcsoft.framework.jremote.core.RemoteClientBuilder
▼C org.pcsoft.framework.jremote.core.RemoteBuilder< RemoteServer >
C org.pcsoft.framework.jremote.core.RemoteServerBuilder
▼C org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration
▼C org.pcsoft.framework.jremote.ext.config.api.ClientConfiguration
C org.pcsoft.framework.jremote.ext.config.impl.fluent.ClientFluentConfiguration
C org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration
C org.pcsoft.framework.jremote.ext.config.impl.xml.ClientXmlConfiguration
▼C org.pcsoft.framework.jremote.ext.config.api.ServerConfiguration
C org.pcsoft.framework.jremote.ext.config.impl.fluent.ServerFluentConfiguration
C org.pcsoft.framework.jremote.ext.config.impl.prop.ServerPropertyConfiguration
C org.pcsoft.framework.jremote.ext.config.impl.xml.ServerXmlConfiguration
C org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< T extends RemoteFluentConfiguration< T >
▼C org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration
C org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration
C org.pcsoft.framework.jremote.ext.config.impl.prop.ServerPropertyConfiguration
C org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< T extends RemoteConfigurationType >
C org.pcsoft.framework.jremote.api.RemoteControlService
C org.pcsoft.framework.jremote.api.RemoteEventReceiver
C org.pcsoft.framework.jremote.api.RemoteEventService
▼C org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< ClientFluentConfiguration >
C org.pcsoft.framework.jremote.ext.config.impl.fluent.ClientFluentConfiguration
▼C org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< ServerFluentConfiguration >
C org.pcsoft.framework.jremote.ext.config.impl.fluent.ServerFluentConfiguration
C org.pcsoft.framework.jremote.ext.np.api.annotation.RemoteKeepAliveService
▼C org.pcsoft.framework.jremote.api.type.RemoteListener
C org.pcsoft.framework.jremote.api.type.EventReceivedListener< T >
C org.pcsoft.framework.jremote.api.type.PushChangedListener
C org.pcsoft.framework.jremote.api.RemotePushModel
C org.pcsoft.framework.jremote.api.RemotePushObserver
C org.pcsoft.framework.jremote.api.RemotePushService
C org.pcsoft.framework.jremote.ext.np.api.annotation.RemoteRegistrationService
▼C org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< ClientConfigurationType >
C org.pcsoft.framework.jremote.ext.config.impl.xml.ClientXmlConfiguration
▼C org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< ServerConfigurationType >
C org.pcsoft.framework.jremote.ext.config.impl.xml.ServerXmlConfiguration
▼C RuntimeException
▼C org.pcsoft.framework.jremote.api.exception.JRemoteException
C org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException
C org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException
▼C org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException
C org.pcsoft.framework.jremote.ext.config.api.exception.JRemoteConfigurationException
C org.pcsoft.framework.jremote.ext.np.api.exception.JRemoteNetworkProtocolException
▼C org.pcsoft.framework.jremote.core.State
C org.pcsoft.framework.jremote.core.ClientState
C org.pcsoft.framework.jremote.core.ServerState
▼C Closeable
▼C org.pcsoft.framework.jremote.ext.np.api.Client
C org.pcsoft.framework.jremote.ext.np.api.ClientBase
▼C org.pcsoft.framework.jremote.ext.np.api.Service
C org.pcsoft.framework.jremote.ext.np.api.ServiceBase


JRemote: Class Members

  • Class Members
  • All
  • Functions
  • Variables
  • a
  • c
  • d
  • e
  • g
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • Add : org.pcsoft.framework.jremote.api.type.ObserverListenerType
  • AutoDetection : org.pcsoft.framework.jremote.api.type.ObserverListenerType

- c -

  • Closed : org.pcsoft.framework.jremote.core.LifecycleState
  • createClient() : org.pcsoft.framework.jremote.ext.np.api.NetworkProtocol , org.pcsoft.framework.jremote.ext.np.impl.rmi.RmiProtocol
  • Created : org.pcsoft.framework.jremote.core.LifecycleState
  • createService() : org.pcsoft.framework.jremote.ext.np.api.NetworkProtocol , org.pcsoft.framework.jremote.ext.np.impl.rmi.RmiProtocol

- d -

  • Default : org.pcsoft.framework.jremote.api.type.PushMethodType

- e -

  • event() : org.pcsoft.framework.jremote.api.Event
  • eventClass() : org.pcsoft.framework.jremote.api.Event

- g -

  • getHost() : org.pcsoft.framework.jremote.core.Remote< S extends State > , org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration , org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< T extends RemoteFluentConfiguration< T > , org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration , org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< T extends RemoteConfigurationType >
  • getKeepAliveServiceClass() : org.pcsoft.framework.jremote.ext.np.api.NetworkProtocol , org.pcsoft.framework.jremote.ext.np.impl.rmi.RmiProtocol
  • getLifecycleState() : org.pcsoft.framework.jremote.core.Remote< S extends State >
  • getNetworkProtocolClass() : org.pcsoft.framework.jremote.core.Remote< S extends State >
  • getOwnPort() : org.pcsoft.framework.jremote.ext.config.api.ClientConfiguration , org.pcsoft.framework.jremote.ext.config.impl.fluent.ClientFluentConfiguration , org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration , org.pcsoft.framework.jremote.ext.config.impl.xml.ClientXmlConfiguration
  • getPort() : org.pcsoft.framework.jremote.core.Remote< S extends State > , org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration , org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< T extends RemoteFluentConfiguration< T > , org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration , org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< T extends RemoteConfigurationType >
  • getRegistrationServiceClass() : org.pcsoft.framework.jremote.ext.np.api.NetworkProtocol , org.pcsoft.framework.jremote.ext.np.impl.rmi.RmiProtocol
  • getState() : org.pcsoft.framework.jremote.core.Remote< S extends State >

- i -

  • invokeRemote() : org.pcsoft.framework.jremote.ext.np.api.Client

- l -

  • listenerType() : org.pcsoft.framework.jremote.api.EventReceiverListener , org.pcsoft.framework.jremote.api.PushObserverListener

- m -

  • modelClass() : org.pcsoft.framework.jremote.api.Push , org.pcsoft.framework.jremote.api.PushObserverListener

- o -

  • onChange() : org.pcsoft.framework.jremote.api.type.EventReceivedListener< T > , org.pcsoft.framework.jremote.api.type.PushChangedListener
  • open() : org.pcsoft.framework.jremote.core.Remote< S extends State > , org.pcsoft.framework.jremote.ext.np.api.Client , org.pcsoft.framework.jremote.ext.np.api.Service
  • Opened : org.pcsoft.framework.jremote.core.LifecycleState

- p -

  • property() : org.pcsoft.framework.jremote.api.Push , org.pcsoft.framework.jremote.api.PushObserverListener

- r -

  • Register : org.pcsoft.framework.jremote.ext.np.api.annotation.Registration.RegistrationType
  • Remove : org.pcsoft.framework.jremote.api.type.ObserverListenerType

- s -

  • SingleListItem : org.pcsoft.framework.jremote.api.type.PushMethodType

- t -

  • type() : org.pcsoft.framework.jremote.api.Push

- u -

  • Unregister : org.pcsoft.framework.jremote.ext.np.api.annotation.Registration.RegistrationType

- v -

  • validate() : org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration , org.pcsoft.framework.jremote.ext.config.impl.fluent.ClientFluentConfiguration , org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< T extends RemoteFluentConfiguration< T > , org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration , org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration , org.pcsoft.framework.jremote.ext.config.impl.xml.ClientXmlConfiguration , org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< T extends RemoteConfigurationType >
  • value() : org.pcsoft.framework.jremote.api.EventReceiverListener , org.pcsoft.framework.jremote.api.PushModelProperty , org.pcsoft.framework.jremote.ext.np.api.annotation.Registration


JRemote: Class Members - Functions

  • Class Members
  • All
  • Functions
  • Variables
  • c
  • e
  • g
  • i
  • l
  • m
  • o
  • p
  • t
  • v

- c -

  • createClient() : org.pcsoft.framework.jremote.ext.np.api.NetworkProtocol , org.pcsoft.framework.jremote.ext.np.impl.rmi.RmiProtocol
  • createService() : org.pcsoft.framework.jremote.ext.np.api.NetworkProtocol , org.pcsoft.framework.jremote.ext.np.impl.rmi.RmiProtocol

- e -

  • event() : org.pcsoft.framework.jremote.api.Event
  • eventClass() : org.pcsoft.framework.jremote.api.Event

- g -

  • getHost() : org.pcsoft.framework.jremote.core.Remote< S extends State > , org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration , org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< T extends RemoteFluentConfiguration< T > , org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration , org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< T extends RemoteConfigurationType >
  • getKeepAliveServiceClass() : org.pcsoft.framework.jremote.ext.np.api.NetworkProtocol , org.pcsoft.framework.jremote.ext.np.impl.rmi.RmiProtocol
  • getLifecycleState() : org.pcsoft.framework.jremote.core.Remote< S extends State >
  • getNetworkProtocolClass() : org.pcsoft.framework.jremote.core.Remote< S extends State >
  • getOwnPort() : org.pcsoft.framework.jremote.ext.config.api.ClientConfiguration , org.pcsoft.framework.jremote.ext.config.impl.fluent.ClientFluentConfiguration , org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration , org.pcsoft.framework.jremote.ext.config.impl.xml.ClientXmlConfiguration
  • getPort() : org.pcsoft.framework.jremote.core.Remote< S extends State > , org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration , org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< T extends RemoteFluentConfiguration< T > , org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration , org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< T extends RemoteConfigurationType >
  • getRegistrationServiceClass() : org.pcsoft.framework.jremote.ext.np.api.NetworkProtocol , org.pcsoft.framework.jremote.ext.np.impl.rmi.RmiProtocol
  • getState() : org.pcsoft.framework.jremote.core.Remote< S extends State >

- i -

  • invokeRemote() : org.pcsoft.framework.jremote.ext.np.api.Client

- l -

  • listenerType() : org.pcsoft.framework.jremote.api.EventReceiverListener , org.pcsoft.framework.jremote.api.PushObserverListener

- m -

  • modelClass() : org.pcsoft.framework.jremote.api.Push , org.pcsoft.framework.jremote.api.PushObserverListener

- o -

  • onChange() : org.pcsoft.framework.jremote.api.type.EventReceivedListener< T > , org.pcsoft.framework.jremote.api.type.PushChangedListener
  • open() : org.pcsoft.framework.jremote.core.Remote< S extends State > , org.pcsoft.framework.jremote.ext.np.api.Client , org.pcsoft.framework.jremote.ext.np.api.Service

- p -

  • property() : org.pcsoft.framework.jremote.api.Push , org.pcsoft.framework.jremote.api.PushObserverListener

- t -

  • type() : org.pcsoft.framework.jremote.api.Push

- v -

  • validate() : org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration , org.pcsoft.framework.jremote.ext.config.impl.fluent.ClientFluentConfiguration , org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< T extends RemoteFluentConfiguration< T > , org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration , org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration , org.pcsoft.framework.jremote.ext.config.impl.xml.ClientXmlConfiguration , org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< T extends RemoteConfigurationType >
  • value() : org.pcsoft.framework.jremote.api.EventReceiverListener , org.pcsoft.framework.jremote.api.PushModelProperty , org.pcsoft.framework.jremote.ext.np.api.annotation.Registration


JRemote: Class Members - Variables

  • Class Members
  • All
  • Functions
  • Variables
  • Add : org.pcsoft.framework.jremote.api.type.ObserverListenerType
  • AutoDetection : org.pcsoft.framework.jremote.api.type.ObserverListenerType
  • Closed : org.pcsoft.framework.jremote.core.LifecycleState
  • Created : org.pcsoft.framework.jremote.core.LifecycleState
  • Default : org.pcsoft.framework.jremote.api.type.PushMethodType
  • Opened : org.pcsoft.framework.jremote.core.LifecycleState
  • Register : org.pcsoft.framework.jremote.ext.np.api.annotation.Registration.RegistrationType
  • Remove : org.pcsoft.framework.jremote.api.type.ObserverListenerType
  • SingleListItem : org.pcsoft.framework.jremote.api.type.PushMethodType
  • Unregister : org.pcsoft.framework.jremote.ext.np.api.annotation.Registration.RegistrationType


JRemote: extensions/np/impl/rmi/src/main/java/org/pcsoft/framework/jremote/ext/np/impl Directory Reference

  • extensions
  • np
  • impl
  • rmi
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • impl
impl Directory Reference

Directories

directory rmi


JRemote: commons/src/main/java/org/pcsoft Directory Reference

  • commons
  • src
  • main
  • java
  • org
  • pcsoft
pcsoft Directory Reference

Directories

directory framework


JRemote: extensions/config/impl/prop/src/main/java/org/pcsoft Directory Reference

  • extensions
  • config
  • impl
  • prop
  • src
  • main
  • java
  • org
  • pcsoft
pcsoft Directory Reference

Directories

directory framework


JRemote: extensions/config/impl/xml/src/main Directory Reference

  • extensions
  • config
  • impl
  • xml
  • src
  • main
main Directory Reference

Directories

directory java


JRemote: core/src/main/java/org/pcsoft/framework/jremote/core/internal/manager Directory Reference

  • core
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • internal
  • manager
manager Directory Reference

Files

file | ClientProxyManager.java
file | ServerProxyManager.java


JRemote: commons Directory Reference

  • commons
commons Directory Reference

Directories

directory src


JRemote: extensions/np/api/src Directory Reference

  • extensions
  • np
  • api
  • src
src Directory Reference

Directories

directory main


JRemote: api/src/main/java/org/pcsoft/framework/jremote/api/type Directory Reference

  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • type
type Directory Reference

Files

file | EventReceivedListener.java
file | ObserverListenerType.java
file | PushChangedListener.java
file | PushItemUpdate.java
file | PushMethodType.java
file | RemoteListener.java


JRemote: extensions/np/api/src/main/java Directory Reference

  • extensions
  • np
  • api
  • src
  • main
  • java
java Directory Reference

Directories

directory org

Files

file module-info.java


JRemote: extensions/config/api/src/main/java/org/pcsoft/framework/jremote/ext/config Directory Reference

  • extensions
  • config
  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
config Directory Reference

Directories

directory api


JRemote: core/src/main Directory Reference

  • core
  • src
  • main
main Directory Reference

Directories

directory java


JRemote: extensions/config/impl/xml/src/main/java Directory Reference

  • extensions
  • config
  • impl
  • xml
  • src
  • main
  • java
java Directory Reference

Directories

directory org

Files

file module-info.java


JRemote: extensions/config/impl/prop/src/main/java/org/pcsoft/framework Directory Reference

  • extensions
  • config
  • impl
  • prop
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
framework Directory Reference

Directories

directory jremote


JRemote: api/src Directory Reference

  • api
  • src
src Directory Reference

Directories

directory main


JRemote: extensions/config/api/src/main/java/org/pcsoft/framework/jremote Directory Reference

  • extensions
  • config
  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
jremote Directory Reference

Directories

directory ext


JRemote: extensions/config/api/src Directory Reference

  • extensions
  • config
  • api
  • src
src Directory Reference

Directories

directory main


JRemote: core/src/main/java Directory Reference

  • core
  • src
  • main
  • java
java Directory Reference

Directories

directory org

Files

file module-info.java


JRemote: extensions/config/impl/prop Directory Reference

  • extensions
  • config
  • impl
  • prop
prop Directory Reference

Directories

directory src


JRemote: extensions/np/impl/rmi/src Directory Reference

  • extensions
  • np
  • impl
  • rmi
  • src
src Directory Reference

Directories

directory main


JRemote: extensions/config/impl/xml/src/main/java/org/pcsoft Directory Reference

  • extensions
  • config
  • impl
  • xml
  • src
  • main
  • java
  • org
  • pcsoft
pcsoft Directory Reference

Directories

directory framework


JRemote: core/src/main/java/org/pcsoft/framework/jremote/core Directory Reference

  • core
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • core
core Directory Reference

Directories

directory internal

Files

file | Client.java
file | ClientState.java
file | LifecycleState.java
file | Remote.java
file | RemoteBase.java
file | RemoteBuilder.java
file | RemoteClient.java
file | RemoteClientBuilder.java
file | RemoteServer.java
file | RemoteServerBuilder.java
file | ServerState.java
file | State.java


JRemote: core/src/main/java/org/pcsoft/framework/jremote/core/internal/type/wrapper Directory Reference

  • core
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • internal
  • type
  • wrapper
wrapper Directory Reference

Files

file | ClientWrapper.java
file | RemoteKeepAliveClientWrapper.java
file | RemoteRegistrationClientWrapper.java


JRemote: extensions/config/api/src/main Directory Reference

  • extensions
  • config
  • api
  • src
  • main
main Directory Reference

Directories

directory java


JRemote: extensions/np/impl Directory Reference

  • extensions
  • np
  • impl
impl Directory Reference

Directories

directory rmi


JRemote: extensions/np/impl/rmi/src/main/java/org/pcsoft/framework/jremote/ext/np/impl/rmi/internal/interf Directory Reference

  • extensions
  • np
  • impl
  • rmi
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • impl
  • rmi
  • internal
  • interf
interf Directory Reference

Files

file | RmiKeepAliveService.java
file | RmiRegistrationService.java


JRemote: extensions/np/impl/rmi/src/main/java/org/pcsoft Directory Reference

  • extensions
  • np
  • impl
  • rmi
  • src
  • main
  • java
  • org
  • pcsoft
pcsoft Directory Reference

Directories

directory framework


JRemote: extensions/np/impl/rmi/src/main/java/org Directory Reference

  • extensions
  • np
  • impl
  • rmi
  • src
  • main
  • java
  • org
org Directory Reference

Directories

directory pcsoft


JRemote: extensions/config/api/src/main/java/org Directory Reference

  • extensions
  • config
  • api
  • src
  • main
  • java
  • org
org Directory Reference

Directories

directory pcsoft


JRemote: extensions/np/impl/rmi/src/main/java/org/pcsoft/framework/jremote/ext/np/impl/rmi/internal Directory Reference

  • extensions
  • np
  • impl
  • rmi
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • impl
  • rmi
  • internal
internal Directory Reference

Directories

directory interf

Files

file | RmiClient.java
file | RmiService.java


JRemote: extensions/config/impl/prop/src/main/java/org/pcsoft/framework/jremote Directory Reference

  • extensions
  • config
  • impl
  • prop
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
jremote Directory Reference

Directories

directory ext


JRemote: api/src/main/java/org/pcsoft Directory Reference

  • api
  • src
  • main
  • java
  • org
  • pcsoft
pcsoft Directory Reference

Directories

directory framework


JRemote: extensions/np/api/src/main/java/org/pcsoft/framework Directory Reference

  • extensions
  • np
  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
framework Directory Reference

Directories

directory jremote


JRemote: extensions/config/impl/fluent/src Directory Reference

  • extensions
  • config
  • impl
  • fluent
  • src
src Directory Reference

Directories

directory main


JRemote: extensions/config/impl/prop/src/main/java/org/pcsoft/framework/jremote/ext/config Directory Reference

  • extensions
  • config
  • impl
  • prop
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
config Directory Reference

Directories

directory impl


JRemote: extensions/np/api/src/main/java/org/pcsoft Directory Reference

  • extensions
  • np
  • api
  • src
  • main
  • java
  • org
  • pcsoft
pcsoft Directory Reference

Directories

directory framework


JRemote: api/src/main/java/org/pcsoft/framework/jremote/api/exception Directory Reference

  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • exception
exception Directory Reference

Files

file | JRemoteAnnotationException.java
file | JRemoteException.java
file | JRemoteExecutionException.java
file | JRemoteExtensionException.java


JRemote: extensions/np/api/src/main Directory Reference

  • extensions
  • np
  • api
  • src
  • main
main Directory Reference

Directories

directory java


JRemote: extensions/np/impl/rmi/src/main Directory Reference

  • extensions
  • np
  • impl
  • rmi
  • src
  • main
main Directory Reference

Directories

directory java


JRemote: core/src Directory Reference

  • core
  • src
src Directory Reference

Directories

directory main


JRemote: extensions/config/impl/fluent/src/main/java/org/pcsoft/framework Directory Reference

  • extensions
  • config
  • impl
  • fluent
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
framework Directory Reference

Directories

directory jremote


JRemote: api Directory Reference

  • api
api Directory Reference

Directories

directory src


JRemote: extensions/config/api Directory Reference

  • extensions
  • config
  • api
api Directory Reference

Directories

directory src


JRemote: api/src/main/java/org Directory Reference

  • api
  • src
  • main
  • java
  • org
org Directory Reference

Directories

directory pcsoft


JRemote: extensions/np/api/src/main/java/org/pcsoft/framework/jremote Directory Reference

  • extensions
  • np
  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
jremote Directory Reference

Directories

directory ext


JRemote: extensions/np/api/src/main/java/org Directory Reference

  • extensions
  • np
  • api
  • src
  • main
  • java
  • org
org Directory Reference

Directories

directory pcsoft


JRemote: extensions/config/impl/xml/src Directory Reference

  • extensions
  • config
  • impl
  • xml
  • src
src Directory Reference

Directories

directory main


JRemote: core/src/main/java/org/pcsoft/framework/jremote/core/internal/validation Directory Reference

  • core
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • internal
  • validation
validation Directory Reference

Files

file | AnnotationValidator.java
file | RemoteBroadcastServiceAnnotationValidator.java
file | RemoteControlServiceAnnotationValidator.java
file | RemoteEventReceiverAnnotationValidator.java
file | RemoteEventServiceAnnotationValidator.java
file | RemoteKeepAliveServiceAnnotationValidator.java
file | RemotePushModelAnnotationValidator.java
file | RemotePushObserverAnnotationValidator.java
file | RemotePushServiceAnnotationValidator.java
file | RemoteRegistrationServiceAnnotationValidator.java
file | RemoteServiceAnnotationValidator.java
file | RemoteServiceAnnotationValidatorBase.java
file | SimpleAnnotationValidator.java
file | Validator.java


JRemote: commons/src/main/java/org/pcsoft/framework/jremote/commons Directory Reference

  • commons
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • commons
commons Directory Reference

Files

file | AnnotationUtils.java
file | ReflectionUtils.java


JRemote: extensions/np/api/src/main/java/org/pcsoft/framework/jremote/ext/np/api Directory Reference

  • extensions
  • np
  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • api
api Directory Reference

Directories

directory | annotation
directory | exception

Files

file | Client.java
file | ClientBase.java
file | NetworkProtocol.java
file | Service.java
file | ServiceBase.java


JRemote: core/src/main/java/org/pcsoft/framework Directory Reference

  • core
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
framework Directory Reference

Directories

directory jremote


JRemote: api/src/main Directory Reference

  • api
  • src
  • main
main Directory Reference

Directories

directory java


JRemote: commons/src/main/java/org/pcsoft/framework Directory Reference

  • commons
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
framework Directory Reference

Directories

directory jremote


JRemote: core/src/main/java/org Directory Reference

  • core
  • src
  • main
  • java
  • org
org Directory Reference

Directories

directory pcsoft


JRemote: api/src/main/java/org/pcsoft/framework Directory Reference

  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
framework Directory Reference

Directories

directory jremote


JRemote: api/src/main/java Directory Reference

  • api
  • src
  • main
  • java
java Directory Reference

Directories

directory org

Files

file module-info.java


JRemote: core Directory Reference

  • core
core Directory Reference

Directories

directory src


JRemote: extensions/config/impl/prop/src/main/java/org/pcsoft/framework/jremote/ext Directory Reference

  • extensions
  • config
  • impl
  • prop
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • ext
ext Directory Reference

Directories

directory config


JRemote: extensions/config/impl/fluent/src/main/java Directory Reference

  • extensions
  • config
  • impl
  • fluent
  • src
  • main
  • java
java Directory Reference

Directories

directory org

Files

file module-info.java


JRemote: core/src/main/java/org/pcsoft/framework/jremote/core/internal/handler Directory Reference

  • core
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • internal
  • handler
handler Directory Reference

Files

file PushModelHandler.java


JRemote: extensions/config/impl Directory Reference

  • extensions
  • config
  • impl
impl Directory Reference

Directories

directory | fluent
directory | prop
directory | xml


JRemote: extensions/config/api/src/main/java Directory Reference

  • extensions
  • config
  • api
  • src
  • main
  • java
java Directory Reference

Directories

directory org

Files

file module-info.java


JRemote: extensions/np/impl/rmi/src/main/java/org/pcsoft/framework/jremote/ext/np/impl/rmi Directory Reference

  • extensions
  • np
  • impl
  • rmi
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • impl
  • rmi
rmi Directory Reference

Directories

directory internal

Files

file RmiProtocol.java


JRemote: commons/src Directory Reference

  • commons
  • src
src Directory Reference

Directories

directory main


JRemote: extensions/config/impl/fluent/src/main Directory Reference

  • extensions
  • config
  • impl
  • fluent
  • src
  • main
main Directory Reference

Directories

directory java


JRemote: extensions/config/impl/prop/src/main/java Directory Reference

  • extensions
  • config
  • impl
  • prop
  • src
  • main
  • java
java Directory Reference

Directories

directory org

Files

file module-info.java


JRemote: extensions/config Directory Reference

  • extensions
  • config
config Directory Reference

Directories

directory | api
directory | impl


JRemote: extensions/np/impl/rmi Directory Reference

  • extensions
  • np
  • impl
  • rmi
rmi Directory Reference

Directories

directory src


JRemote: extensions/config/impl/prop/src/main Directory Reference

  • extensions
  • config
  • impl
  • prop
  • src
  • main
main Directory Reference

Directories

directory java


JRemote: extensions/np/api/src/main/java/org/pcsoft/framework/jremote/ext/np/api/annotation Directory Reference

  • extensions
  • np
  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • api
  • annotation
annotation Directory Reference

Files

file | KeepAlive.java
file | Registration.java
file | RemoteKeepAliveService.java
file | RemoteRegistrationService.java


JRemote: extensions Directory Reference

  • extensions
extensions Directory Reference

Directories

directory | config
directory | np


JRemote: core/src/main/java/org/pcsoft/framework/jremote/core/internal/proxy Directory Reference

  • core
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • internal
  • proxy
proxy Directory Reference

Files

file | ProxyBuilder.java
file | ProxyFactory.java
file | RemoteClientServiceProxyBuilder.java
file | RemoteEventReceiverProxyBuilder.java
file | RemoteEventServiceProxyBuilder.java
file | RemoteKeepAliveServiceProxyBuilder.java
file | RemoteListenerProxyBuilder.java
file | RemotePushModelProxyBuilder.java
file | RemotePushObserverProxyBuilder.java
file | RemotePushServiceProxyBuilder.java
file | RemoteRegistrationServiceProxyBuilder.java


JRemote: extensions/np Directory Reference

  • extensions
  • np
np Directory Reference

Directories

directory | api
directory | impl


JRemote: extensions/config/impl/prop/src/main/java/org/pcsoft/framework/jremote/ext/config/impl Directory Reference

  • extensions
  • config
  • impl
  • prop
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • impl
impl Directory Reference

Directories

directory prop


JRemote: extensions/config/api/src/main/java/org/pcsoft Directory Reference

  • extensions
  • config
  • api
  • src
  • main
  • java
  • org
  • pcsoft
pcsoft Directory Reference

Directories

directory framework


JRemote: extensions/config/impl/xml/src/main/java/org/pcsoft/framework/jremote/ext/config/impl/xml Directory Reference

  • extensions
  • config
  • impl
  • xml
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • impl
  • xml
xml Directory Reference

Files

file | ClientXmlConfiguration.java
file | RemoteXmlConfiguration.java
file | ServerXmlConfiguration.java


JRemote: extensions/config/impl/fluent/src/main/java/org Directory Reference

  • extensions
  • config
  • impl
  • fluent
  • src
  • main
  • java
  • org
org Directory Reference

Directories

directory pcsoft


JRemote: extensions/config/impl/xml Directory Reference

  • extensions
  • config
  • impl
  • xml
xml Directory Reference

Directories

directory src


JRemote: extensions/config/impl/xml/src/main/java/org/pcsoft/framework/jremote/ext/config Directory Reference

  • extensions
  • config
  • impl
  • xml
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
config Directory Reference

Directories

directory impl


JRemote: extensions/np/impl/rmi/src/main/java/org/pcsoft/framework/jremote Directory Reference

  • extensions
  • np
  • impl
  • rmi
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
jremote Directory Reference

Directories

directory ext


JRemote: commons/src/main/java/org/pcsoft/framework/jremote Directory Reference

  • commons
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
jremote Directory Reference

Directories

directory commons


JRemote: extensions/np/impl/rmi/src/main/java/org/pcsoft/framework Directory Reference

  • extensions
  • np
  • impl
  • rmi
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
framework Directory Reference

Directories

directory jremote


JRemote: extensions/config/api/src/main/java/org/pcsoft/framework/jremote/ext Directory Reference

  • extensions
  • config
  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • ext
ext Directory Reference

Directories

directory config


JRemote: extensions/np/api/src/main/java/org/pcsoft/framework/jremote/ext Directory Reference

  • extensions
  • np
  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • ext
ext Directory Reference

Directories

directory np


JRemote: core/src/main/java/org/pcsoft/framework/jremote/core/internal Directory Reference

  • core
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • internal
internal Directory Reference

Directories

directory | handler
directory | manager
directory | processor
directory | proxy
directory | registry
directory | type
directory | validation


JRemote: extensions/config/api/src/main/java/org/pcsoft/framework/jremote/ext/config/api/exception Directory Reference

  • extensions
  • config
  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • api
  • exception
exception Directory Reference

Files

file JRemoteConfigurationException.java


JRemote: extensions/config/impl/prop/src/main/java/org/pcsoft/framework/jremote/ext/config/impl/prop Directory Reference

  • extensions
  • config
  • impl
  • prop
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • impl
  • prop
prop Directory Reference

Files

file | ClientPropertyConfiguration.java
file | RemotePropertyConfiguration.java
file | ServerPropertyConfiguration.java


JRemote: api/src/main/java/org/pcsoft/framework/jremote/api Directory Reference

  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • api
api Directory Reference

Directories

directory | exception
directory | internal
directory | type

Files

file | Control.java
file | Event.java
file | EventReceiverListener.java
file | Push.java
file | PushModelProperty.java
file | PushObserverListener.java
file | RemoteControlService.java
file | RemoteEventReceiver.java
file | RemoteEventService.java
file | RemotePushModel.java
file | RemotePushObserver.java
file | RemotePushService.java


JRemote: commons/src/main/java Directory Reference

  • commons
  • src
  • main
  • java
java Directory Reference

Directories

directory org

Files

file module-info.java


JRemote: extensions/config/impl/xml/src/main/java/org/pcsoft/framework/jremote/ext Directory Reference

  • extensions
  • config
  • impl
  • xml
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • ext
ext Directory Reference

Directories

directory config


JRemote: extensions/np/impl/rmi/src/main/java/org/pcsoft/framework/jremote/ext/np Directory Reference

  • extensions
  • np
  • impl
  • rmi
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
np Directory Reference

Directories

directory impl


JRemote: extensions/config/impl/prop/src/main/java/org Directory Reference

  • extensions
  • config
  • impl
  • prop
  • src
  • main
  • java
  • org
org Directory Reference

Directories

directory pcsoft


JRemote: extensions/config/impl/fluent/src/main/java/org/pcsoft/framework/jremote/ext/config Directory Reference

  • extensions
  • config
  • impl
  • fluent
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
config Directory Reference

Directories

directory impl


JRemote: extensions/np/api/src/main/java/org/pcsoft/framework/jremote/ext/np/api/exception Directory Reference

  • extensions
  • np
  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • api
  • exception
exception Directory Reference

Files

file JRemoteNetworkProtocolException.java


JRemote: extensions/config/impl/xml/src/main/java/org Directory Reference

  • extensions
  • config
  • impl
  • xml
  • src
  • main
  • java
  • org
org Directory Reference

Directories

directory pcsoft


JRemote: core/src/main/java/org/pcsoft Directory Reference

  • core
  • src
  • main
  • java
  • org
  • pcsoft
pcsoft Directory Reference

Directories

directory framework


JRemote: extensions/config/impl/fluent/src/main/java/org/pcsoft/framework/jremote/ext/config/impl Directory Reference

  • extensions
  • config
  • impl
  • fluent
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • impl
impl Directory Reference

Directories

directory fluent


JRemote: extensions/config/api/src/main/java/org/pcsoft/framework Directory Reference

  • extensions
  • config
  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
framework Directory Reference

Directories

directory jremote


JRemote: extensions/config/api/src/main/java/org/pcsoft/framework/jremote/ext/config/api Directory Reference

  • extensions
  • config
  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • api
api Directory Reference

Directories

directory exception

Files

file | ClientConfiguration.java
file | RemoteConfiguration.java
file | ServerConfiguration.java


JRemote: extensions/config/impl/xml/src/main/java/org/pcsoft/framework/jremote Directory Reference

  • extensions
  • config
  • impl
  • xml
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
jremote Directory Reference

Directories

directory ext


JRemote: extensions/config/impl/fluent/src/main/java/org/pcsoft/framework/jremote/ext/config/impl/fluent Directory Reference

  • extensions
  • config
  • impl
  • fluent
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • impl
  • fluent
fluent Directory Reference

Files

file | ClientFluentConfiguration.java
file | RemoteFluentConfiguration.java
file | ServerFluentConfiguration.java


JRemote: extensions/np/impl/rmi/src/main/java/org/pcsoft/framework/jremote/ext Directory Reference

  • extensions
  • np
  • impl
  • rmi
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • ext
ext Directory Reference

Directories

directory np


JRemote: extensions/np/api Directory Reference

  • extensions
  • np
  • api
api Directory Reference

Directories

directory src


JRemote: extensions/config/impl/fluent/src/main/java/org/pcsoft/framework/jremote Directory Reference

  • extensions
  • config
  • impl
  • fluent
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
jremote Directory Reference

Directories

directory ext


JRemote: extensions/config/impl/fluent Directory Reference

  • extensions
  • config
  • impl
  • fluent
fluent Directory Reference

Directories

directory src


JRemote: extensions/config/impl/fluent/src/main/java/org/pcsoft Directory Reference

  • extensions
  • config
  • impl
  • fluent
  • src
  • main
  • java
  • org
  • pcsoft
pcsoft Directory Reference

Directories

directory framework


JRemote: extensions/config/impl/fluent/src/main/java/org/pcsoft/framework/jremote/ext Directory Reference

  • extensions
  • config
  • impl
  • fluent
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • ext
ext Directory Reference

Directories

directory config


JRemote: api/src/main/java/org/pcsoft/framework/jremote Directory Reference

  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
jremote Directory Reference

Directories

directory api


JRemote: extensions/config/impl/xml/src/main/java/org/pcsoft/framework Directory Reference

  • extensions
  • config
  • impl
  • xml
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
framework Directory Reference

Directories

directory jremote


JRemote: core/src/main/java/org/pcsoft/framework/jremote/core/internal/registry Directory Reference

  • core
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • internal
  • registry
registry Directory Reference

Files

file ClientRegistry.java


JRemote: extensions/config/impl/prop/src Directory Reference

  • extensions
  • config
  • impl
  • prop
  • src
src Directory Reference

Directories

directory main


JRemote: extensions/np/impl/rmi/src/main/java Directory Reference

  • extensions
  • np
  • impl
  • rmi
  • src
  • main
  • java
java Directory Reference

Directories

directory org

Files

file module-info.java


JRemote: extensions/config/impl/xml/src/main/java/org/pcsoft/framework/jremote/ext/config/impl Directory Reference

  • extensions
  • config
  • impl
  • xml
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • impl
impl Directory Reference

Directories

directory xml


JRemote: commons/src/main Directory Reference

  • commons
  • src
  • main
main Directory Reference

Directories

directory java


JRemote: extensions/np/api/src/main/java/org/pcsoft/framework/jremote/ext/np Directory Reference

  • extensions
  • np
  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
np Directory Reference

Directories

directory api


JRemote: core/src/main/java/org/pcsoft/framework/jremote/core/internal/processor Directory Reference

  • core
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • internal
  • processor
processor Directory Reference

Files

file | KeepAliveProcessor.java
file | Processor.java


JRemote: core/src/main/java/org/pcsoft/framework/jremote/core/internal/type Directory Reference

  • core
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • internal
  • type
type Directory Reference

Directories

directory wrapper

Files

file MethodKey.java


JRemote: api/src/main/java/org/pcsoft/framework/jremote/api/internal Directory Reference

  • api
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • internal
internal Directory Reference

Files

file | RemoteMethod.java
file | RemoteService.java


JRemote: core/src/main/java/org/pcsoft/framework/jremote Directory Reference

  • core
  • src
  • main
  • java
  • org
  • pcsoft
  • framework
  • jremote
jremote Directory Reference

Directories

directory core


JRemote: commons/src/main/java/org Directory Reference

  • commons
  • src
  • main
  • java
  • org
org Directory Reference

Directories

directory pcsoft


JRemote: Main Page

JRemote Documentation


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • RemoteClient
  • ControlManager
org.pcsoft.framework.jremote.core.RemoteClient.ControlManager Member List

This is the complete list of members for org.pcsoft.framework.jremote.core.RemoteClient.ControlManager, including all inherited members.


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • api
  • Client
org.pcsoft.framework.jremote.ext.np.api.Client Member List

This is the complete list of members for org.pcsoft.framework.jremote.ext.np.api.Client, including all inherited members.

invokeRemote(Method method, Object...params) | org.pcsoft.framework.jremote.ext.np.api.Client
open(String host, int port) | org.pcsoft.framework.jremote.ext.np.api.Client


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • exception
  • JRemoteExecutionException
org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException, including all inherited members.

JRemoteException() (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(String message) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(String message, Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteExecutionException() (defined in org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException) | org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException
JRemoteExecutionException(String message) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException) | org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException
JRemoteExecutionException(String message, Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException) | org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException
JRemoteExecutionException(Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException) | org.pcsoft.framework.jremote.api.exception.JRemoteExecutionException


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • impl
  • fluent
  • RemoteFluentConfiguration
org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< T extends RemoteFluentConfiguration< T > Member List

This is the complete list of members for org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< T extends RemoteFluentConfiguration< T >, including all inherited members.

getHost() | org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< T extends RemoteFluentConfiguration< T >
getPort() | org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< T extends RemoteFluentConfiguration< T >
setHost(String host) (defined in org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< T extends RemoteFluentConfiguration< T >) | org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< T extends RemoteFluentConfiguration< T >
setPort(int port) (defined in org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< T extends RemoteFluentConfiguration< T >) | org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< T extends RemoteFluentConfiguration< T >
validate() | org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< T extends RemoteFluentConfiguration< T >


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • Push
org.pcsoft.framework.jremote.api.Push Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.Push, including all inherited members.

modelClass() | org.pcsoft.framework.jremote.api.Push
property() | org.pcsoft.framework.jremote.api.Push
type() default PushMethodType.Default | org.pcsoft.framework.jremote.api.Push


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • impl
  • fluent
  • ClientFluentConfiguration
org.pcsoft.framework.jremote.ext.config.impl.fluent.ClientFluentConfiguration Member List

This is the complete list of members for org.pcsoft.framework.jremote.ext.config.impl.fluent.ClientFluentConfiguration, including all inherited members.

create() (defined in org.pcsoft.framework.jremote.ext.config.impl.fluent.ClientFluentConfiguration) | org.pcsoft.framework.jremote.ext.config.impl.fluent.ClientFluentConfiguration | static
RemoteFluentConfiguration< ClientFluentConfiguration >.getHost() | org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< ClientFluentConfiguration > |
org::pcsoft::framework::jremote::ext::config::api::ClientConfiguration.getHost() | org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration |
getOwnPort() | org.pcsoft.framework.jremote.ext.config.impl.fluent.ClientFluentConfiguration |
RemoteFluentConfiguration< ClientFluentConfiguration >.getPort() | org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< ClientFluentConfiguration > |
org::pcsoft::framework::jremote::ext::config::api::ClientConfiguration.getPort() | org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration |
setHost(String host) (defined in org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< ClientFluentConfiguration >) | org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< ClientFluentConfiguration > |
setOwnPort(int ownPort) (defined in org.pcsoft.framework.jremote.ext.config.impl.fluent.ClientFluentConfiguration) | org.pcsoft.framework.jremote.ext.config.impl.fluent.ClientFluentConfiguration |
setPort(int port) (defined in org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< ClientFluentConfiguration >) | org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< ClientFluentConfiguration > |
validate() | org.pcsoft.framework.jremote.ext.config.impl.fluent.ClientFluentConfiguration |


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • RemoteServerBuilder
org.pcsoft.framework.jremote.core.RemoteServerBuilder Member List

This is the complete list of members for org.pcsoft.framework.jremote.core.RemoteServerBuilder, including all inherited members.

build() (defined in org.pcsoft.framework.jremote.core.RemoteServerBuilder) | org.pcsoft.framework.jremote.core.RemoteServerBuilder |
create(String host, int port) (defined in org.pcsoft.framework.jremote.core.RemoteServerBuilder) | org.pcsoft.framework.jremote.core.RemoteServerBuilder | static
create(String host, int port, Class<?extends NetworkProtocol > networkProtocolClass) (defined in org.pcsoft.framework.jremote.core.RemoteServerBuilder) | org.pcsoft.framework.jremote.core.RemoteServerBuilder | static
create(ServerConfiguration configuration) (defined in org.pcsoft.framework.jremote.core.RemoteServerBuilder) | org.pcsoft.framework.jremote.core.RemoteServerBuilder | static
create(ServerConfiguration configuration, Class<?extends NetworkProtocol > networkProtocolClass) (defined in org.pcsoft.framework.jremote.core.RemoteServerBuilder) | org.pcsoft.framework.jremote.core.RemoteServerBuilder | static
withEventClient(Class<?>...eventClientClasses) (defined in org.pcsoft.framework.jremote.core.RemoteServerBuilder) | org.pcsoft.framework.jremote.core.RemoteServerBuilder |
withPushClient(Class<?>...pushClientClasses) (defined in org.pcsoft.framework.jremote.core.RemoteServerBuilder) | org.pcsoft.framework.jremote.core.RemoteServerBuilder |
withPushModelData(Class<?>...pushModelDataClasses) (defined in org.pcsoft.framework.jremote.core.RemoteServerBuilder) | org.pcsoft.framework.jremote.core.RemoteServerBuilder |
withPushModelData(Object...pushModelDataList) (defined in org.pcsoft.framework.jremote.core.RemoteServerBuilder) | org.pcsoft.framework.jremote.core.RemoteServerBuilder |
withRemoteControlService(Class<?>...controlServiceImplClasses) (defined in org.pcsoft.framework.jremote.core.RemoteServerBuilder) | org.pcsoft.framework.jremote.core.RemoteServerBuilder |
withRemoteControlService(Object...controlServiceImpls) (defined in org.pcsoft.framework.jremote.core.RemoteServerBuilder) | org.pcsoft.framework.jremote.core.RemoteServerBuilder |


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • exception
  • JRemoteExtensionException
org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException, including all inherited members.

JRemoteException() (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(String message) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(String message, Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteExtensionException() (defined in org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException) | org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException
JRemoteExtensionException(String message) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException) | org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException
JRemoteExtensionException(String message, Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException) | org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException
JRemoteExtensionException(Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException) | org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • impl
  • xml
  • RemoteXmlConfiguration
org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< T extends RemoteConfigurationType > Member List

This is the complete list of members for org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< T extends RemoteConfigurationType >, including all inherited members.

getHost() | org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< T extends RemoteConfigurationType > |
getPort() | org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< T extends RemoteConfigurationType > |
load(T type) (defined in org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< T extends RemoteConfigurationType >) | org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< T extends RemoteConfigurationType > | protected
validate() | org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< T extends RemoteConfigurationType > |


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • exception
  • JRemoteException
org.pcsoft.framework.jremote.api.exception.JRemoteException Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.exception.JRemoteException, including all inherited members.

JRemoteException() (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(String message) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(String message, Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • commons
  • AnnotationUtils
org.pcsoft.framework.jremote.commons.AnnotationUtils Member List

This is the complete list of members for org.pcsoft.framework.jremote.commons.AnnotationUtils, including all inherited members.

getModelProperties(Class<?> clazz) (defined in org.pcsoft.framework.jremote.commons.AnnotationUtils) | org.pcsoft.framework.jremote.commons.AnnotationUtils | static
isModelProperty(Method method) (defined in org.pcsoft.framework.jremote.commons.AnnotationUtils) | org.pcsoft.framework.jremote.commons.AnnotationUtils | static
isRemoteMethod(Method method) (defined in org.pcsoft.framework.jremote.commons.AnnotationUtils) | org.pcsoft.framework.jremote.commons.AnnotationUtils | static
isRemoteModel(Class<?> clazz) (defined in org.pcsoft.framework.jremote.commons.AnnotationUtils) | org.pcsoft.framework.jremote.commons.AnnotationUtils | static
isRemoteService(Class<?> clazz) (defined in org.pcsoft.framework.jremote.commons.AnnotationUtils) | org.pcsoft.framework.jremote.commons.AnnotationUtils | static


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • api
  • Service
org.pcsoft.framework.jremote.ext.np.api.Service Member List

This is the complete list of members for org.pcsoft.framework.jremote.ext.np.api.Service, including all inherited members.

open(String host, int port) org.pcsoft.framework.jremote.ext.np.api.Service


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • api
  • exception
  • JRemoteNetworkProtocolException
org.pcsoft.framework.jremote.ext.np.api.exception.JRemoteNetworkProtocolException Member List

This is the complete list of members for org.pcsoft.framework.jremote.ext.np.api.exception.JRemoteNetworkProtocolException, including all inherited members.

JRemoteException() (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(String message) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(String message, Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteExtensionException() (defined in org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException) | org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException
JRemoteExtensionException(String message) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException) | org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException
JRemoteExtensionException(String message, Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException) | org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException
JRemoteExtensionException(Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException) | org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException
JRemoteNetworkProtocolException() (defined in org.pcsoft.framework.jremote.ext.np.api.exception.JRemoteNetworkProtocolException) | org.pcsoft.framework.jremote.ext.np.api.exception.JRemoteNetworkProtocolException
JRemoteNetworkProtocolException(String message) (defined in org.pcsoft.framework.jremote.ext.np.api.exception.JRemoteNetworkProtocolException) | org.pcsoft.framework.jremote.ext.np.api.exception.JRemoteNetworkProtocolException
JRemoteNetworkProtocolException(String message, Throwable cause) (defined in org.pcsoft.framework.jremote.ext.np.api.exception.JRemoteNetworkProtocolException) | org.pcsoft.framework.jremote.ext.np.api.exception.JRemoteNetworkProtocolException
JRemoteNetworkProtocolException(Throwable cause) (defined in org.pcsoft.framework.jremote.ext.np.api.exception.JRemoteNetworkProtocolException) | org.pcsoft.framework.jremote.ext.np.api.exception.JRemoteNetworkProtocolException


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • api
  • ServiceBase
org.pcsoft.framework.jremote.ext.np.api.ServiceBase Member List

This is the complete list of members for org.pcsoft.framework.jremote.ext.np.api.ServiceBase, including all inherited members.

open(String host, int port) | org.pcsoft.framework.jremote.ext.np.api.Service |
ServiceBase(Object serviceImplementation) (defined in org.pcsoft.framework.jremote.ext.np.api.ServiceBase) | org.pcsoft.framework.jremote.ext.np.api.ServiceBase |
serviceImplementation (defined in org.pcsoft.framework.jremote.ext.np.api.ServiceBase) | org.pcsoft.framework.jremote.ext.np.api.ServiceBase | protected


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • api
  • NetworkProtocol
org.pcsoft.framework.jremote.ext.np.api.NetworkProtocol Member List

This is the complete list of members for org.pcsoft.framework.jremote.ext.np.api.NetworkProtocol, including all inherited members.

createClient(Class<?> serviceClass) | org.pcsoft.framework.jremote.ext.np.api.NetworkProtocol
createService(Object serviceImplementation) | org.pcsoft.framework.jremote.ext.np.api.NetworkProtocol
getKeepAliveServiceClass() | org.pcsoft.framework.jremote.ext.np.api.NetworkProtocol
getRegistrationServiceClass() | org.pcsoft.framework.jremote.ext.np.api.NetworkProtocol


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • impl
  • prop
  • RemotePropertyConfiguration
org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration Member List

This is the complete list of members for org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration, including all inherited members.

getHost() | org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration |
getPort() | org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration |
load(Properties properties) (defined in org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration) | org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration | protected
validate() | org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration |


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • api
  • annotation
  • Registration
org.pcsoft.framework.jremote.ext.np.api.annotation.Registration Member List

This is the complete list of members for org.pcsoft.framework.jremote.ext.np.api.annotation.Registration, including all inherited members.

value() org.pcsoft.framework.jremote.ext.np.api.annotation.Registration


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • exception
  • JRemoteAnnotationException
org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException, including all inherited members.

JRemoteAnnotationException() (defined in org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException) | org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException
JRemoteAnnotationException(String message) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException) | org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException
JRemoteAnnotationException(String message, Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException) | org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException
JRemoteAnnotationException(Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException) | org.pcsoft.framework.jremote.api.exception.JRemoteAnnotationException
JRemoteException() (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(String message) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(String message, Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • commons
  • ReflectionUtils
org.pcsoft.framework.jremote.commons.ReflectionUtils Member List

This is the complete list of members for org.pcsoft.framework.jremote.commons.ReflectionUtils, including all inherited members.

findInterfaces(Class<?> clazz) (defined in org.pcsoft.framework.jremote.commons.ReflectionUtils) | org.pcsoft.framework.jremote.commons.ReflectionUtils | static
findInterfaces(Class<?> clazz, Predicate< Class<?>> validator) (defined in org.pcsoft.framework.jremote.commons.ReflectionUtils) | org.pcsoft.framework.jremote.commons.ReflectionUtils | static


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • impl
  • xml
  • ServerXmlConfiguration
org.pcsoft.framework.jremote.ext.config.impl.xml.ServerXmlConfiguration Member List

This is the complete list of members for org.pcsoft.framework.jremote.ext.config.impl.xml.ServerXmlConfiguration, including all inherited members.

RemoteXmlConfiguration< ServerConfigurationType >.getHost() | org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< ServerConfigurationType > |
org::pcsoft::framework::jremote::ext::config::api::ServerConfiguration.getHost() | org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration |
RemoteXmlConfiguration< ServerConfigurationType >.getPort() | org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< ServerConfigurationType > |
org::pcsoft::framework::jremote::ext::config::api::ServerConfiguration.getPort() | org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration |
load(T type) (defined in org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< ServerConfigurationType >) | org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< ServerConfigurationType > | protected
loadFrom(File file) (defined in org.pcsoft.framework.jremote.ext.config.impl.xml.ServerXmlConfiguration) | org.pcsoft.framework.jremote.ext.config.impl.xml.ServerXmlConfiguration | static
loadFrom(InputStream in) (defined in org.pcsoft.framework.jremote.ext.config.impl.xml.ServerXmlConfiguration) | org.pcsoft.framework.jremote.ext.config.impl.xml.ServerXmlConfiguration | static
loadFrom(ServerConfigurationType type) (defined in org.pcsoft.framework.jremote.ext.config.impl.xml.ServerXmlConfiguration) | org.pcsoft.framework.jremote.ext.config.impl.xml.ServerXmlConfiguration | static
RemoteXmlConfiguration< ServerConfigurationType >.validate() | org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< ServerConfigurationType > |
org::pcsoft::framework::jremote::ext::config::api::ServerConfiguration.validate() | org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration |


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • RemoteServer
org.pcsoft.framework.jremote.core.RemoteServer Member List

This is the complete list of members for org.pcsoft.framework.jremote.core.RemoteServer, including all inherited members.

addClientRegisteredListener(Consumer< Client > l) (defined in org.pcsoft.framework.jremote.core.RemoteServer) | org.pcsoft.framework.jremote.core.RemoteServer |
addClientUnregisteredListener(Consumer< Client > l) (defined in org.pcsoft.framework.jremote.core.RemoteServer) | org.pcsoft.framework.jremote.core.RemoteServer |
addLifecycleStateChangeListener(Consumer< LifecycleState > l) (defined in org.pcsoft.framework.jremote.core.RemoteBase< ServerState >) | org.pcsoft.framework.jremote.core.RemoteBase< ServerState > |
addStateChangeListener(Consumer< ServerState > l) (defined in org.pcsoft.framework.jremote.core.RemoteServer) | org.pcsoft.framework.jremote.core.RemoteServer |
close() (defined in org.pcsoft.framework.jremote.core.RemoteBase< ServerState >) | org.pcsoft.framework.jremote.core.RemoteBase< ServerState > |
doClose() (defined in org.pcsoft.framework.jremote.core.RemoteServer) | org.pcsoft.framework.jremote.core.RemoteServer |
doOpen() (defined in org.pcsoft.framework.jremote.core.RemoteServer) | org.pcsoft.framework.jremote.core.RemoteServer |
getBroadcast() (defined in org.pcsoft.framework.jremote.core.RemoteServer) | org.pcsoft.framework.jremote.core.RemoteServer |
getConnectedClients() (defined in org.pcsoft.framework.jremote.core.RemoteServer) | org.pcsoft.framework.jremote.core.RemoteServer |
getHost() (defined in org.pcsoft.framework.jremote.core.RemoteServer) | org.pcsoft.framework.jremote.core.RemoteServer |
getLifecycleState() (defined in org.pcsoft.framework.jremote.core.RemoteBase< ServerState >) | org.pcsoft.framework.jremote.core.RemoteBase< ServerState > |
getNetworkProtocolClass() (defined in org.pcsoft.framework.jremote.core.RemoteBase< ServerState >) | org.pcsoft.framework.jremote.core.RemoteBase< ServerState > |
getPort() (defined in org.pcsoft.framework.jremote.core.RemoteServer) | org.pcsoft.framework.jremote.core.RemoteServer |
getState() (defined in org.pcsoft.framework.jremote.core.RemoteServer) | org.pcsoft.framework.jremote.core.RemoteServer |
host (defined in org.pcsoft.framework.jremote.core.RemoteBase< ServerState >) | org.pcsoft.framework.jremote.core.RemoteBase< ServerState > | protected
networkProtocol (defined in org.pcsoft.framework.jremote.core.RemoteBase< ServerState >) | org.pcsoft.framework.jremote.core.RemoteBase< ServerState > | protected
open() (defined in org.pcsoft.framework.jremote.core.RemoteBase< ServerState >) | org.pcsoft.framework.jremote.core.RemoteBase< ServerState > |
port (defined in org.pcsoft.framework.jremote.core.RemoteBase< ServerState >) | org.pcsoft.framework.jremote.core.RemoteBase< ServerState > | protected
removeClientRegisteredListener(Consumer< Client > l) (defined in org.pcsoft.framework.jremote.core.RemoteServer) | org.pcsoft.framework.jremote.core.RemoteServer |
removeClientUnregisteredListener(Consumer< Client > l) (defined in org.pcsoft.framework.jremote.core.RemoteServer) | org.pcsoft.framework.jremote.core.RemoteServer |
removeLifecycleStateChangeListener(Consumer< LifecycleState > l) (defined in org.pcsoft.framework.jremote.core.RemoteBase< ServerState >) | org.pcsoft.framework.jremote.core.RemoteBase< ServerState > |
removeStateChangeListener(Consumer< ServerState > l) (defined in org.pcsoft.framework.jremote.core.RemoteServer) | org.pcsoft.framework.jremote.core.RemoteServer |


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • PushModelProperty
org.pcsoft.framework.jremote.api.PushModelProperty Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.PushModelProperty, including all inherited members.

value() org.pcsoft.framework.jremote.api.PushModelProperty


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • RemoteBuilder
org.pcsoft.framework.jremote.core.RemoteBuilder< T extends Remote > Member List

This is the complete list of members for org.pcsoft.framework.jremote.core.RemoteBuilder< T extends Remote >, including all inherited members.

build() (defined in org.pcsoft.framework.jremote.core.RemoteBuilder< T extends Remote >) org.pcsoft.framework.jremote.core.RemoteBuilder< T extends Remote >


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • RemoteClientBuilder
org.pcsoft.framework.jremote.core.RemoteClientBuilder Member List

This is the complete list of members for org.pcsoft.framework.jremote.core.RemoteClientBuilder, including all inherited members.

build() (defined in org.pcsoft.framework.jremote.core.RemoteClientBuilder) | org.pcsoft.framework.jremote.core.RemoteClientBuilder |
create(String host, int port, int ownPort) (defined in org.pcsoft.framework.jremote.core.RemoteClientBuilder) | org.pcsoft.framework.jremote.core.RemoteClientBuilder | static
create(String host, int port, int ownPort, Class<?extends NetworkProtocol > networkProtocolClass) (defined in org.pcsoft.framework.jremote.core.RemoteClientBuilder) | org.pcsoft.framework.jremote.core.RemoteClientBuilder | static
create(ClientConfiguration configuration) (defined in org.pcsoft.framework.jremote.core.RemoteClientBuilder) | org.pcsoft.framework.jremote.core.RemoteClientBuilder | static
create(ClientConfiguration configuration, Class<?extends NetworkProtocol > networkProtocolClass) (defined in org.pcsoft.framework.jremote.core.RemoteClientBuilder) | org.pcsoft.framework.jremote.core.RemoteClientBuilder | static
withRemoteControlClient(Class<?>...controlClientClasses) (defined in org.pcsoft.framework.jremote.core.RemoteClientBuilder) | org.pcsoft.framework.jremote.core.RemoteClientBuilder |
withRemoteEventReceiver(Class<?>...eventReceiverClasses) (defined in org.pcsoft.framework.jremote.core.RemoteClientBuilder) | org.pcsoft.framework.jremote.core.RemoteClientBuilder |
withRemoteEventService(Class<?>...eventServiceClasses) (defined in org.pcsoft.framework.jremote.core.RemoteClientBuilder) | org.pcsoft.framework.jremote.core.RemoteClientBuilder |
withRemotePushModel(Class<?>...pushModelClasses) (defined in org.pcsoft.framework.jremote.core.RemoteClientBuilder) | org.pcsoft.framework.jremote.core.RemoteClientBuilder |
withRemotePushObserver(Class<?>...pushObserverClasses) (defined in org.pcsoft.framework.jremote.core.RemoteClientBuilder) | org.pcsoft.framework.jremote.core.RemoteClientBuilder |
withRemotePushService(Class<?>...pushServiceClasses) (defined in org.pcsoft.framework.jremote.core.RemoteClientBuilder) | org.pcsoft.framework.jremote.core.RemoteClientBuilder |


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • type
  • PushMethodType
org.pcsoft.framework.jremote.api.type.PushMethodType Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.type.PushMethodType, including all inherited members.

Default | org.pcsoft.framework.jremote.api.type.PushMethodType
SingleListItem | org.pcsoft.framework.jremote.api.type.PushMethodType


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • type
  • ObserverListenerType
org.pcsoft.framework.jremote.api.type.ObserverListenerType Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.type.ObserverListenerType, including all inherited members.

Add | org.pcsoft.framework.jremote.api.type.ObserverListenerType
AutoDetection | org.pcsoft.framework.jremote.api.type.ObserverListenerType
Remove | org.pcsoft.framework.jremote.api.type.ObserverListenerType


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • impl
  • xml
  • ClientXmlConfiguration
org.pcsoft.framework.jremote.ext.config.impl.xml.ClientXmlConfiguration Member List

This is the complete list of members for org.pcsoft.framework.jremote.ext.config.impl.xml.ClientXmlConfiguration, including all inherited members.

RemoteXmlConfiguration< ClientConfigurationType >.getHost() | org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< ClientConfigurationType > |
org::pcsoft::framework::jremote::ext::config::api::ClientConfiguration.getHost() | org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration |
getOwnPort() | org.pcsoft.framework.jremote.ext.config.impl.xml.ClientXmlConfiguration |
RemoteXmlConfiguration< ClientConfigurationType >.getPort() | org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< ClientConfigurationType > |
org::pcsoft::framework::jremote::ext::config::api::ClientConfiguration.getPort() | org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration |
load(ClientConfigurationType type) (defined in org.pcsoft.framework.jremote.ext.config.impl.xml.ClientXmlConfiguration) | org.pcsoft.framework.jremote.ext.config.impl.xml.ClientXmlConfiguration | protected
load(T type) (defined in org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< ClientConfigurationType >) | org.pcsoft.framework.jremote.ext.config.impl.xml.RemoteXmlConfiguration< ClientConfigurationType > | protected
loadFrom(File file) (defined in org.pcsoft.framework.jremote.ext.config.impl.xml.ClientXmlConfiguration) | org.pcsoft.framework.jremote.ext.config.impl.xml.ClientXmlConfiguration | static
loadFrom(InputStream in) (defined in org.pcsoft.framework.jremote.ext.config.impl.xml.ClientXmlConfiguration) | org.pcsoft.framework.jremote.ext.config.impl.xml.ClientXmlConfiguration | static
loadFrom(ClientConfigurationType type) (defined in org.pcsoft.framework.jremote.ext.config.impl.xml.ClientXmlConfiguration) | org.pcsoft.framework.jremote.ext.config.impl.xml.ClientXmlConfiguration | static
validate() | org.pcsoft.framework.jremote.ext.config.impl.xml.ClientXmlConfiguration |


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • Client
org.pcsoft.framework.jremote.core.Client Member List

This is the complete list of members for org.pcsoft.framework.jremote.core.Client, including all inherited members.

Client(String host, int port) (defined in org.pcsoft.framework.jremote.core.Client) | org.pcsoft.framework.jremote.core.Client
getHost() (defined in org.pcsoft.framework.jremote.core.Client) | org.pcsoft.framework.jremote.core.Client
getPort() (defined in org.pcsoft.framework.jremote.core.Client) | org.pcsoft.framework.jremote.core.Client


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • PushObserverListener
org.pcsoft.framework.jremote.api.PushObserverListener Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.PushObserverListener, including all inherited members.

listenerType() default ObserverListenerType.AutoDetection | org.pcsoft.framework.jremote.api.PushObserverListener
modelClass() | org.pcsoft.framework.jremote.api.PushObserverListener
property() | org.pcsoft.framework.jremote.api.PushObserverListener


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • type
  • PushChangedListener
org.pcsoft.framework.jremote.api.type.PushChangedListener Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.type.PushChangedListener, including all inherited members.

onChange() org.pcsoft.framework.jremote.api.type.PushChangedListener


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • RemoteServer
  • BroadcastManager
org.pcsoft.framework.jremote.core.RemoteServer.BroadcastManager Member List

This is the complete list of members for org.pcsoft.framework.jremote.core.RemoteServer.BroadcastManager, including all inherited members.


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • impl
  • rmi
  • RmiProtocol
org.pcsoft.framework.jremote.ext.np.impl.rmi.RmiProtocol Member List

This is the complete list of members for org.pcsoft.framework.jremote.ext.np.impl.rmi.RmiProtocol, including all inherited members.

createClient(Class<?> serviceClass) | org.pcsoft.framework.jremote.ext.np.impl.rmi.RmiProtocol
createService(Object serviceImplementation) | org.pcsoft.framework.jremote.ext.np.impl.rmi.RmiProtocol
getKeepAliveServiceClass() | org.pcsoft.framework.jremote.ext.np.impl.rmi.RmiProtocol
getRegistrationServiceClass() | org.pcsoft.framework.jremote.ext.np.impl.rmi.RmiProtocol


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • type
  • PushItemUpdate
org.pcsoft.framework.jremote.api.type.PushItemUpdate Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.type.PushItemUpdate, including all inherited members.

Add (defined in org.pcsoft.framework.jremote.api.type.PushItemUpdate) | org.pcsoft.framework.jremote.api.type.PushItemUpdate
Remove (defined in org.pcsoft.framework.jremote.api.type.PushItemUpdate) | org.pcsoft.framework.jremote.api.type.PushItemUpdate
Update (defined in org.pcsoft.framework.jremote.api.type.PushItemUpdate) | org.pcsoft.framework.jremote.api.type.PushItemUpdate


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • Event
org.pcsoft.framework.jremote.api.Event Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.Event, including all inherited members.

event() | org.pcsoft.framework.jremote.api.Event
eventClass() | org.pcsoft.framework.jremote.api.Event


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • impl
  • fluent
  • ServerFluentConfiguration
org.pcsoft.framework.jremote.ext.config.impl.fluent.ServerFluentConfiguration Member List

This is the complete list of members for org.pcsoft.framework.jremote.ext.config.impl.fluent.ServerFluentConfiguration, including all inherited members.

create() (defined in org.pcsoft.framework.jremote.ext.config.impl.fluent.ServerFluentConfiguration) | org.pcsoft.framework.jremote.ext.config.impl.fluent.ServerFluentConfiguration | static
RemoteFluentConfiguration< ServerFluentConfiguration >.getHost() | org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< ServerFluentConfiguration > |
org::pcsoft::framework::jremote::ext::config::api::ServerConfiguration.getHost() | org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration |
RemoteFluentConfiguration< ServerFluentConfiguration >.getPort() | org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< ServerFluentConfiguration > |
org::pcsoft::framework::jremote::ext::config::api::ServerConfiguration.getPort() | org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration |
setHost(String host) (defined in org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< ServerFluentConfiguration >) | org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< ServerFluentConfiguration > |
setPort(int port) (defined in org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< ServerFluentConfiguration >) | org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< ServerFluentConfiguration > |
RemoteFluentConfiguration< ServerFluentConfiguration >.validate() | org.pcsoft.framework.jremote.ext.config.impl.fluent.RemoteFluentConfiguration< ServerFluentConfiguration > |
org::pcsoft::framework::jremote::ext::config::api::ServerConfiguration.validate() | org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration |


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • impl
  • prop
  • ClientPropertyConfiguration
org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration Member List

This is the complete list of members for org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration, including all inherited members.

getHost() | org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration |
getOwnPort() | org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration |
getPort() | org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration |
load(Properties properties) (defined in org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration) | org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration | protected
loadFrom(File file) (defined in org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration) | org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration | static
loadFrom(InputStream in) (defined in org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration) | org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration | static
loadFrom(Properties properties) (defined in org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration) | org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration | static
validate() | org.pcsoft.framework.jremote.ext.config.impl.prop.ClientPropertyConfiguration |


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • type
  • EventReceivedListener
org.pcsoft.framework.jremote.api.type.EventReceivedListener< T > Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.type.EventReceivedListener< T >, including all inherited members.

onChange(T value) org.pcsoft.framework.jremote.api.type.EventReceivedListener< T >


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • RemoteClient
org.pcsoft.framework.jremote.core.RemoteClient Member List

This is the complete list of members for org.pcsoft.framework.jremote.core.RemoteClient, including all inherited members.

addLifecycleStateChangeListener(Consumer< LifecycleState > l) (defined in org.pcsoft.framework.jremote.core.RemoteBase< ClientState >) | org.pcsoft.framework.jremote.core.RemoteBase< ClientState > |
addStateChangeListener(Consumer< ClientState > l) (defined in org.pcsoft.framework.jremote.core.RemoteClient) | org.pcsoft.framework.jremote.core.RemoteClient |
close() (defined in org.pcsoft.framework.jremote.core.RemoteBase< ClientState >) | org.pcsoft.framework.jremote.core.RemoteBase< ClientState > |
doClose() (defined in org.pcsoft.framework.jremote.core.RemoteClient) | org.pcsoft.framework.jremote.core.RemoteClient |
doOpen() (defined in org.pcsoft.framework.jremote.core.RemoteClient) | org.pcsoft.framework.jremote.core.RemoteClient |
getControl() (defined in org.pcsoft.framework.jremote.core.RemoteClient) | org.pcsoft.framework.jremote.core.RemoteClient |
getData() (defined in org.pcsoft.framework.jremote.core.RemoteClient) | org.pcsoft.framework.jremote.core.RemoteClient |
getHost() (defined in org.pcsoft.framework.jremote.core.RemoteClient) | org.pcsoft.framework.jremote.core.RemoteClient |
getLifecycleState() (defined in org.pcsoft.framework.jremote.core.RemoteBase< ClientState >) | org.pcsoft.framework.jremote.core.RemoteBase< ClientState > |
getNetworkProtocolClass() (defined in org.pcsoft.framework.jremote.core.RemoteBase< ClientState >) | org.pcsoft.framework.jremote.core.RemoteBase< ClientState > |
getOwnPort() (defined in org.pcsoft.framework.jremote.core.RemoteClient) | org.pcsoft.framework.jremote.core.RemoteClient |
getPort() (defined in org.pcsoft.framework.jremote.core.RemoteClient) | org.pcsoft.framework.jremote.core.RemoteClient |
getState() (defined in org.pcsoft.framework.jremote.core.RemoteClient) | org.pcsoft.framework.jremote.core.RemoteClient |
getUuid() (defined in org.pcsoft.framework.jremote.core.RemoteClient) | org.pcsoft.framework.jremote.core.RemoteClient |
host (defined in org.pcsoft.framework.jremote.core.RemoteBase< ClientState >) | org.pcsoft.framework.jremote.core.RemoteBase< ClientState > | protected
networkProtocol (defined in org.pcsoft.framework.jremote.core.RemoteBase< ClientState >) | org.pcsoft.framework.jremote.core.RemoteBase< ClientState > | protected
open() (defined in org.pcsoft.framework.jremote.core.RemoteBase< ClientState >) | org.pcsoft.framework.jremote.core.RemoteBase< ClientState > |
port (defined in org.pcsoft.framework.jremote.core.RemoteBase< ClientState >) | org.pcsoft.framework.jremote.core.RemoteBase< ClientState > | protected
removeLifecycleStateChangeListener(Consumer< LifecycleState > l) (defined in org.pcsoft.framework.jremote.core.RemoteBase< ClientState >) | org.pcsoft.framework.jremote.core.RemoteBase< ClientState > |
removeStateChangeListener(Consumer< ClientState > l) (defined in org.pcsoft.framework.jremote.core.RemoteClient) | org.pcsoft.framework.jremote.core.RemoteClient |


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • api
  • ClientConfiguration
org.pcsoft.framework.jremote.ext.config.api.ClientConfiguration Member List

This is the complete list of members for org.pcsoft.framework.jremote.ext.config.api.ClientConfiguration, including all inherited members.

getHost() | org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration
getOwnPort() | org.pcsoft.framework.jremote.ext.config.api.ClientConfiguration
getPort() | org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration
validate() | org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • api
  • ServerConfiguration
org.pcsoft.framework.jremote.ext.config.api.ServerConfiguration Member List

This is the complete list of members for org.pcsoft.framework.jremote.ext.config.api.ServerConfiguration, including all inherited members.

getHost() | org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration
getPort() | org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration
validate() | org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • Remote
org.pcsoft.framework.jremote.core.Remote< S extends State > Member List

This is the complete list of members for org.pcsoft.framework.jremote.core.Remote< S extends State >, including all inherited members.

addLifecycleStateChangeListener(Consumer< LifecycleState > l) (defined in org.pcsoft.framework.jremote.core.Remote< S extends State >) | org.pcsoft.framework.jremote.core.Remote< S extends State >
addStateChangeListener(Consumer< S > l) (defined in org.pcsoft.framework.jremote.core.Remote< S extends State >) | org.pcsoft.framework.jremote.core.Remote< S extends State >
getHost() | org.pcsoft.framework.jremote.core.Remote< S extends State >
getLifecycleState() | org.pcsoft.framework.jremote.core.Remote< S extends State >
getNetworkProtocolClass() | org.pcsoft.framework.jremote.core.Remote< S extends State >
getPort() | org.pcsoft.framework.jremote.core.Remote< S extends State >
getState() | org.pcsoft.framework.jremote.core.Remote< S extends State >
open() | org.pcsoft.framework.jremote.core.Remote< S extends State >
removeLifecycleStateChangeListener(Consumer< LifecycleState > l) (defined in org.pcsoft.framework.jremote.core.Remote< S extends State >) | org.pcsoft.framework.jremote.core.Remote< S extends State >
removeStateChangeListener(Consumer< S > l) (defined in org.pcsoft.framework.jremote.core.Remote< S extends State >) | org.pcsoft.framework.jremote.core.Remote< S extends State >


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • ClientState
org.pcsoft.framework.jremote.core.ClientState Member List

This is the complete list of members for org.pcsoft.framework.jremote.core.ClientState, including all inherited members.

Connected (defined in org.pcsoft.framework.jremote.core.ClientState) | org.pcsoft.framework.jremote.core.ClientState
Disconnected (defined in org.pcsoft.framework.jremote.core.ClientState) | org.pcsoft.framework.jremote.core.ClientState
Unknown (defined in org.pcsoft.framework.jremote.core.ClientState) | org.pcsoft.framework.jremote.core.ClientState


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • api
  • RemoteConfiguration
org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration Member List

This is the complete list of members for org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration, including all inherited members.

getHost() | org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration
getPort() | org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration
validate() | org.pcsoft.framework.jremote.ext.config.api.RemoteConfiguration


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • impl
  • prop
  • ServerPropertyConfiguration
org.pcsoft.framework.jremote.ext.config.impl.prop.ServerPropertyConfiguration Member List

This is the complete list of members for org.pcsoft.framework.jremote.ext.config.impl.prop.ServerPropertyConfiguration, including all inherited members.

getHost() | org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration |
getPort() | org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration |
load(Properties properties) (defined in org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration) | org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration | protected
loadFrom(File file) (defined in org.pcsoft.framework.jremote.ext.config.impl.prop.ServerPropertyConfiguration) | org.pcsoft.framework.jremote.ext.config.impl.prop.ServerPropertyConfiguration | static
loadFrom(InputStream in) (defined in org.pcsoft.framework.jremote.ext.config.impl.prop.ServerPropertyConfiguration) | org.pcsoft.framework.jremote.ext.config.impl.prop.ServerPropertyConfiguration | static
loadFrom(Properties properties) (defined in org.pcsoft.framework.jremote.ext.config.impl.prop.ServerPropertyConfiguration) | org.pcsoft.framework.jremote.ext.config.impl.prop.ServerPropertyConfiguration | static
validate() | org.pcsoft.framework.jremote.ext.config.impl.prop.RemotePropertyConfiguration |


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • LifecycleState
org.pcsoft.framework.jremote.core.LifecycleState Member List

This is the complete list of members for org.pcsoft.framework.jremote.core.LifecycleState, including all inherited members.

Closed | org.pcsoft.framework.jremote.core.LifecycleState
Created | org.pcsoft.framework.jremote.core.LifecycleState
Opened | org.pcsoft.framework.jremote.core.LifecycleState


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • api
  • ClientBase
org.pcsoft.framework.jremote.ext.np.api.ClientBase Member List

This is the complete list of members for org.pcsoft.framework.jremote.ext.np.api.ClientBase, including all inherited members.

ClientBase(Class<?> serviceClass) (defined in org.pcsoft.framework.jremote.ext.np.api.ClientBase) | org.pcsoft.framework.jremote.ext.np.api.ClientBase |
invokeRemote(Method method, Object...params) | org.pcsoft.framework.jremote.ext.np.api.Client |
open(String host, int port) | org.pcsoft.framework.jremote.ext.np.api.Client |
serviceClass (defined in org.pcsoft.framework.jremote.ext.np.api.ClientBase) | org.pcsoft.framework.jremote.ext.np.api.ClientBase | protected


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • api
  • EventReceiverListener
org.pcsoft.framework.jremote.api.EventReceiverListener Member List

This is the complete list of members for org.pcsoft.framework.jremote.api.EventReceiverListener, including all inherited members.

listenerType() default ObserverListenerType.AutoDetection | org.pcsoft.framework.jremote.api.EventReceiverListener
value() | org.pcsoft.framework.jremote.api.EventReceiverListener


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • RemoteClient
  • DataManager
org.pcsoft.framework.jremote.core.RemoteClient.DataManager Member List

This is the complete list of members for org.pcsoft.framework.jremote.core.RemoteClient.DataManager, including all inherited members.


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • ServerState
org.pcsoft.framework.jremote.core.ServerState Member List

This is the complete list of members for org.pcsoft.framework.jremote.core.ServerState, including all inherited members.

Closed (defined in org.pcsoft.framework.jremote.core.ServerState) | org.pcsoft.framework.jremote.core.ServerState
Opened (defined in org.pcsoft.framework.jremote.core.ServerState) | org.pcsoft.framework.jremote.core.ServerState


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • np
  • api
  • annotation
  • Registration
  • RegistrationType
org.pcsoft.framework.jremote.ext.np.api.annotation.Registration.RegistrationType Member List

This is the complete list of members for org.pcsoft.framework.jremote.ext.np.api.annotation.Registration.RegistrationType, including all inherited members.

Register | org.pcsoft.framework.jremote.ext.np.api.annotation.Registration.RegistrationType
Unregister | org.pcsoft.framework.jremote.ext.np.api.annotation.Registration.RegistrationType


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • core
  • RemoteBase
org.pcsoft.framework.jremote.core.RemoteBase< S extends State > Member List

This is the complete list of members for org.pcsoft.framework.jremote.core.RemoteBase< S extends State >, including all inherited members.

addLifecycleStateChangeListener(Consumer< LifecycleState > l) (defined in org.pcsoft.framework.jremote.core.RemoteBase< S extends State >) | org.pcsoft.framework.jremote.core.RemoteBase< S extends State > |
addStateChangeListener(Consumer< S > l) (defined in org.pcsoft.framework.jremote.core.Remote< S >) | org.pcsoft.framework.jremote.core.Remote< S > |
close() (defined in org.pcsoft.framework.jremote.core.RemoteBase< S extends State >) | org.pcsoft.framework.jremote.core.RemoteBase< S extends State > |
doClose() (defined in org.pcsoft.framework.jremote.core.RemoteBase< S extends State >) | org.pcsoft.framework.jremote.core.RemoteBase< S extends State > | protected
doOpen() (defined in org.pcsoft.framework.jremote.core.RemoteBase< S extends State >) | org.pcsoft.framework.jremote.core.RemoteBase< S extends State > | protected
getHost() | org.pcsoft.framework.jremote.core.Remote< S > |
getLifecycleState() (defined in org.pcsoft.framework.jremote.core.RemoteBase< S extends State >) | org.pcsoft.framework.jremote.core.RemoteBase< S extends State > |
getNetworkProtocolClass() (defined in org.pcsoft.framework.jremote.core.RemoteBase< S extends State >) | org.pcsoft.framework.jremote.core.RemoteBase< S extends State > |
getPort() | org.pcsoft.framework.jremote.core.Remote< S > |
getState() | org.pcsoft.framework.jremote.core.Remote< S > |
host (defined in org.pcsoft.framework.jremote.core.RemoteBase< S extends State >) | org.pcsoft.framework.jremote.core.RemoteBase< S extends State > | protected
networkProtocol (defined in org.pcsoft.framework.jremote.core.RemoteBase< S extends State >) | org.pcsoft.framework.jremote.core.RemoteBase< S extends State > | protected
open() (defined in org.pcsoft.framework.jremote.core.RemoteBase< S extends State >) | org.pcsoft.framework.jremote.core.RemoteBase< S extends State > |
port (defined in org.pcsoft.framework.jremote.core.RemoteBase< S extends State >) | org.pcsoft.framework.jremote.core.RemoteBase< S extends State > | protected
removeLifecycleStateChangeListener(Consumer< LifecycleState > l) (defined in org.pcsoft.framework.jremote.core.RemoteBase< S extends State >) | org.pcsoft.framework.jremote.core.RemoteBase< S extends State > |
removeStateChangeListener(Consumer< S > l) (defined in org.pcsoft.framework.jremote.core.Remote< S >) | org.pcsoft.framework.jremote.core.Remote< S > |


JRemote: Member List

  • Class Members
  • org
  • pcsoft
  • framework
  • jremote
  • ext
  • config
  • api
  • exception
  • JRemoteConfigurationException
org.pcsoft.framework.jremote.ext.config.api.exception.JRemoteConfigurationException Member List

This is the complete list of members for org.pcsoft.framework.jremote.ext.config.api.exception.JRemoteConfigurationException, including all inherited members.

JRemoteConfigurationException() (defined in org.pcsoft.framework.jremote.ext.config.api.exception.JRemoteConfigurationException) | org.pcsoft.framework.jremote.ext.config.api.exception.JRemoteConfigurationException
JRemoteConfigurationException(String message) (defined in org.pcsoft.framework.jremote.ext.config.api.exception.JRemoteConfigurationException) | org.pcsoft.framework.jremote.ext.config.api.exception.JRemoteConfigurationException
JRemoteConfigurationException(String message, Throwable cause) (defined in org.pcsoft.framework.jremote.ext.config.api.exception.JRemoteConfigurationException) | org.pcsoft.framework.jremote.ext.config.api.exception.JRemoteConfigurationException
JRemoteConfigurationException(Throwable cause) (defined in org.pcsoft.framework.jremote.ext.config.api.exception.JRemoteConfigurationException) | org.pcsoft.framework.jremote.ext.config.api.exception.JRemoteConfigurationException
JRemoteException() (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(String message) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(String message, Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteException(Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteException) | org.pcsoft.framework.jremote.api.exception.JRemoteException
JRemoteExtensionException() (defined in org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException) | org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException
JRemoteExtensionException(String message) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException) | org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException
JRemoteExtensionException(String message, Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException) | org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException
JRemoteExtensionException(Throwable cause) (defined in org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException) | org.pcsoft.framework.jremote.api.exception.JRemoteExtensionException